-   Puppy (
-   -   From Puppy 1 to 2 (

eurfyl 07-03-2006 06:58 AM

From Puppy 1 to 2
Hi all,

I read on the following quote:

"If you want to upgrade from Puppy1, that is, you have a 'pup001' file somewhere, there is a script for importing from it. Open a terminal window and type "importfrompuppy1". This script is pretty bare-bones and I would like help with improving it."

I tried this and after selecting the partition in which the puppy001 resides (hda - compact flash in my case), it says that I have chosen /dev/hda1|msdos and says that no puppyxxx file was found.
Why is this?

Any clues will be much appreciated...

b0uncer 07-03-2006 08:05 AM

I guess that was a typing error, you first wrote about pup001 and a bit downwards it became puppy001.

In which directory does it try to locate the file in? If the file is not in the location where the script is looking for it, you need to copy or link or move it to that folder first..

I need to get my hands down to Puppy Linux a bit before I can help me that sounds like the script is just searching from a wrong place, that's all I get. Another thing: if Puppy is, like I believe, a small distribution and you've "installed" it on a removable media, then have you mounted your harddisk on Puppy? I think you cannot use hda1 before it's mounted.

EDIT: mounting, of course, works from the console as follows:

1) create a directory where you want to mount the disk, like /mnt/hda1
2) usually you need to be root to do this, unless you've got an fstab entry that permits you mounting, so issue su command
3) then try to mount your harddisk with:

mount /dev/hda1 /mnt/hda1
and if it complains about the fs type, give it one; either vfat if it's FAT32 drive, like Win98, or ntfs if it's WinXP for example:

mount -t vfat /dev/hda1 /mnt/hda1

eurfyl 07-11-2006 09:09 AM

Tried it on usb stick with vfat format and puppy001 was recognised.
Didn't with DOS format.

Job done

All times are GMT -5. The time now is 12:01 PM.