-   Puppy (
-   -   chmod and subdirectorys (

stripe21 01-27-2008 06:25 PM

chmod and subdirectorys
im using puppy 3, and im am using this to access a freinds ubuntu system that is down. I can access the HDD's that he has, but i can not copy off all of his home directory documents and files.

I have tried

chmod 777 /mnt/sda1/home/tony

but this didn't work. So i looked at the chmod --help and see that i should of been using

chmod rwxXst //mnt/sda1/home/tony

This seamed to work better...... BUT when it came to accessing the subdirectorys it said that i couldn't as there was not right too this. What am i doing wong?
I would like to change ALL the files and directorys in the /home/tony/*.* open them up so i can copy them to another drive.

dive 01-27-2008 06:28 PM

The switch for recursion is -R

stripe21 01-27-2008 06:31 PM

many thanks for getting back to me so fast...

So is the command line then

chmod -R //mnt/sda1/home/tony


chmod -RwxXst //mnt/sda1/home/tony

dive 01-27-2008 06:36 PM

chmod -R +/-wxrs

but you would probably only need

chmod -R +xwr /mnt/sda1/tony/*

stripe21 01-27-2008 06:48 PM

ok it sounded like it did more as in the HDD spun for about 20 secs. wheni tried coping over and still got

Failed to predserve ownership
First ~':Operation not permitted

dose this mean thats it still a file permissions issue

dive 01-27-2008 07:11 PM

Best thing is cd into the dir and do a 'ls -l' on some of the files. What command are you using to copy? scp or cp?
Please write the complete command here with the error.

All times are GMT -5. The time now is 11:55 PM.