-   Puppy (
-   -   c/c++ on puppy (making gcc work) (

tuskotheelephant 01-13-2013 03:06 AM

c/c++ on puppy (making gcc work)
ok so im running puppy on an antique compaq that was probably made by da vinci. version is 5.4 (precise).

so im using this old piece of sh** because i no longer have my baby (an asus laptop that was by no means cheap) and i cant go without a computer. i NEED to continue expanding my knowledge of programming concepts which is hard to do without a functioning compiler.

when i installed puppy i didnt realize that it didnt come with gcc (or if it does it doesnt work) so i went on the hunt. i found devx and proceeded to follow the instructions to install it...

first i tried using bash commands to install the sfs. for some reason it didnt work. claiming something about invalid path (i tried every variation i know of where to find my hd (sda3))

so i fell back on the wizard that popped up saying that it can install the sfs for me... it gave me something about being experimental in pupmode=2 (any info on what pupmode is would be helpful) so i said whatever and continued... when it finished it said some files were not extracted... i had no clue what to do with them so i continued. so i tested it on a simple hello world code

it said there were missing shared librarys (which im sure would be found in the files that WERE NOT extracted *sigh*)

so my question to you all is this:

does anyone know how to (from a clean full install) get gcc and g++ working correctly? i would appreciate if you dont shuffle me off to some external link that doesnt give me very much useful info. i want ot know the steps YOU took (or know to take) to get a clean, polished, and shiney version of some form of c/c++ compiler working in puppy. libs included

it would also (most likely) fix the problem to know what pupmode=2 means and how to change it.


Snark1994 01-14-2013 04:29 AM and (scroll down to the bottom section, on C++, on the second link) seem to be fairly straightforward.

They are using your SFS method - if you try running the commands given on the link and they don't work (make sure you copy & paste from the website so you don't make any typos) then post the exact command you ran here, and the exact error message, and we may be able to work out what's going wrong.

tuskotheelephant 01-15-2013 03:12 PM

Installing devx (gcc/g++) on precise puppy 5.4 full install
ok so thanks much for the assitance. the links provided useful (however not conclusive) information. Since posting i have managed to work out the problem.

so to answer my own question for the sake of solving the thread.

when using precise puppy (v5.4) as a full install(not frugal ie: pupmode=2)

and when attempting to obtain a c/c++ compiler

step 1: run the puppy package manager
step 2: at the bottom there is a buttin to obtain .sfs files from the official repository, click it.
step 3: select the devx radio button
step 4: select the desired server to download the files from (i recommend you text the URL's first. this will download the .sfs file for the devx package (which includes gcc and g++) it may or may not automatically install.
step 5: if SFS Load does not start on its own- navigate to the folder where the file was downloaded to (for me it was /) and left click it.
step 6: you will be presented with a dialog asking if you want to view the files or install them click install.
step 7: the installer will claim that it is experimental in pupmode=2 (scroll down for more information). do not worry about this as you have obtained the sfs file from the puppy repository and it DOES WORK.
step 7: wait... when the installer is finished it will claim that some files may not have been copied. although this is true it only does so because the files are already installed. there is no need to copy them.

testing to make sure it worked:
open a bash prompt and type
if it says "fatal error: no input files" then the install worked
if it says something like invalid command, it didnt work and i appologize but i dont know what the problem is

about pupmod=2
all this means is that your running a full install, any other pupmode is most likly running in frugal or live. there is no way to chage this without a full reinstallation

where i went wrong: i assumed that the dialog about some files not being copied meant it didnt work. after further investigation i realized that the files didnt need to be installed because they were already there. i tested it on some code and wham bam shazam it worked

All times are GMT -5. The time now is 12:52 PM.