-   Puppy (
-   -   5.1.2.sfs not found (

vanaya 07-10-2011 01:58 AM

5.1.2.sfs not found
Hi all, I'm new to linux and need some help. I did do a search but came up empty, and apologize if it has been already discussed. Please guide me in the right direction.

I am trying to install wary 5.1.2 on my spare 600e Thinkpad. I choose this distro as from searches it works well with my old equipment and the pci wireless card I would like to use. As stated in the title, after the splash screen of puppy I am greeting to the option of booting into normal, basic, and advanced. I have chosen each one and all give the same error - puppy_wary_5.1.2.sfs not found. Dropping out to initial-ramdisk console...

I have confirmed a correct download with md5sum.

Any suggestions??

thanks in advance!!

8-bit 07-11-2011 12:45 AM

Is this booting from a CD, or from the hard drive?
If it is from the hard drive, did you do a full or a frugal install?
If you are booting with Grub, can you post your /boot/grub/menu.lst?
It could just be a simple thing of adding a kernel parameter to get the sfs file found.

vanaya 07-11-2011 10:36 AM

I am booting from cd, I downloaded and burned the .iso.

8-bit 07-13-2011 02:04 AM

You might try adding a parameter to the kernel line when you boot. You do this by typing "puppy" to stop the boot process long enough so you can enter that parameter. Try "puppy acpi=noacpi" or "puppy pci=nopci". There are others and pressing the F1 key should show you available boot parameters.

Karl Godt 07-13-2011 03:13 PM


Developer IBM (19922005), Lenovo (2005)
Type Laptop
Release date 1992

Into puppy's past
may be of interest .

To get it going you may need some kernel-parameters.txt.

The ACPI_BLACKLIST_YEAR is for Puppy kernel 33.2=2001 , 31.14=2001 , 30.5=2002 , 25.16=2002 .

If your *pad is that old , try "acpi=force" .

If you can boot other linux on it , try run

dmidecode | grep -i -n -E 'acpi|apm'
from the shell .

Other usefull commands to get some basic info in the initramdisk are

df && mount && free && lsmod && cat /tmp/*

busybox && ls /bin/* && ls /sbin/*
would show available commands .

To learn more about linux commands , google "man df manual page" .

Short answer for short supply of info .

vanaya 07-13-2011 09:26 PM

Thanks, I will try the puppy acpi=force. I have tried a different distro (Fiesty Fawn) with almost the same problem. I tried following this guide with no success.

What other info would be helpful to provide??

I will post back in a few moments with the =force suggestion.

vanaya 07-13-2011 11:35 PM

Hooray!! Thanks Karl!! I used the "puppy acpi=force" and it started to load like a charm.

Now all I have to do is go thru the wizards to complete the install.

Thanks again.

Karl Godt 07-14-2011 04:31 PM

The acpi option actually recognizes a lot more drivers , than acpi disabled or APM .

All times are GMT -5. The time now is 06:23 PM.