LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Projects > LinuxQuestions.org > Bug
User Name
Password

Notices


Android client crashes on threads with polls Issue Tools
issueid=217 12-25-2017 09:38 AM
Senior Member
Android client crashes on threads with polls

Hello,

As the title says; whenever I try to scroll down on a thread with a poll on the Android client, it crashes.

Best regards.
Issue Details
Project LinuxQuestions.org
Category Other
Status Awaiting Feedback
Priority 5 - Medium
Affected Version Unknown
Fixed Version (none)
Users able to reproduce bug 1
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)

12-25-2017 10:27 AM
Senior Member
 
The same happens when there is enough reply's in a thread, don't know the exact number tho. It also crashes when I try and look at Notifications. (for the "Did you find this post helpful?")
Reply
12-26-2017 09:19 AM
root
 
What version of Android are you seeing this on?

--jeremy
Reply
12-26-2017 09:26 AM
Senior Member
 
Quote:
Originally Posted by jeremy
What version of Android are you seeing this on?

--jeremy
4.4.2 for me.
Reply
12-26-2017 10:31 AM
Senior Member
 
Android 7.1.1 here.
Reply
12-26-2017 11:29 AM
root
 
I'm not able to reproduce this, but I'm rolling out a new version that may fix this issue.

--jeremy
Reply
12-27-2017 04:57 AM
Senior Member
 
Hi Jeremy,

I tried the new version, but the problem persists.

If you need more info about my system or testing, just let me know.

Best regards.
Reply
12-27-2017 01:50 PM
Senior Member
 
Yeah same here Jeremy... It doesn't crash as much but, as odiseo77 says; whenever there's a poll in the thread it will still crash regardless. It also gives the following error message when trying to access the "Notifications" part:

AppError [code:client_connection_error,extra:null,exeception:java.io.IOExeception:Unexpected HTTP server response code (404)]

I'm no developer but it would suggest either, a) the app can't find the relevant info on ya server there or b) the server is giving the app the wrong info.

If you need more info, let me know and I can see what I can dig up for ya.

Beyond that, I don't know...
Reply
12-27-2017 03:04 PM
root
 
I'm not able to reproduce this on any device I own. I've enabled some additional debugging to try to track it down. That said, 4.4.2 is unsupported at this point so it's possible we won't be able to fix that issue. It should definitely work on 7.1.1, though. Which device is this?

--jeremy
Reply
12-27-2017 04:20 PM
Senior Member
 
Mine is a BQ Aquarius U Plus. IIRC, it has 2 GB of RAM and an octa core processor (not sure where to check the hardware details on the device itself).
Reply
01-06-2018 04:36 PM
Senior Member
 
Small update:

The problem seems to occur only with threads that contain polls and many posts, since I was able to view the LQ awards poll threads (and even vote on them) from my phone when the polls had just been released (hence only contained a few posts or no posts at all).
Reply
01-06-2018 04:58 PM
root
 
Thanks for the update.

--jeremy
Reply
Reply

Issue Tools
Subscribe to this issue

  



All times are GMT -5. The time now is 02:01 AM.

Main Menu
Advertisement
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration