LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Non-*NIX Forums > Programming
User Name
Password
Programming This forum is for all programming questions.
The question does not have to be directly related to Linux and any language is fair game.

Notices


Reply
  Search this Thread
Old 04-27-2009, 02:20 PM   #1
abhinav.zoso
LQ Newbie
 
Registered: Jan 2009
Posts: 14

Rep: Reputation: 0
Question Turn off keyboard echo system wide


Is it possible to turn off keyboard echo in linux? In the terminal, we can do it using stty -echo. Similarly, the keyboard echo has to be turned off system wide. Is it possible?
 
Old 04-27-2009, 02:26 PM   #2
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,528

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
can't you set this in
/etc/bashrc ?
 
Old 04-27-2009, 02:49 PM   #3
SlowCoder
Member
 
Registered: Oct 2004
Location: Southeast, U.S.A.
Distribution: Fedora (Desktop), CentOS (Server), Knoppix (Diags)
Posts: 934

Rep: Reputation: 38
Just a question: Why would you do this systemwide? I've only ever had to turn off local echo when the remote system was already echoing input. If you do it systemwide, won't anything you type be invisible? Am I talking about something totally different?
 
Old 04-28-2009, 12:47 AM   #4
abhinav.zoso
LQ Newbie
 
Registered: Jan 2009
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by SlowCoder View Post
Just a question: Why would you do this systemwide? I've only ever had to turn off local echo when the remote system was already echoing input. If you do it systemwide, won't anything you type be invisible? Am I talking about something totally different?
Exactly.. I want nothing to be visible. I have designed an input method (IM) which converts english to indic languages. When the user starts typing, wherever he/she types, the converted text can be seen. That is, for example, if kannada (one of the indic languages) is selected, in any application you type, you can only see kannada. But, the problem is that it also echoes the english character along with the indic character. What I am doing is, along with the indic character, I am also sending a backspace so that it deletes the english character. This is very shabby and cumbersome. So, if I can find a way to turn off the echo, the english characters wont be put at all. I am using Xlib to send events to the focussed window.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't get my head around system-wide email... ArthurDent Linux - Newbie 2 05-20-2007 02:56 AM
kde system wide config bong.mau Linux - Software 8 06-09-2006 06:17 AM
System Wide Permission lmanwarren Linux - General 1 03-29-2005 09:15 PM
Where are system-wide blackbox configs? Erik Thorsson Linux - Software 1 01-30-2005 09:41 PM
Keyboard does not echo........ Ryan L. Brown Linux - Newbie 1 01-10-2005 07:01 PM

LinuxQuestions.org > Forums > Non-*NIX Forums > Programming

All times are GMT -5. The time now is 09:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration