-   Programming (
-   -   Trouble with build and install GCC-toolchain for ARM (

_oligarch 04-23-2009 05:52 AM

Trouble with build and install GCC-toolchain for ARM
Hi everybody. Help me please. I have openSUSE 11.0 (i586).
I was trying to build and install GCC-toolchain (binutils-2.19, gcc-4.3.2, insight-6.8, newlib-1.16.0) for AT91SAM9260 (ARM926EJ-S core).
First off all I tried to build binutils. I did
It performed without any errors. After that I tried to do
It was performing good till the follow errors occure:

make[2]: Entering directory `/GCC-4.3toolchain/binutils-2.19/opcodes'
make all-recursive
make[3]: Entering directory `/GCC-4.3toolchain/binutils-2.19/opcodes'
Making all in po
make[4]: Entering directory `/GCC-4.3toolchain/binutils-2.19/opcodes/po'
make[4]: *** No rule to make target `all'. Stop.
make[4]: Leaving directory `/GCC-4.3toolchain/binutils-2.19/opcodes/po'
make[4]: Entering directory `/GCC-4.3toolchain/binutils-2.19/opcodes'
make[4]: Leaving directory `/GCC-4.3toolchain/binutils-2.19/opcodes'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/GCC-4.3toolchain/binutils-2.19/opcodes'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/GCC-4.3toolchain/binutils-2.19/opcodes'
make[1]: *** [all-opcodes] Error 2
make[1]: Leaving directory `/GCC-4.3toolchain/binutils-2.19'
make: *** [all] Error 2

What should I do this situation?
thank you.

theNbomr 04-23-2009 10:33 AM

I strongly recommend using a system that is designed to build cross compilers/toolchains. Either the crosstool or newer crosstool-ng packages seem to be the most common ones. I've used crosstool, and am looking into setting up a crosstool-ng environment.
Building cross toolchains carries a whole host of issues that are not solved by simply downloading and building GCC. These packages address those issues.
--- rod

_oligarch 04-26-2009 11:03 PM

thank you. It works now!

All times are GMT -5. The time now is 06:55 PM.