LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Non-*NIX Forums > Programming
User Name
Password
Programming This forum is for all programming questions.
The question does not have to be directly related to Linux and any language is fair game.

Notices


Reply
  Search this Thread
Old 12-08-2003, 01:41 AM   #1
nawazsa
LQ Newbie
 
Registered: Dec 2003
Posts: 1

Rep: Reputation: 0
Seg fault with root on ramdisk


Hi,

I have derived a root disk from Slackware 9 that I use on a Pentium3 SBC. I use the kernel from Slackware 9 to boot and use this ramdisk as root using loadlin after booting DOS from an IDE flash disk. Everything goes well and the system boots.

I have a c++ application using pthreads and compiled on Slackware 9 desktop. I want to run this application on the embedded system. THis application compiles and runs properly on the Slackware 9 desktop but seg faults when I try to run it on the embedded system.

I used ldd to determine the libraries and copied all those libraries from the Slackware 9 dekstop to my embedded system root disk.
I can run small test programs like a program using pthreads and a c++ program properly on this system. This means that there shouldn't be anything wront with the libraries. When I run my application in gdb on the embedded system I get following error

Starting program: /root/main
[New Thread 16384 (LWP 541)]
Program received signal SIGSEGV, Segmentation fault
[Switching to Thread 16384 (LWP 541)]
0x401bc299 in sYSMALLOc () from /lib/libc.so.6


What could be wrong. I checked with free there is around 110MB of free ram available.
Any clues. I'll greatly appreciate any help.

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
seg fault on fedora only dh0104 Programming 3 03-26-2005 12:57 PM
weird seg fault zaichik Programming 7 01-29-2005 06:34 AM
C seg fault drigz Programming 5 10-01-2004 03:35 PM
gnome_error_dialog seg fault?? Castro Programming 3 06-11-2003 01:28 PM
gnome_app_create_menus seg fault in RH 7.3 Castro Programming 0 05-30-2003 08:46 PM

LinuxQuestions.org > Forums > Non-*NIX Forums > Programming

All times are GMT -5. The time now is 04:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration