LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Programming (https://www.linuxquestions.org/questions/programming-9/)
-   -   qt-libs not found (https://www.linuxquestions.org/questions/programming-9/qt-libs-not-found-15376/)

niklasw19 03-01-2002 08:28 PM

qt-libs not found
 
Hi!

I have a problem with the qt-libs when I try to configure makefiles
that requires qt, the following is output from a configure script:

checking for Qt... configure: error: Qt (>= Qt 2.2.2)
(library qt) not found. Please check your installation!

I'm using Mandrake 8.2 Beta3.

djoao 03-12-2002 01:03 PM

The qt library/toolkit does not vome standard with most distributions. I do not know whether Mandrake bundles it. From the error message it appears that you do not have qt installed. I suggest you visit:

www.trolltech.com/developer/download/qt-x11.html

for a free edition (provided under GPL) of qt. Hope this solves your problem. Have a good day.

Rohit 03-15-2002 01:16 AM

qt is installed /usr/lib/qt3 or qt2 ... set your QTDIR path to this one.

k4zau 05-02-2003 11:02 AM

how would I go about changing the QTDIR path?

Hko 05-03-2003 08:58 AM

In some distro's the QTDIR is already set, and you should be OK.
In other distro's this isn't done (Debian for example).

You can set it yourself by first finding out where Qt is installed (look at the directories Rohit's mentiones, or for Debian it's /usr/share/qt). Then set QTDIR to this directory with:

export QTDIR=/usr/share/qt

And then try running ./configure && make again.

k4zau 05-04-2003 12:30 PM

but would setting QTDIR to find the qt2 libraries prevent qt3 programs from running?

Hko 05-04-2003 06:20 PM

No.
It's only needed when you compile the program. When you exit the shell the QTDIR environment variable is lost anyway, thus undoing all of it's effect.
Except for the executable that you configured/compiled with the QTDIR set, which will "remember" where to find the Qt2 lib's.

k4zau 05-06-2003 11:20 AM

I found the qt2 libraries under /usr/lib/qt2/lib

I entered export QTDIR=/usr/lib/qt2/lib

I switched to the directory where I have the program, and entered ./configure

Same error. I guess I have the wrong Qt.

These are the files in the qt2 directory:
libqt-mt.so.2 libqt.so.2 libqutil.so.1
libqt-mt.so.2.3 libqt.so.2.3 libqutil.so.1.0
libqt-mt.so.2.3.1 libqt.so.2.3.1 libqutil.so.1.0.0

Hko 05-07-2003 07:18 PM

Try:
Code:

export QTDIR=/usr/lib/qt2
(without "/lib")

k4zau 09-11-2003 04:47 PM

that didn't work either. i can't say i'm a big fan of Qt.

ujotne 09-11-2003 08:36 PM

Make sure that the QTDIR path is activated after you added
QTDIR=/usr/lib/qt3
export $QTDIR
to the .bashrc file in your home directory. To check that you do indeed have a QTDIR environment variable type
echo $QTDIR
You should then see
/usr/lib/qt3
The .bashrc file is read when you open a new shell, so when you open a new shell the QTDIR will be set. If you log out of KDE and inn again and type
echo $QTDIR
you will also see that the QTDIR env. var is set.

Good luck.

lukescott 11-22-2003 01:12 PM

QT Libs not found
 
I'm getting the same problems, but in SuSE 9. have you found an answer yet?

k4zau 11-24-2003 04:17 PM

I was told that I needed to install the Qt Development Libraries (qt-devel, I think) in order to compile any application that uses Qt. I haven't had time to mess with it though. You might try to download and install those, then try to compile the application again.


All times are GMT -5. The time now is 01:32 PM.