-   Programming (
-   -   Python using compiled VTE library (

sadarax 07-19-2009 08:39 AM

(SOLVED) Python import/binding error with compiled VTE library
EDIT: Problem solved. I just use my distributions package source and run their compile scripts after editing whatever source files I want.

I'm working on VTE, so I can use it in Python.

I can compile their source files successfully (using and make), but I do not know how to make a '' file that I can actually use in my python programs.

python ./ #using the simple demo program they provide in the source files

#!/usr/bin/env python
import vte

I get the error message:

Traceback (most recent call last):
  File "./", line 6, in <module>
    import vte
ImportError: No module named vte

I have no idea what to do. Please help.

My build process so far command line:

bzr branch lp:vte
cd vte
sudo make install
sudo ldconfig
cd python/
python ./

The make and make install process do not seem to produce a vte-module that python sees on my system.

bannock 07-21-2009 06:43 PM

Looks like the build of may have omitted some source files.

sadarax 07-21-2009 11:46 PM

Indeed. I did eventually figure that out. Now I must learn how to make it build the file and install it.....

sadarax 07-23-2009 08:05 AM

Bump with new information about the problem. See first post.

bannock 07-23-2009 07:32 PM

Try this:
bzr branch lp:vte
cd vte
cd python
PYTHONPATH=../libs python

All times are GMT -5. The time now is 11:19 AM.