LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Programming (https://www.linuxquestions.org/questions/programming-9/)
-   -   POP3Client probs (https://www.linuxquestions.org/questions/programming-9/pop3client-probs-46/)

bickford 08-18-2000 03:19 AM

OK I'm nearly done with my webmail program but I've run into what I think is a snag. It all seems to be related to POP3Client and it not being completely compatible with my default pop server? First off I uncommented out the pop server from inetd.conf and restarted inetd. Next I got myself a copy of POP3Client from cpan.org and installed it no problem. When I ran the 'make test' on the POP3Client with POPTESTACCOUNT=bickford:secret:localhost I get the following:

Use of uninitialized value at blib/lib/Mail/POP3Client.pm line 510.
FAILED tests 2-5, 24
Failed 5/26 tests, 80.77% okay
Failed Test Status Wstat Total Fail Failed List of failed
------------------------------------------------------------
t/poptest.t 26 5 19.23% 2-5, 24
Failed 1/1 test scripts, 0.00% okay. 5/26 subtests failed, 80.77% okay.
make: *** [test_dynamic] Error 29

Basically you can see that only a certain percentage of the test passed. When I actually try and use my webmail client is stalls for about 10 seconds (just like the 'make test' did actually) then perl bitches:

[error] [client 127.0.0.1] Premature end of script headers: /home/httpd/cgi-bin/webmail.pl

Now I understand that the error perl is giving me may not be related to POP3Client, but I don't know for sure. If anything, does anyone know why make test for POP3Client wouldn't succeed 100%? Thanks!


P.S. Oh yea, when I run make test with POPTESTACCOUNT=bickford:secret:my.isps.mailserver it works no problem at all. I wonder what pop client my ISP is using that seems to be 100% compatible with POP3Client?

P.S.S. Argh, Ok I just did one last test w/ POP3Client against my ISP's mail server, but this time with an inentionally bad password and I got a similar result to what I was getting when I was running it against my own pop server, so it would seem as if it's an authentication problem? (isn't it always)

jeremy 08-18-2000 07:48 AM

What POP3 server are you running?

bickford 08-18-2000 08:26 AM

For $100, what is ipop3d?

jeremy 08-18-2000 08:35 AM

OK so you uncommented out the pop server from inetd.conf and restarted inetd but is ipop3d installed, configured and running correctly? You are running Red Hat right? Unless you installed ipop3d it's probably not there. Try typing:
Code:

telnet localhost 110
and see if you get a response. BTW I have been using cucipop for awhile now and I really like it. If ipop3d is not installed I would just install cucipop.

bickford 08-18-2000 10:43 AM

OK well against your advice I installed ipopd because cucipop wouldn't compile. It would complain about not being able to locate the header file db.h in the directory db2/. I definitely don't have this file... So in any case I installed the IMAP RPM which includes ipopd. Now when I telnet localhost 110 I get the response "+OK POP3 resnet72-48.resnet.buffalo.edu v7.64 server ready", when I type in "USER bickford" it responds "+OK User name accepted, password please" but when I "PASS mypass" it responds "-ERR Bad login". I'm definitely typing in my correct password... perhaps it's a problem with PAM? (again).

jeremy 08-18-2000 11:06 AM

Could be. Do you have an imapd/ipopd entry in /etc/pam.d?

bickford 08-18-2000 12:27 PM

Well, I was hunting around in /etc/pam.d/ and I do have a file called pop with the following contents:

#%PAM-1.0
auth required /lib/security/pam_pwdb.so shadow nullok
account required /lib/security/pam_pwdb.so

I also have an imap file with the exact same contents.

Also, before my last post I noticed that in inetd.conf I had auth commented out. I made sure to uncomment that and restart inetd, so that should be all well and good, if it's even required.

jeremy 08-18-2000 05:44 PM

The auth you see in /etc/inetd is unrelated to the the auth in the pam files. The inetd auth is referring to the tcp service running on port 113. The more common name for this service nowadays is ident.

bickford 08-18-2000 10:35 PM

Ahh I see, thanks for the clarification. =) Any more thoughts on what could be causing my authentication probs? I've pretty much exhausted all my ideas.... it didn't take very long.

bickford 08-19-2000 01:33 AM

argh
 
nevermind i figured it out, somehow all my users passwords were changed.... wish i'd noticed that earlier or i woulda saved myself at least a day of constant frusteration and hair pulling. Such is the life of a programmer i suppose......

jeremy 08-19-2000 09:13 AM

All your passwords were changed, but YOU didn't change them?

Alpha 03-12-2001 06:10 PM

POP3Client Newbie
 
I know newbies aren't very popular but, try to remember, you used to be a newbie too.

I am very much a newbie so please have patience.

Can someone give me an idiot proof walkthrough on how to install POP3Client on my RedHat server and test it to make sure it works?

Please assume I don't know anything.

Cause I don't :>





All times are GMT -5. The time now is 10:42 PM.