Register a domain and help support LQ
Go Back > Forums > Non-*NIX Forums > Programming
User Name
Programming This forum is for all programming questions.
The question does not have to be directly related to Linux and any language is fair game.


  Search this Thread
Old 09-23-2012, 05:07 PM   #1
Registered: Jun 2010
Distribution: Debian, Ubuntu, Win
Posts: 137

Rep: Reputation: 16
Perl: CPAN modules under Debian (Wheezy) not installing properly.

Hi All,

I'm trying to determine if this is a bug or if it's by design, but when I call:

cpan[1]> install "IPC::Cache"

The module reports that it installs successfully, but the perl scripts cannot find it.

Even manually building the module and running 'make install' still fails to install it properly.

Hopefully this log of a CPAN install can show some light on it:

cpan[11]> force install "IPC::Cache"
Running install for module 'IPC::Cache'
Running make for D/DC/DCLINTON/IPC-Cache-0.02.tar.gz
Checksum for /root/.cpan/sources/authors/id/D/DC/DCLINTON/IPC-Cache-0.02.tar.gz ok Building D/DC/DCLINTON/IPC-Cache-0.02.tar.gz

Checking if your kit is complete...
Looks good
Writing Makefile for IPC::Cache
Writing MYMETA.yml
cp blib/lib/IPC/
Manifying blib/man3/IPC::Cache.3pm
/usr/bin/make -- OK
Running make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-Iblib/lib" "-Iblib/arch"
ok 1
ok 2
ok 3
ok 4
ok 5
ok 6
ok 7
ok 8
ok 9
ok 10
ok 11
ok 12
ok 13
ok 14
ok 15
ok 16
/usr/bin/make test -- OK
Running make install
Appending installation info to /root/perl5/lib/perl5/i486-linux-gnu-thread-multi-64int/perllocal.pod
/usr/bin/make install -- OK


Is this potentially a bug or is this by design and I'm missing something??

Old 09-23-2012, 06:41 PM   #2
Senior Member
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 461Reputation: 461Reputation: 461Reputation: 461Reputation: 461
Building Debian packages of Perl modules -

There is also a cpan repo: -- debified CPAN packages -


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Issue with installing Perl CPAN Modules on Ubuntu 11.04 NeonFlash Linux - Software 4 07-30-2012 07:07 AM
issues with cpan perl modules reticent Debian 12 01-29-2011 07:30 AM
[SOLVED] Problem installing CPAN modules (perl) and proxy settings rodriguez Linux - Newbie 1 02-17-2010 08:39 AM
CPAN and PERL Modules metallica1973 Programming 4 02-01-2008 09:14 PM
"cc1: error: invalid option 'tune=i686'" while installing Perl modules via CPAN scuzzman Programming 12 08-21-2006 09:30 PM

All times are GMT -5. The time now is 09:54 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration