LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Non-*NIX Forums > Programming
User Name
Password
Programming This forum is for all programming questions.
The question does not have to be directly related to Linux and any language is fair game.

Notices


Reply
  Search this Thread
Old 12-17-2012, 11:01 PM   #1
manoj7410
Member
 
Registered: Jun 2012
Location: India
Distribution: 2.6.x
Posts: 40

Rep: Reputation: Disabled
Unhappy -lavdevice not found


Hi,

I am trying to compile ffmpeg. included libavdevice.a but still facing -lavdevice not found.
 
Old 12-18-2012, 07:29 AM   #2
JohnGraham
Member
 
Registered: Oct 2009
Posts: 467

Rep: Reputation: 139Reputation: 139
The central problem is that the development libraries for libavdevice aren't installed - use your package manager to do so. On Debian-based systems (such as Ubuntu, which your profile says you use) this can be done with the following (as root user):

Code:
apt-get install libavdevice-dev
Better yet, you can stall all dependencies for ffmpeg with:

Code:
apt-get build-dep ffmpeg
 
Old 12-18-2012, 07:52 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2019 CentOS6.10 CentOS7.5 + 50+ other Linux OS, for test only.
Posts: 17,170

Rep: Reputation: 3535Reputation: 3535Reputation: 3535Reputation: 3535Reputation: 3535Reputation: 3535Reputation: 3535Reputation: 3535Reputation: 3535Reputation: 3535Reputation: 3535
Quote:
I am trying to compile ffmpeg
Why ? ?
"ffmpeg" is included in Ubuntu : sudo apt-get install ffmpeg
( http://packages.ubuntu.com/quantal-updates/ffmpeg )

Quote:
-lavdevice not found.
May be it's about "libavdevice.so" :
The configure option to create shared libraries (.so) is --enable-shared
http://packages.ubuntu.com/source/quantal-updates/libav
→ The red dots mark the dependencies.
$ sudo apt-get build-dep libav

Which Ubuntu version are you using ?
And which version of ffmpeg are you trying to compile ? ?

.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Xorg, no screens found; no devices found (after Virtualbox install) Archytas Linux - General 6 03-06-2013 03:41 PM
404 Not Found The requested URL '/zm' was not found on this server. mickeyboa Ubuntu 8 07-26-2012 11:02 AM
Directory not found; -xzvf not found; Makefile not found RealGomer Linux - Software 4 09-20-2010 10:02 AM
Fedora Core 6 boot No medium found No volume groups found awadhut Linux - Hardware 1 02-22-2007 01:15 AM
PDC 20276 - Promise Fasttrack 133 found but still not found.. FransE Linux - Hardware 3 02-16-2004 07:44 AM

LinuxQuestions.org > Forums > Non-*NIX Forums > Programming

All times are GMT -5. The time now is 01:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration