-   Programming (
-   -   i set CLASSPATH but still can't comile my java code (

cgchayan 09-21-2009 12:08 AM

i set CLASSPATH but still can't comile my java code
I am learning j2se n i have fedora 9 installed. While learning using packages I had to set set CLASSPATH. I wrote:
because I wanted to import a class whose corresponding bytecode was saved in the mentioned /home/.../bytecode folder.
I tried echo $CLASSPATH and it showed the expected output.
but when i tried to compile my new class using
javac -d /home/.../bytecode
it shows the errors:
package ABC does not exist
cannot find symbol

[ABC is the package that holds the previously compiled class that i want to import]

Please help..
thanking you,

paulsm4 09-21-2009 01:36 AM

Hi -

This link might help:

Basically, do this:

1. If you've got a package "graphics", with a class "Rectangle"...

//in the file
package graphics;
public class Rectangle {
  . . .

2. ... then put your source file "" in a subdirectory called "graphics":

3. ... and compile and run your program directory ABOVE "graphics":

javac graphics/
java graphics/Rectangle

'Hope that helps .. PSM

You might find this link helpful, too:

All times are GMT -5. The time now is 10:12 PM.