LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Non-*NIX Forums > Programming
User Name
Password
Programming This forum is for all programming questions.
The question does not have to be directly related to Linux and any language is fair game.

Notices


Reply
  Search this Thread
Old 10-07-2019, 07:42 AM   #1
vlrk
Member
 
Registered: Dec 2008
Posts: 39

Rep: Reputation: 1
httpd + openssl : compilation issues while using shared openssl library


I am using httpd-2.2.31 , trying to use openssl-1.0.2t with --with-ssl and --enable-ssl parameter.

--with-ssl points to the openssl installed directory.

I am having redhat 5.7 with x86_64 ,where the compiled binaries would be running.

Used the openssl parameters of shared ,to get ssl shared objects while compiling the openssl in centos 5.7 .


i try to use ssl as shared library , i get below error

opt/apache/bin/httpd: error while loading shared libraries: /opt/apache/lib/libssl.so.1.0.0: requires glibc 2.5 or later dynamic linker
apxs:Error: Sorry, no shared object support for Apache.
apxs:Error: available under your platform. Make sure.
apxs:Error: the Apache module mod_so is compiled into.



Any inputs on this would be appreciated.
 
Old 10-07-2019, 08:19 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,564

Rep: Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794
Quote:
apxs:Error: Sorry, no shared object support for Apache.
apxs:Error: available under your platform. Make sure.
apxs:Error: the Apache module mod_so is compiled into.
Why are you using apashe-2.2 on RHEL-5.7. Both reached EOL btw, so they are unsupported.

Anyway, from the error you got above, I guess you have to compile first apache with the "--enable-so" and then recompile it adding support for ssl a a DSO.
 
Old 10-07-2019, 08:19 AM   #3
NevemTeve
Senior Member
 
Registered: Oct 2011
Location: Budapest
Distribution: Debian/GNU/Linux, AIX
Posts: 3,860

Rep: Reputation: 1344Reputation: 1344Reputation: 1344Reputation: 1344Reputation: 1344Reputation: 1344Reputation: 1344Reputation: 1344Reputation: 1344Reputation: 1344
Compile everything (openssl, apr, apr-util, and whatever they depend on) from source, but don't use random (or ad hoc) directories, use --prefix=/usr/local consequently when compiling.
 
1 members found this post helpful.
Old 10-07-2019, 10:36 AM   #4
vlrk
Member
 
Registered: Dec 2008
Posts: 39

Original Poster
Rep: Reputation: 1
Thanks bathory and NevemTeve ,

This is not a standalone compilation , httpd is a part of target board package .

This is legacy code . It has already shared objects of previous version openssl-1.0.1t .Here i am trying to upgrade openssl to 1.0.2t.

The httpd binary runs in the redhat el 5.7. Here to update the dependent libraries , procedure followed is like below.

Take the source and get compiled in centos 5.7 , take the installed libraries and use them httpd compilation with --with-ssl=<installed dir>

The issue i think is with steps or the system where i am trying to generate the openssl shared objects.

Why so because , even if i try with the old source 1.0.1t and use those generated libraries i get same error.

Should i compile in redhat 5.7 EL only ?. will that make any difference ?.
 
Old 10-07-2019, 10:43 AM   #5
NevemTeve
Senior Member
 
Registered: Oct 2011
Location: Budapest
Distribution: Debian/GNU/Linux, AIX
Posts: 3,860

Rep: Reputation: 1344Reputation: 1344Reputation: 1344Reputation: 1344Reputation: 1344Reputation: 1344Reputation: 1344Reputation: 1344Reputation: 1344Reputation: 1344
Code:
error while loading shared libraries: /opt/apache/lib/libssl.so.1.0.0: requires glibc 2.5 or later dynamic linker
This means you have installed some binary package that isn't suitable for you OS.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Issues with shared library dependencies in apache and openssl compile peter_gbg Linux - Server 0 06-30-2015 12:44 PM
[SOLVED] Link shared library against other shared library Lobinho Linux - Newbie 2 05-28-2010 08:16 AM
gcc link shared library against another shared library qcp Linux - Newbie 1 07-25-2008 11:15 AM
Starting httpd: httpd: Syntax error on line 209 of /etc/httpd/conf/httpd.conf: Syntax sethukpathi Linux - Networking 6 04-12-2008 11:26 AM
Shared object library that uses another shared object library Nightfox Programming 1 02-15-2006 10:00 PM

LinuxQuestions.org > Forums > Non-*NIX Forums > Programming

All times are GMT -5. The time now is 11:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration