LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Non-*NIX Forums > Programming
User Name
Password
Programming This forum is for all programming questions.
The question does not have to be directly related to Linux and any language is fair game.

Notices


Reply
  Search this Thread
Old 03-23-2016, 02:07 PM   #1
asif_bahrainwala
Member
 
Registered: Mar 2015
Posts: 47

Rep: Reputation: Disabled
g_type_class_adjust_private_offset


Hi,
I am working with gstreamer, I get a lot of errors:

(gst-plugin-scanner:28286): GStreamer-WARNING **: Failed to load plugin '/usr/local/lib/gstreamer-1.0/libgstplugin.so': /usr/lib/x86_64-linux-gnu/libgstreamer-1.0.so.0: undefined symbol: g_type_class_adjust_private_offset

g_type_class_adjust_private_offset :: how do I solve this?
 
Old 03-23-2016, 02:45 PM   #2
NevemTeve
Senior Member
 
Registered: Oct 2011
Location: Budapest
Distribution: Debian/GNU/Linux, AIX
Posts: 4,150

Rep: Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523
Some components come from /usr/local/lib, others from /usr/lib/x86_64-linux-gnu/, and they are incompatible
 
Old 03-23-2016, 05:15 PM   #3
asif_bahrainwala
Member
 
Registered: Mar 2015
Posts: 47

Original Poster
Rep: Reputation: Disabled
Thanks for the update, how do I solve this issue.
I don't have an x86_64 folder , I am using Ubuntu 14.04.4 (64 bit)

Last edited by asif_bahrainwala; 03-23-2016 at 06:28 PM.
 
Old 03-24-2016, 12:08 AM   #4
NevemTeve
Senior Member
 
Registered: Oct 2011
Location: Budapest
Distribution: Debian/GNU/Linux, AIX
Posts: 4,150

Rep: Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523
Some components come from /usr/local/lib, others from /usr/lib/x86_64-linux-gnu, and they are incompatible. You should remember what did you install from source, and what did you install deb-package, because they don't work together.
 
Old 03-24-2016, 11:46 AM   #5
asif_bahrainwala
Member
 
Registered: Mar 2015
Posts: 47

Original Poster
Rep: Reputation: Disabled
I have now set up a new VM with Ubuntu 14.04.4 (64bit)

GStreamer-WARNING **: Failed to load plugin '/usr/local/lib/gstreamer-1.0/libgstplugin.so': /usr/lib/x86_64-linux-gnu/libgstreamer-1.0.so.0: undefined symbol: g_type_class_adjust_private_offset

any idea how to fix this....
 
Old 03-30-2016, 01:33 AM   #6
NevemTeve
Senior Member
 
Registered: Oct 2011
Location: Budapest
Distribution: Debian/GNU/Linux, AIX
Posts: 4,150

Rep: Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523
Some components come from /usr/local/lib, others from /usr/lib/x86_64-linux-gnu, and they are incompatible. You should remember what did you install from source, and what did you install deb-package, because they don't work together.
 
Old 08-23-2016, 02:49 PM   #7
Zope
LQ Newbie
 
Registered: Jan 2013
Posts: 7

Rep: Reputation: Disabled
What if this happens after a yum update??
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



LinuxQuestions.org > Forums > Non-*NIX Forums > Programming

All times are GMT -5. The time now is 07:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration