-   Programming (
-   -   error: unexpected token `newline' (

CarlosV 11-03-2003 11:34 AM

error: unexpected token `newline'
Hi all,

when i run this line in shell works ok:

cat /userdir/file.conf | sed "s/" > /userdir/file.conf1

but i want to add it in a shell script, and when i run it i got an error:

./test: line 2: syntax error near unexpected token `newline'
./test: line 2: `cat /userdir/file.conf | sed "s/" >'

my script is this:

cat /userdir/file.conf | sed "s/" >

i hope someone can help me finding where my error is or what i need to change to run it in a script

Thank You
Carlos V.

jhorvath 11-03-2003 11:37 AM

move the third line to the end of the second

if it is imperitive that this line (the third one) be seperate for some reason have to change it to this:


cat /userdir/file.conf | sed "s/" >\

CarlosV 11-03-2003 12:06 PM

It works Thank You Jeremy :)

maryamf 05-17-2011 03:14 AM

unexpected token 'newline'

when i run this lines in shell works ok:
echo "[Desktop Entry]
Name=No Name
X-GNOME-Autostart-enabled=true" >

acid_kewpie 05-17-2011 03:47 AM

Don't drag up 8 year old threads. new question = new thread. Not that you've even asked a question at all.

All times are GMT -5. The time now is 04:04 PM.