LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Non-*NIX Forums > Programming
User Name
Password
Programming This forum is for all programming questions.
The question does not have to be directly related to Linux and any language is fair game.

Notices


Reply
  Search this Thread
Old 07-26-2007, 02:21 AM   #1
maverick_pol
LQ Newbie
 
Registered: May 2007
Location: Lublin, Poland
Distribution: Gentoo, Fedora, FreeBSD
Posts: 17

Rep: Reputation: 0
errno: TLS definition ...mismatches nonTLS def..


Hi guys,

I have just installed the Fedora 7 system. Compiled Qt 4.3.0 and tried to compile my application which is using OGDI(C-API library for reading vpf data) compilation went ok until linking. At the end I got this message:

/usr/bin/ld: errno: TLS definition in /lib/libc.so.6 section .tbss mismatches non-TLS definition in ogdi/lib/linux/libogdi.so section .bss
/lib/libc.so.6: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[1]: *** [bin/Commander] Error 1

I have the same error under Slackware 12.0.
I belive that this problem is connected with static linking, as before while I were using Qt which was compiled dynamically I didn't get any errors

Any idea how to solve this problem?

Beforehand thanks.

Last edited by maverick_pol; 07-27-2007 at 12:54 AM.
 
Old 04-07-2008, 04:18 AM   #2
fabaix
LQ Newbie
 
Registered: Apr 2008
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by maverick_pol View Post
Hi guys,

I have just installed the Fedora 7 system. Compiled Qt 4.3.0 and tried to compile my application which is using OGDI(C-API library for reading vpf data) compilation went ok until linking. At the end I got this message:

/usr/bin/ld: errno: TLS definition in /lib/libc.so.6 section .tbss mismatches non-TLS definition in ogdi/lib/linux/libogdi.so section .bss
/lib/libc.so.6: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[1]: *** [bin/Commander] Error 1

I have the same error under Slackware 12.0.
I belive that this problem is connected with static linking, as before while I were using Qt which was compiled dynamically I didn't get any errors

Any idea how to solve this problem?

Beforehand thanks.

I'm French, and I have the same error.
Have you the solution?

Thanks
 
Old 05-21-2008, 09:45 PM   #3
codedr
Member
 
Registered: Feb 2007
Location: USA
Distribution: opensuse, slackware
Posts: 35

Rep: Reputation: 18
In the code I was compiling, the following line was the offender:

extern int errno;

I replaced this line with #include <errno.h>
and the problem went away.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to install utf8.def? max2004 Fedora 1 12-27-2011 08:48 AM
errno: TLS definition in /lib64/libc.so.6 section .tbss mismatches non-TLS reference johnpaulodonnell Programming 2 07-25-2008 04:37 AM
Error occurred while reading definition data from /root/.lineak/lineakkb.def marietechie Linux - Software 4 07-23-2007 09:14 PM
Is there any app to convert emacs's syntax highlight def. file to vim's def. file ? cyu021 Linux - Software 0 10-05-2004 11:02 PM
Is this correct DEF for NAT? Thom_Redhat Linux - General 1 09-10-2003 05:20 PM

LinuxQuestions.org > Forums > Non-*NIX Forums > Programming

All times are GMT -5. The time now is 03:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration