LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Non-*NIX Forums > Programming
User Name
Password
Programming This forum is for all programming questions.
The question does not have to be directly related to Linux and any language is fair game.

Notices


Reply
  Search this Thread
Old 03-17-2006, 09:59 AM   #1
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Costa Rica
Distribution: Kubuntu, Debian, Knoppix
Posts: 2,092
Blog Entries: 1

Rep: Reputation: 90
Question dynamic SVG (php) on firefox: this XML blah blah


I' creating a SVG with a PHP script. I can see it perfectly on konqueror and on IE, however firefox (1.5) complains with this message:

Code:
This XML file does not appear to have any style information associated with it. The document tree is shown below.
The php code looks like this:
Code:
<?="<?"?>xml version="1.0" encoding="UTF-8" standalone="no" <?="?>"?>

<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN" 
  "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd"> 
<svg blah blah>
.
.
.
.
.
</svg>
I'm setting the content-type in the beginning of the script:
header("Content-type: image/svg+xml");

and I'm also defining the type on the <embed /> tag on another scripts that calls the SVG script:
Code:
<embed class="svgex" src="reportesvg.php?reporte=<?= isset($reporteSeleccionado) ? $reporteSeleccionado->getId() : "" ?>" type="image/svg+xml" frameborder="no" align="middle" width="<?= $SVG_ANCHO_VISTA ?>" height="<?= $SVG_ALTO_VISTA ?>" pluginspage="http://www.adobe.com/svg/viewer/install/" />
What is the problem then?

Last edited by eantoranz; 03-17-2006 at 10:07 AM.
 
Old 03-17-2006, 11:58 AM   #2
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Costa Rica
Distribution: Kubuntu, Debian, Knoppix
Posts: 2,092

Original Poster
Blog Entries: 1

Rep: Reputation: 90
Problem solved! I added two more properties to the svg element:

Code:
<svg blah blah xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad Display Name balh.blah.blah.com in remove command 0.o *BSD 2 12-08-2004 01:37 PM
Expanding file names in a script? ../blah -> /home/blah Bebo Linux - General 24 03-29-2004 05:39 PM
ln -s smbspool /blah/blah/hugh? wlfdgcrkz Linux - Networking 0 06-24-2003 12:29 AM
newbie issues....kernel panic: blah blah blah Rio Nishida Slackware 16 11-29-2002 12:08 AM
apachectl configtest ... blah punt Linux - Software 7 07-18-2001 11:23 AM

LinuxQuestions.org > Forums > Non-*NIX Forums > Programming

All times are GMT -5. The time now is 05:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration