-   Programming (
-   -   Configuring mcrypt and libmcrypt (

wyntre 10-16-2007 07:35 PM

Configuring mcrypt and libmcrypt
I am having problems with configuring mcrypt and libmcrypt.

I am running RHEL 5, with Apache 2.2.6 and PHP 5.2.4.

I have installed libmcrypt 5.2.7 and mcrypt 2.6.4-2 through rpms. I try to re-configure php with mcrypt and gives me the error:

checking for mcrypt support... yes
configure: error: mcrypt.h not found. Please reinstall libmcrypt.

i've unistalled mcrypt and libmcrypt, then tried to configure them from source, but i get errors from those, mainly dealing with the g++ and c++ compiler, but i have the entire gcc suite installed.

Hko 10-17-2007 03:11 AM

I think you rproblem will be solved by just installing one more package: "libmcrypt-devel".

"-devel" packages generally. contain header file (*.h) for compiling software against libraries. They are packaged seperately because the are not needed to run ready-compiled programs that use the lib.

wyntre 10-17-2007 10:28 PM
i configure with:

./configure --with-gd --with-jpeg-dir=/usr/lib --with-png-dir=/usr/lib --with-freetype-dir=/usr/lib --with-mysql --with-mcrypt --with-apxs2=/usr/local/apache2/bin/apxs --with-xpm-dir=/usr/lib

and when i run make i get:

/usr/bin/ld: cannot find -lltdl
collect2: ld returned 1 exit status
make: *** [] Error 1

what is with the libphp5 error? Do you know how to fix that? I did a google search of the error, but didn't find much on how to fix it.

All times are GMT -5. The time now is 04:03 PM.