-   Programming (
-   -   configure script not found error (

rhlee 06-07-2012 04:46 PM

configure script not found error
(this is a repost of, just trying to grab a larger audience)

I'm trying to compile the mplayer2 encoder branch statically (because I am slightly modifying the libav libraries).

So I run

configure --enable-static
It always ends with this error:


Checking for Libav (libavutil > 51.21.0:libavcodec > 53.34.0:libavformat > 53.20.0:libswscale >= 2.0.0:libpostproc >= 52.0.0) ...
./configure: 6012: ./configure: pkg-config --static: not found

The relevant lines leading up to line 6012 are:


all_libav_libs="libavutil > 51.21.0:libavcodec > 53.34.0:libavformat > 53.20.0:libswscale >= 2.0.0:libpostproc >= 52.0.0"
echocheck "Libav ($all_libav_libs)"
if $_pkg_config --exists --print-errors $all_libav_libs ; then
  IFS=":"  # shell should not be used for programming
  if $_pkg_config --exists --print-errors $all_libav_libs ; then
  inc_ffmpeg=$($_pkg_config --cflags $all_libav_libs)
  _ld_tmp=$($_pkg_config --libs $all_libav_libs)
  extra_ldflags="$extra_ldflags $_ld_tmp"
  extra_cflags="$extra_cflags $inc_ffmpeg"
  unset IFS
  die "Unable to find development files for some of the required Libav libraries above. Aborting."

with 6012 being the first if statement.

I dumped out the $_pkg_config which is "pkg-config --static". There are no special characters within the string. But for some reason it is as if sh is treating "pkg-config --static" as the name of a binary.

I tried putting various parenthesis around the command, but with no avail:

if [ $($_pkg_config --exists --print-errors $all_libav_libs) ] ; then
What am I missing here?

Reuti 06-08-2012 06:25 AM

Is pkg-config installed on your system?

rhlee 06-08-2012 12:28 PM

I have checked.

I think this a problem with dash. I ran it through gdb and I can see it calling find_command('pkg-config --static', ... )

All times are GMT -5. The time now is 09:24 AM.