-   Programming (
-   -   command with shell script (

sunlinux 12-29-2006 12:07 AM

command with shell script
How do we use execute linux commands as a bunch with shell script. I created following script to to set lan card setting but when i run it give error saying :
[root@mon shll]# ./net
./net: line 1: $: command not found
./net: line 2: $: command not found
./net: line 3: $: command not found
./net: line 4: $: command not found
./net: line 5: $: command not found
./net: line 6: $: command not found

My shell script :
$ cd /sbin
$ ./ifconfig ath0 up
$ ./iwconfig ath0 essid "private net work"
$ ./ifconfig ath0 netmask up
$ ./iwconfig ath0 key 0af21bbbbb
$ ping

what to do to run all commands in a script ?

penguiniator 12-29-2006 12:12 AM

It looks like you are including the prompt character in your commands. The prompt character is the dollar sign ($), which is being read as the command to execute by the shell. Get rid of it on all of the lines of your shell script.

sunlinux 12-29-2006 12:36 AM

DO not Post I hv SOLVED IT...:study:

All times are GMT -5. The time now is 08:26 AM.