LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Other *NIX
User Name
Password
Other *NIX This forum is for the discussion of any UNIX platform that does not have its own forum. Examples would include HP-UX, IRIX, Darwin, Tru64 and OS X.

Notices


Reply
  Search this Thread
Old 07-03-2009, 10:54 PM   #1
moron76
LQ Newbie
 
Registered: Jul 2009
Posts: 2

Rep: Reputation: 0
segmentation fault with firefox 3


So I managed to get a copy of athene and I think it's just fabulous albeit a little outdated.

SO, I tried to get a copy of firefox 3 to run. Success! by following these instructions:

http://blogs.warwick.ac.uk/mikewilli.../of_firefox_3/

as well as installing dbus libraries.

Well, firefox 3.5 didn't work but firefox 3.0 did. But I wanted to get flash to work.

Installing flash plugin I get an error that I need glibc 2.4. OK. SO compiled glibc to prefix /usr/local/me (where I installed the other libraries as per instructions from link).

Now I get a segmentation fault when I try to run firefox. What gives?

Any ideas?
 
Old 07-04-2009, 04:26 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,402

Rep: Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611
Welcome to LQ.

Glibc-2.4 may be corrupt ?
Did the 'make check' pass the tests ? ?

A possible solution : Use a 'flash-player'
meant for Suse 10 ( If that is your OS.)

http://rpm.pbone.net/index.php3?stat...0-1.1.i586.rpm
> > flash-player-9.0.48.0-1.1.i586.rpm
.....
 
Old 07-04-2009, 10:32 AM   #3
moron76
LQ Newbie
 
Registered: Jul 2009
Posts: 2

Original Poster
Rep: Reputation: 0
First of all, thanks for responding.

I'm not sure what "make check" does or how/when to run it. All I know is ./configure, make, make install. Can you elaborate on this.
 
Old 07-04-2009, 01:28 PM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,402

Rep: Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611
For building a working Glibc, please use the
instructions in LFS, e.g. version 6.3
ftp://ftp.eenet.ee/pub/gentoo/distfi...3-HTML.tar.bz2
Glibc : Sections 5.6 and 6.9
... or book-6.2
http://www.linuxfromscratch.org/lfs/downloads/6.2/
./configure --<option> --<option> && make && make check &&
make install .
.....
But why not give an older flash player a try ?
Building a usable glibc isn't necessarily easy.
.....

Last edited by knudfl; 07-04-2009 at 01:29 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
firefox segmentation fault FrancescoPx Linux - Software 3 12-07-2006 02:37 PM
Firefox segmentation fault issue. M$ISBS Linux - Software 3 06-30-2006 11:03 PM
Segmentation fault - Firefox satimis Linux From Scratch 2 08-26-2005 04:57 AM
Firefox 1.0 segmentation fault rutgerw Linux - Software 13 03-01-2005 06:12 AM
Firefox Segmentation fault. RoaCh Of DisCor Linux - Software 12 12-08-2004 01:36 PM

LinuxQuestions.org > Forums > Other *NIX Forums > Other *NIX

All times are GMT -5. The time now is 05:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration