LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Other *NIX
User Name
Password
Other *NIX This forum is for the discussion of any UNIX platform that does not have its own forum. Examples would include HP-UX, IRIX, Darwin, Tru64 and OS X.

Notices


Reply
  Search this Thread
Old 05-13-2008, 05:09 PM   #1
daihard
Member
 
Registered: Jul 2003
Location: Seattle, WA
Distribution: Kubuntu 14.04 LTS
Posts: 915

Rep: Reputation: 34
How to skip a starup process in HP-UX?


Hi.

I've been trying to sort this out for half a day with no success. Hopefully that's going to change.

Our company changed our network configuration quite drastically over the weekend, including changing the domain name. Being familiar with Linux, I managed to reconfigure our NIS server (running RHEL 4). However, our HP-UX machines, which are all NIS clients, refuse to complete the bootup process.

The culprit is the ypbind subsystem, which looks for an old NIS server (nis1.olddomain.com) whereas the new NIS server is running as nis1.newdomain.us. The address of the DNS server has changed as well. As the result, the ypbind keeps trying, even after the login prompt shows up. The end result is that we can't log in at all.

I have tried booting them up in single-user mode. The problem is, /usr doesn't get mounted so I can't use any of the editors (vi, ed, pico, etc) to change the configuration files.

What should I do now? Some googling told me that any "busy" subsystem should fail after 30 mintues, but I'm not so sure. As far as I can see, the ypbind process has been holding up for long than that.

Any help would be much appreciated.

Dai
 
Old 05-13-2008, 09:47 PM   #2
eggixyz
Member
 
Registered: Apr 2008
Posts: 310

Rep: Reputation: 30
Hey There,

I believe if you hit ^B to get the system console and then run : hpux -is

even if /usr doesn't get mounted, you should be able to get to the startup scripts in /etc/rc.config.d and comment out that startup

Best wishes,

Mike
 
Old 05-13-2008, 11:17 PM   #3
daihard
Member
 
Registered: Jul 2003
Location: Seattle, WA
Distribution: Kubuntu 14.04 LTS
Posts: 915

Original Poster
Rep: Reputation: 34
Quote:
Originally Posted by eggixyz View Post
Hey There,

I believe if you hit ^B to get the system console and then run : hpux -is

even if /usr doesn't get mounted, you should be able to get to the startup scripts in /etc/rc.config.d and comment out that startup
Hi Mike!

Thanks for the reply. Yes, I've gotten to the point where I can run "hpux -is" to get into the single-user mode. The trouble is, since /usr isn't mounted, there's no editor program available to open and edit /etc/rc.config.d. Or is there a way that I can do that without loading the file into editor?

Thanks again!
Dai
 
Old 05-13-2008, 11:49 PM   #4
eggixyz
Member
 
Registered: Apr 2008
Posts: 310

Rep: Reputation: 30
Hmmm...

If you have the disk mirrored, after ^B, issue your normal boot command and then answer y to the question about whether you want to stop at the ISL prompt.

At that prompt, type: display -- that should show you paths to all your disk. Note the secondary
then, if it's not set, type: altpath (with the secondary disk path)

if it's already set, try doing a boot from the altpath.

Alternatively, you could change the primpath variable to be the path to the secondary disk and just do a regular boot.


Depending on your situation, you might be better off just booting off of the cdrom into single user mode, mounting up the user partition rw and comment out the startup script.

Let me know if none of this is helping BTW, what version of HP-UX are you running and what kind of box is it on. Just in case, since there are some big differences between the lower-level commands between versions of the OS and between some of the different classes of servers.

Best wishes,

Mike
 
Old 05-14-2008, 08:02 PM   #5
daihard
Member
 
Registered: Jul 2003
Location: Seattle, WA
Distribution: Kubuntu 14.04 LTS
Posts: 915

Original Poster
Rep: Reputation: 34
Hi Mike.

Thanks again for all your suggestions. I have finally been able to get the HP-UX machine up and running again. Here is what I've done:

1) Booted it up in single-user mode.
2) Run "ch_rc -a -p NIS_CLIENT /etc/rc.config.d/namesvrs" to disable the NIS client daemon.
3) Restarted the machine.

With this, I was finally able to get past the ypbind process. I had to repeat the same steps twice more to bypass two other processes, but I at least knew what I was doing.

Little did I know that there was a command to change the configuration parameter values of /etc/rc.config.d files like "ch_rc." I guess I did not do enough googling around.

I ran into another issue at the console prompt. After a few more minutes of googling I found that you cannot login as root at the console if your root password contains special characters! I went back to the single-user mode, changed the root password, and then finally managed to login to the system.

The machine is now up and running smoothly. I have learned a lot. I have a few other HP-UX machines to deal with, but now I know what to do. Thanks again for all your help!

Dai

Last edited by daihard; 05-14-2008 at 08:04 PM.
 
Old 05-14-2008, 09:15 PM   #6
eggixyz
Member
 
Registered: Apr 2008
Posts: 310

Rep: Reputation: 30
Hey There,

Glad I could help. I didn't know about the ch_rc command either. That's "huge" I'm going to keep that in mind the next time I'm thinking of going the torture of booting single user off of the media dvd!

Thanks

, Mike
 
Old 05-15-2008, 03:01 PM   #7
daihard
Member
 
Registered: Jul 2003
Location: Seattle, WA
Distribution: Kubuntu 14.04 LTS
Posts: 915

Original Poster
Rep: Reputation: 34
Quote:
Originally Posted by eggixyz View Post
Hey There,

Glad I could help. I didn't know about the ch_rc command either. That's "huge" I'm going to keep that in mind the next time I'm thinking of going the torture of booting single user off of the media dvd!

Thanks
Glad I was able to help, too.

Now, I am against another wall... this other HP-UX machine (PA-RISC 9000/785) running HP-UX 11 will not get into the single-user mode. I press <Escape> right after the boot sequence starts, but it still boots the primary path. What can I do about it?

It has FASTBOOT enabled. I'm not sure if it's relevant. Since I cannot get the machine up and running without changing the configuration parameters, I will not be able to disable FASTBOOT either, even if that is the culprit.

Boy oh boy...
 
Old 05-15-2008, 03:45 PM   #8
Asy
LQ Newbie
 
Registered: May 2008
Location: The Netherlands
Distribution: Ubuntu
Posts: 25

Rep: Reputation: 16
In the console you get a message like

touch any key to interrupt the boot within 10 seconds

then hit the <any key>

then boot pri # to boot the primary path

interact with ISL yes

ISL> hpux -is

it is possible after the boot into single user to mount more disk.
try the mount command.

perhaps you are not using the shell you are normaly using.
It's in single user the bourne shell, this is acting in a different way as the ksh.

cd to the home of root and execute the profile
or set the path to /sbin:/usr/bin and you get more tools to edit your files.

Asy

Last edited by Asy; 05-15-2008 at 03:49 PM.
 
Old 05-15-2008, 04:13 PM   #9
eggixyz
Member
 
Registered: Apr 2008
Posts: 310

Rep: Reputation: 30
Hey There,

If you have console access, you could try ctl-b to break into the lower level, too. If you've tried that and the hit-any-key solution, I'm stumped for now, too. I'll see if I can find anything on that.

BTW, how are you connecting to the machine (telnet or ssh to a terminal server connected to console, direct console, etc). That might help if this gets ugly

Take it easy, man,

Mike
 
Old 05-15-2008, 06:14 PM   #10
daihard
Member
 
Registered: Jul 2003
Location: Seattle, WA
Distribution: Kubuntu 14.04 LTS
Posts: 915

Original Poster
Rep: Reputation: 34
Quote:
Originally Posted by Asy View Post
In the console you get a message like

touch any key to interrupt the boot within 10 seconds

then hit the <any key>

then boot pri # to boot the primary path

interact with ISL yes

ISL> hpux -is
Thanks for the response.

The issue is, I don't get that prompt on that particular machine. We have two "Workstation b2600"s. One of them shows the prompt, and I was able to boot in the single-user mode there. It is this other b2600 that doesn't give me that option. Any other idea?
 
Old 05-15-2008, 06:54 PM   #11
eggixyz
Member
 
Registered: Apr 2008
Posts: 310

Rep: Reputation: 30
Hey There,

Two more options if ctl-b doesn't break you out to console.

If you can, disconnect the keyboard and power up the b2600, that should get you an ISL> prompt. Then plug the keyboard back in.

One other thing, for now, check around the back of the system for the TOC (Transfer or control) button (you'll probably need a pen or something to push it. It should cause a controlled system crash and reboot, which might help (at the worst, you might get some decent diagnostic information - If it spits out system codes and proceeds to hang again, just repeat and get as much of the info as possible. If you post it here and I have the information, I'll let you know what it might mean. If you have the box under warranty, HP should be able to diagnose the situation a lot easier with that information.

Good luck, still!

, Mike
 
Old 05-15-2008, 09:47 PM   #12
daihard
Member
 
Registered: Jul 2003
Location: Seattle, WA
Distribution: Kubuntu 14.04 LTS
Posts: 915

Original Poster
Rep: Reputation: 34
Quote:
Originally Posted by eggixyz View Post
Hey There,

Two more options if ctl-b doesn't break you out to console.

If you can, disconnect the keyboard and power up the b2600, that should get you an ISL> prompt. Then plug the keyboard back in.
Thanks for the advice. I will give that a try tomorrow. One thing I've noticed is that if you unplug the keyboard from an HP-UX machine, it will shut the machine down. I'm not sure if it is the defined behaviour of all HP-UX computers, though.

Now, I am onto the last two machines - two Integrity rx2620's. I booted one of them up into the single-user mode. I got the command prompt successfully, but then the keyboard suddenly doesn't work anymore. Different workstations, different problems...
 
Old 05-15-2008, 10:02 PM   #13
eggixyz
Member
 
Registered: Apr 2008
Posts: 310

Rep: Reputation: 30
Man, you're having a rough week

For that last machine you might have to hook a terminal connection up to the serial port. Got any old WYSE terminals laying around?

Best of luck, I'll keep my ears open for ya!

, Mike
 
Old 05-16-2008, 12:23 AM   #14
daihard
Member
 
Registered: Jul 2003
Location: Seattle, WA
Distribution: Kubuntu 14.04 LTS
Posts: 915

Original Poster
Rep: Reputation: 34
Quote:
Originally Posted by eggixyz View Post
Man, you're having a rough week

For that last machine you might have to hook a terminal connection up to the serial port. Got any old WYSE terminals laying around?
That may be it. The machine was originally configured to use a serial console. I changed its primary console device to VGA so I can hook it up to a standard monitor. I believe we have a dumb terminal laying around somewhere. I'll look for it tomorrow.

Thanks!
Dai
 
Old 05-16-2008, 09:18 AM   #15
eggixyz
Member
 
Registered: Apr 2008
Posts: 310

Rep: Reputation: 30
Cool,

Hope it goes well

, Mike
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
starup and shutdown on FC 7 harpoon45 Fedora 2 01-01-2008 03:00 PM
Starup programs Mojojo Linux - Software 2 03-07-2007 10:30 AM
skip a process when pc is booting totti10 Mandriva 4 11-15-2004 12:19 PM
slax starup music Maver Linux - Distributions 5 06-26-2004 11:05 AM
Skip a step in the Email process langman Linux - Networking 6 02-25-2004 07:16 AM

LinuxQuestions.org > Forums > Other *NIX Forums > Other *NIX

All times are GMT -5. The time now is 04:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration