LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > MEPIS
User Name
Password
MEPIS This forum is for the discussion of MEPIS Linux.

Notices


Reply
  Search this Thread
Old 06-09-2005, 10:46 PM   #1
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Rep: Reputation: 49
my eth0 is not coming up


I installed Mepis 3.3 and I have a strange problem.

My network requires me to use static IP .

So, in Mepis OS Center, Under the networking Tab, I entered the Static Nameservers (DNS Settings) and under eth0, i entered the static IP addresses.

Now, when i am told that I should restart the network, eth0 doesn't come up.

SO, this results in no internet connection in Mepis.

i have Ubuntu installed, that works absolutely fine.

What is wrong with MEPIS?

I found that there was no host mentioned in the /etc/hosts file and added the IP address of my machine there.(Using the help provided by Mepislovers.org)

Still no luck.
 
Old 06-10-2005, 01:41 AM   #2
joosep
LQ Newbie
 
Registered: Jun 2005
Location: Estonia
Distribution: MEPIS
Posts: 23

Rep: Reputation: 15
I have the same problem, but i use DHCP. I need to manually bring up eth0 every time using
Code:
# ifconfig eth0 up
 
Old 06-10-2005, 01:50 AM   #3
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Original Poster
Rep: Reputation: 49
Sure I will try that.

But my problem was like, no matter how many times i click on start eth0, it won't come up.
Hold on, i will try your idea!
 
Old 06-10-2005, 12:31 PM   #4
Garibaldi3489
Member
 
Registered: Oct 2004
Posts: 172

Rep: Reputation: 30
I'm having the same problem. On the live-cd it activates eth0 fine and uses DHCP to auto detect my settings fine, but on my new hd install it doesn't work, and no matter how many times I try to start it (its grayed out) or use ifconfig eth0 up it just says "device doesn't exist." Why would it be different from the live-cd?
 
Old 06-10-2005, 12:48 PM   #5
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Original Poster
Rep: Reputation: 49
Same here, works perfectly with Live Cd, but not with HDD install.

However, I found a cheap way to do that.

What I did was I changed the settings for eth0 to DHCP and then tried to start eth0.
But it did not.
Then I changed the settings back to static.
Then, whoo -whee eth0 was up.


But, still i can't login to my ISP account, and so there is still no Internet connection in MEPIS.

Please help me out of this situation.
 
Old 06-10-2005, 04:19 PM   #6
pofadda
Member
 
Registered: Jan 2005
Location: Bristol, UK
Distribution: Depend on what was loaded yesterday...
Posts: 50

Rep: Reputation: 15
This is NOT Mepis experience talking. but...

had the same problem with a laptop running XP SP1 today. A chance look at the icon of the share (a Windoze term, kiddies) showed a tiny yellow blob next to it. It looked like a lock... it was! The firewall had been set on by default!

Is guarddog on Mepis screwing you around, maybe?

My 2 piase worth

Pofadda
 
Old 06-10-2005, 04:30 PM   #7
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 48
Try entering your IP like this:
# /sbin/ifconfig eth0 init 192.168.2.1 netmask 255.255.255.0

the ip/netmask are examples only.

KC

Last edited by kencaz; 06-10-2005 at 04:31 PM.
 
Old 06-11-2005, 05:49 AM   #8
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Original Poster
Rep: Reputation: 49
Thanks man.

I tried that out, but it returned me some error.

Now, I disabled Guard Dog, and now, I am in.

I think that my OS Center is buggy............even if eth0 is stopped, I can ping my Gateway.

So, this means that it is ON.

Internet now working fine in Mepis.
 
Old 11-05-2005, 03:25 AM   #9
greench
LQ Newbie
 
Registered: Aug 2005
Location: Whoville
Distribution: Debian 3.1
Posts: 1

Rep: Reputation: 0
Unhappy

I`m using Debian 3.1 and have the same problem (my eth0 and eth1 want coming up). The network card which is eth1(DHCP), is the one I would like to use automatically.I don't have a network cable plugged into eth0, because I`m not using it in the moment. When I restart the PC and run it under recover mode - it finds eth1(DHCP) and 'utilieses it' but it doesn`t detect the eth0(But why? ) . OK everything is working successful except one thing when I start it in 'normal' mode it doesn`t detect the both eth. Please help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie Question: Route all request coming from eth1 to ppp0/dsl0/eth0 hansschmucker SUSE / openSUSE 0 02-12-2005 10:38 PM
eth0 not coming up quick enough on MDK 10 Official shea1roh Mandriva 1 10-04-2004 02:19 PM
eth0 not coming up on boot after 2.6.5 recompile agoatley Linux - Software 2 05-29-2004 05:20 AM
eth0 not coming up after boot liquidcool Linux - Networking 4 04-23-2004 04:53 AM
need help urgently!!! display not coming and error mesage coming when user is logging rddreamz Linux - Newbie 0 08-14-2003 12:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > MEPIS

All times are GMT -5. The time now is 03:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration