-   MEPIS (
-   -   MEPIS v6.0 & Canon Printers (

craftybytes 10-21-2006 01:16 AM

MEPIS v6.0 & Canon Printers
Hi all,

Well I installed Mepis 6.0 and most of it worked quite well!
Was surprisingly quick and easy to install and set up.

However - ONE BIG PROBLEM!!!!! It seems that since switching to the Ubuntu base, if one owns a Canon printer (specifically any PIXMA models) one certainly can install the required printer files successfully BUT the printer just WILL NOT WORK.

I have a Canon Pixma MP110 multifunction printer that worked well under MEPIS v3.4-3 but will not work at all under MEPIS v6.0. It seems that the "cups" side of things may be broken (for such printers) in MEPIS v6.0 - found out this little bit of very disturbing info from reading posts in several forums describing said problem with the Canon Pixma model printers.

Just wondering if any of you forum members have had similar problems with this?

Anyway as I prefer to have a printer that works I have reverted back to MEPIS v3.4-3 till the issues with this problem have been sorted out - a real bummer as most everything else in MEPIS v6.0 worked a treat.

Any comments would be appreciated - specially from those in the know!!

sleepyEDB 10-23-2006 08:34 AM

Send an email to the Mepis development team. I know that printer compatibility was high on their list when preparing for this's possible they know a fix that the people on the other forums don't, or that you would be the first to bring it to their attention and eventually help make Mepis better for everyone! :)


craftybytes 10-24-2006 12:50 AM

Thanks sleepEDB for your reply!!

Funny you should mention that - I was giving it some consideration.

After reloading simplyMEPIS v3.4-3 (I had previously used it for almost 6 months up until I upgraded to SMv6.0 3 weeks ago) - had almost the same problem re-installing the Canon printer setup. Then I remembered that I needed to install a specific dependency - libpng10-0 (>=1.0.18) OTHERWISE the printer just wouldn't work. I one of my more active brainf***d moods a while back I had modified the ./control file in the printer .deb file to upgrade to libpng12-0 as dependency - thought that might solve the problem - BUT NO GO - it had to be libpng10-0 or nothing worked.

So I'm thinking that as I didn't do the install for this libpng10-0 when in SMv6.0 maybe that could be the cause for the printer to not work - will maybe have to check it out some time in the future - now that I'm back on SMv3.4-3 again and everything is working as I want it to - I'm relunctent to go through the hassle of upgrading to SMv6.0 again just to find out I'm wrong again. Ah well we live and learn!!!

Thanks anyway.

sleepyEDB 10-24-2006 08:51 AM

I'm glad to hear things are working for you, but sorry to hear that it took a downgrade to a previous version to accomplish that. :(

I think you'll find the Mepis team rather approachable in terms of bug reporting and things like that. I've heard of several cases where people were able to get help on certain issues from Warren himself! I imagine they'd like to hear about any printer-related issues; especially with a Canon printer which is a well-known brand and should (as far as I'm concerned) be supported if Mepis is to remain among the top distros.


craftybytes 10-25-2006 09:15 PM

Thanks for the reply. I'm seriously considering loading up SM v6.0 again - I've got SM v3.4-3 on a 38GB partition at the mo - so maybe scribing off say 10GB of that for SM v6.0 won't be too much of a hassle - will give me a proper chance to try it out and still give me a backup of SM v3.4-3 if things don't go as hoped...

Anyway, if I still have probs with getting the Canon printer to work in SM v6.0 this time, THEN I'll submit a report to the Mepis team. And yep, the Canon printers are a well known brand and DEFINITELY there should be more support from the Linux distros - especially Mepis - if we are to keep it up there in the top 5!!!


esage 11-16-2006 06:43 PM

Canon Pixma iP3000
I have an iP3000 and it works w/o any problems on Mepis 6.0 Final. That's all the info I have.

craftybytes 11-16-2006 11:42 PM

Hi esage,
I have a Canon MP110 which works ok for printing using the ip1500 drivers - but no scanner yet - in SM v3.4-3.

Downloaded the Canon .deb drivers as needed and installed them then ran the printer setup and installed the printer no hassles in SM v3.4-3 - but in SM v6.0 - the drivers installed ok but nothing came up in the printer install screen for the drivers so could'nt select the correct drivers for the printer to work - that's why I went back to SM v3.4-3 - it all works very well under SM v3.4-3 without too much tweaking - yet in SM v6.0 I found one had to do a fair amount of tweaking of various settings in many of the installed progs to get them to work as good as they did in SM v3.4-3 - and even then some of the settings required some extra fine tuning to get them to do what they did in SM v3.4-3.... So decided that till Warren and the team get SM v6.0 up to the same standard of working as SM v3.4-3 - then I would stay with SM v3.4-3 for now AS EVERYTHING WORKS JUST AS I WANT IT TO without too much tweaking involved!!!!

Thanks for your reply anyways!.

All times are GMT -5. The time now is 02:45 AM.