LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   MEPIS (https://www.linuxquestions.org/questions/mepis-64/)
-   -   I need a walktrough (https://www.linuxquestions.org/questions/mepis-64/i-need-a-walktrough-366130/)

Blitzkreig75 09-22-2005 10:40 PM

I need a walktrough
 
I can't get Firefox to play video online. I've gotten mozilla mplayer installed via kpackage, but still nothing plays. I receive an online mag that contains daily video, but when I go to view it, the page just loads and nothing plays. I don't get any kind of prompt at all. I've tried to find the "mozilla-firefox/plugins" on my system, but kwrite says the file doesn't exist,(I was told by a moderator at MepisLovers to delete all the mplayer out of the plugins, then I would be promted to select what program to use when the page loads).

The part I"m really confused about is that Firefox acts as if there isn't even video there, at least there's no kind of response to it, nothing that I can identify.

So, I guess I need a step-by-step solution to get the video to at least be recognized, then I can work on getting it to play.

Can someone help an impatient idiot?:cry:

aysiu 09-22-2005 10:48 PM

My guess is that one of these links has to be useful:

http://66.102.7.104/search?q=cache:o...=en&lr=lang_en
http://66.102.7.104/search?q=cache:r...=en&lr=lang_en
http://66.102.7.104/search?q=cache:B...=en&lr=lang_en
http://66.102.7.104/search?q=cache:7...=en&lr=lang_en
http://66.102.7.104/search?q=cache:g...=en&lr=lang_en

kencaz 09-22-2005 10:52 PM

Well, if you see the mplayer plugin load then it's not a plugin problem but a codec problem... What type of video are you trying to view?

mplayer -vc help

will list all your available codecs. Check that you have the needed codec for the format your attempting to play first

KC

Blitzkreig75 09-22-2005 11:02 PM

aysiu, those links are helpful. I'll try some of those things.

kenkas, when I go to the page where the video is, I get nothing except the pictures and text. No plugin stuff at all.

I'll try some things tomorrow, it's getting late on my end. Time to go to bed.

Thanx, yall'

Blitzkreig75 09-23-2005 10:22 PM

Alright, Ive looked around on my unit. I have the mplayer plugin fir mozilla-firefox, but I can't seem to locate any codecs at all.

Blitzkreig75 09-23-2005 10:40 PM

I looked at the online site where the video is, and the properties lists the link as "javascript:show(0,1)"
the #'s go up- "...(1,1)....(2,1).." and so on. When I try to veiw image, this is what it says,
"The requested URL /members/magMembers/images/fmg/ss/undefined.jpg was not found on this server"
I know it's there, I can view it on my Windows computer just fine.
Is any of this helpful?

kencaz 09-23-2005 11:39 PM

so what is the output of:

mplayer -vc help

you need to D/L and extract the Win32 codec package to /usr/lib/win32

go here for more info:

http://www.mplayerhq.hu/homepage/design7/codecs.html

KC

Blitzkreig75 09-23-2005 11:45 PM

Alright, I think I'm getting somewhere! mplayer -vc help slammed down a list of things, then, after "rawyvu9..." it says "null.....null....crashing NULL codec (no decoding!)

When I try to do apt-get install w32codecs.HTH. it says "cannot find package".

kencaz 09-23-2005 11:58 PM

get the "Windows all" .zip package from the link I gave you and extract it to:

/usr/lib/win32

you should not need to re-compile mplayer... then run

mplayer -vc help

and just try your file again.

KC

Blitzkreig75 09-24-2005 12:31 AM

I successfully completed that operation, and it changed nothing.

kencaz 09-24-2005 12:37 AM

try downloading the file and run it in a console so we can get the exact output Mplayer is putting out. we still are not sure it's a codec issue...

KC

Blitzkreig75 09-24-2005 12:45 AM

I can't download it. The computer, (eithr Firefox or Mepis), doesn't even find any video. If I right-click on where the video is supposed to be playing, I get an option to view an image, no playback options. The "forward" and "stop" options are greyed out.

Blitzkreig75 09-24-2005 12:54 AM

I may have discovered something: I went to another site related to my mag, and it prompted me to download Windows Media Player 10 as a manual plugin. So, I think I need a plugin that will play Windows Media Player things. Does that sound right?

kencaz 09-24-2005 12:59 AM

sounds right. I have trouble on some sites using the embedded mplayer plugin for .wmv and other will work. but either way I can play the files if downloaded.

Try finding, downloading, and playing a .wmv format file (most likely what they are using). See if you can play it through mplayer not using the browser plugin. If so you know it's not a codec problem...

Post the site as well and see if other can play the file...

KC

Blitzkreig75 09-25-2005 11:45 AM

Someone on TechIMO says that if it's a DRM, it won't play at all in Linux. I think it is, since when I watch it in my Winows unit, the player says "Aquiring lisencing agreement.." prior to buffering.

I won't post the site because it's an adult site.

I'll try to download anothr .wmv file and see if I can get it to play.


All times are GMT -5. The time now is 06:07 PM.