-   MEPIS (
-   -   Dual Boot Mepis & XP on same SATA 2 drive (

mdlinuxwolf 12-14-2006 03:48 PM

Dual Boot Mepis & XP on same SATA 2 drive
This is my first post here. I'm from MD and I'm Windows and Comptia certified. I just installed Mepis and this is my 1st question. So, here it goes.

I'm having problems dual booting Windows and Mepis on the same drive. I changed from SuSE 10 to Mepis because SuSE doesn't "do" SATA drives at all and my new SATA is a 1/4 terabyte. :cool:

Promise technology says that they have a driver for SuSE 10 that fits on a floppy but there driver won't install under bin, is 1.47 MB so it doesn't fit in a floppy as needed and you can't add a non-standard hard drive controller under the repair menu.

It gets even weirder. Mepis can easily mount the windows drive and move data around it. When the boot loader pops up, it even shows Windows as a choice, both the sda2 and sda3 partitions. Sda2 is a fat32 with nothing on it and sda3 has XP. When you click on it, tht GUI drops away and switches you to a command line which is identical to the GUI. When you click on it again, nothing happens. At that point, booting into Mepis is the only choice you have.

Even Mandrake 10.1 was able to dual boot with Windows. SuSE 10 could also do the same thing. Neither can see a SATA drive, however. Both were using 2 IDE physical drives, a 10 gig drive for Linux and a 20 gig drive for windows.

I have one partition with about 107 gig as NTFS, one with the Ext3 file system for Mepis (which doesn't use Reiser files), one 20 gig which is FAT32 with nothing on it and the rest left over as unallocated or for swap partitions.

Is there anywhere I could get LILO to work with Mepis in a Debian version?

LILO under Mandrake was the best bootloader ever. You could move it around from drive to drive, pick default operating systems to boot without any trouble. Mandrake, however, couldn't see any of my NICS. :(

One other little nitpick, my graphics only goes up to 1024*738 and cycles at 70hz. The monitor will do 1600*1200 and 90hz under XP. I did install the nvidia driver, not the generic one.

Is there a way to increase the resolution?

Caeda 12-14-2006 03:56 PM

Suse "does" sata just fine. I have 2 system with sata that work perfectly with 10.1

Did you try using 10.0 which is now massively out of date? Or 10.1 which was up to date right up until they released 10.2?

mdlinuxwolf 12-14-2006 05:41 PM

I tried upgrading to 10.1. I wiped it out and started over because it couldn't play the multimedia stuff that I worked hard to set up and it wouldn't even see my wireless card. Although 10.1 looked pretty, it did far less for me then 10.0 did. Mepis currently sees my old D-Link wireless card, that I'm using now. If you upgrade an operating system, it should preserve most of your settings.

SuSE 10.0 can use a Linksys 802.11g PCI wireless card instantly with no configuration with DHCP even before it is done installing !!!! Aside from not doing SATA 2, SuSE 10 is wonderful. YasT is a little buggy, but that is normal. 10.1 does less. It is like half the drivers are gone and I think that may be for legal reasons. It is just like how you have to uninstall Xine and go to packman Linux to watch movies because SuSE can't give you libdvdcss.

With Mepis, that isn't a problem. It would be nice to get more resolution with the monitor and to be able to boot into XP. After all, no computer is safe with just one operating system. Dual booting builds fault tolerance into a computer, especially an older one. I chose Mepis just because it does SATA 2.

Actually, I solved the original problem. (I'm editing the post) I just deleted the unnecessary partitions, ran the fixmbr off of the XP CD, ran the default boot loader repair option from the Mepis 6 live CD and now everything is fine. I have 40 gigs worth of unallocated partitions to play with. Of course, I could resize the partitions to take up the slack, but I have no reason to do so since space ien't an issue.

All times are GMT -5. The time now is 10:15 PM.