-   MEPIS (
-   -   Can't play music (

ronepowell 04-03-2007 09:07 AM

Can't play music
I installed RC3 on a new HP laptop and was delighted that mepis connected to internet without all the grief that I experience with the other distros.
However, for some reason, when I go to play any kind of music, amarok, kaffeine, realplayer, will not play. The sound card is working (at least it makes sounds when booting in), so is there something I can do to configure the various media programs to work?

Matz 04-03-2007 09:14 AM

What kind of media did you try to play, and what kind of response you get from media players when you try to play it?

ronepowell 04-03-2007 09:19 AM

Usually mp3s, and also tried streaming from Shoutcast. Realplayer starts to play but the sound breaks up. Amarok and Kaffeine just do not play at all. Very strange.

mos 04-03-2007 12:40 PM

apt-get install libmad0

ronepowell 04-03-2007 01:10 PM

Thanks, but as it turns out, the latest version is already installed. Strange thing is that RealPlayer 'almost' works, but the other programs (including mplayer) don't give any sign of life.

tekkieman 04-03-2007 02:13 PM

Are you sure? As I recall, only the dummy file is included (legal reasons). It usually requires a refresh in synaptic, then installing libmad as mos suggested.

ronepowell 04-03-2007 04:20 PM

Don't know if I made things better or worse, but I uninstalled libmad0, and reinstalled it. Still no music. Now, however, Amarok tells me 'currently cannot play mp3 files', and has the button 'install mp3 support', which I clicked on, was told that I now had support but close and reopen. Made no difference at all.

mepnoob2005 04-04-2007 12:43 PM

Try getting lame from synaptic. Get libk3b2mp3 too. Liblame0 and libmad0 may help you too. libxine-extracodecs. Kdemultimedia-kio-plugins. Get VLC. Vlc has a lot of it's own codecs that will work with apps you now have. Sometimes an upgrade will hoop amarok but rhythmbox will usually play every time. I have had to use rhythmbox now and then but not for a while.
Try using oss instead of auto-detect or alsa. Oss is cleaner sounding for me.
That 'install mp3 support' box got me too but it was a few weeks ago. Things seem good now.

tzonga1 06-02-2007 09:09 PM


Installed via yum libmad0. I can now play MP3s under FC5 using Amarok. The FC help pages are usefull for activating yum.

archtoad6 06-03-2007 09:38 AM

Excuse me, why are you posting a Fedora solution to a MEPIS problem in the MEPIS forum? You really ought to know that yum is not available in Debian-based distros. We have something that we passionately believe is superior: .deb, APT, & Debian Policy.

Many of us, myself included, who have used both (yum & APT) think that the former is an unmitigated piece of crap. In fact, I think that some of my FC-using friends say that FC is dropping yum & going to use APT. At least that is what I thought I heard.

Sorry if this seems rude or too harsh, but your off-topic post ticked me off.

mepnoob2005 06-04-2007 09:58 AM

Sound set up help
ronepowell....did you try the help info that I left on my last post? Have you re-booted lately? Have you got kmix set up right?
Here are some links that may help you.

All times are GMT -5. The time now is 08:37 AM.