LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Manjaro (https://www.linuxquestions.org/questions/manjaro-119/)
-   -   Black Screen after Suspend (https://www.linuxquestions.org/questions/manjaro-119/black-screen-after-suspend-4175653973/)

Mr.Muffins 05-15-2019 03:30 PM

Black Screen after Suspend
 
Hey guys, noob here.

Just installed Manjaro today on a SanDisk Ultra 128GB flash drive, just trying to fix some hiccups along the way so I can have a fully working portable Linux.

When I suspend my computer, it comes back with a black screen & nothing that I do works. (Pressed all buttons and had to do a hard reset).

I installed hardinfo and exported a report if you need to know what my specs are.

Any help or guidance is appreciated.

Lysander666 05-15-2019 03:45 PM

How did you suspend? Did you close the lid or suspend from the logout menu?

Sometimes closing the lid is not the best way, doing it manually from the logout menu is way more reliable [takes about 2 more seconds].

I have found in the past this is to do with an old out-of-date kernel. Just in my use-case. I am not a Manjaro user, but if you just installed Manjaro today I would encourage updating everything.

Mr.Muffins 05-16-2019 08:36 AM

Thanks for the reply!

Yesterday, closing the lid or suspending it manually did not work. I tried different things, but I gave up last night and went to sleep.

This morning, I tried to repeat the problem but now it's not doing the black screen anymore??? Maybe letting the laptop cool down for the night or disconnecting the USB flash drive fixed it?

I have no idea what fixed the problem, but if it comes back I'll let you know.


All times are GMT -5. The time now is 07:13 PM.