LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 11-18-2003, 11:39 AM   #16
FF103
Member
 
Registered: Aug 2003
Location: Kentucky
Distribution: Mandrake 10.1
Posts: 157

Original Poster
Rep: Reputation: 30

Thank you ,michaelk and tricky_linux for the suggestions. Yes I did try to mount the drive and I got somewhat of a strange response. I tried "mount /dev/sda mnt/zip" and it mounted the drive but would only display 1 file on the disk, which makes me think it only maybe mounted 1 partition? ( is that possible?) If I tried "mount /dev/sda4 /mnt/zip" I got a Error " no such file in fstab or mtab" but I know it's there.Sooooo at the risk of screwing everything up I reloaded the OS and kept all my home files,I did this to clean up the fstab and to try and start fresh. So, now I am back to trying to open the zip drive and getting the error "unable to enter directory /mnt/zip" So here I am. I really appreciate all the help on this. I'm kinda at my wits end with this thing.
 
Old 11-18-2003, 12:13 PM   #17
michaelk
Moderator
 
Registered: Aug 2002
Posts: 20,402

Rep: Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548
What are the permissions for /mnt/zip?
ls -l /mnt/zip

Have you tried mounting the drive logged in as root?
 
Old 11-18-2003, 07:32 PM   #18
FF103
Member
 
Registered: Aug 2003
Location: Kentucky
Distribution: Mandrake 10.1
Posts: 157

Original Poster
Rep: Reputation: 30
Well after getting my blood pressure back down to a comfortable level,I am finally able to mount the zip drive and to read the contents of the disk. Here's what I did. I believe tricky_linux got me in the ball park with "mount /dev/sda" notice the 4 is missing. All tho mandrake insists on calling it sda4,it would not mount it as sda4. I removed th 4 from the fstab line,rebooted and clicked on my zip icon and it opened.Now , how to I get permission to write to the zip disk.Here's the permission file,but I'm not sure how to change it:
total 5144
drwxrwxr-x 3 ray ray 4096 Nov 18 20:19 Desktop/
drwxr-xr-x 5 ray ray 4096 Nov 14 16:04 Documents/
drwxrwxr-x 2 ray ray 4096 Nov 13 12:37 E-mail/
drwxr-xr-x 5 ray ray 4096 Nov 18 07:30 evolution/
drwxrwxr-x 2 ray ray 4096 Feb 28 2003 install_flash_player_6_linux/
-rw------- 1 ray ray 707027 Nov 13 13:17 install_flash_player_6_linux.tar.gz
drwxrwxr-x 3 ray ray 4096 Nov 16 18:47 kcdlabel/
drwx------ 7 ray ray 4096 Nov 18 07:31 Mail/
drwxr-xr-x 3 root root 4096 Nov 8 15:39 mnt/
drwxrwxr-x 3 ray ray 4096 Nov 4 17:37 mp3/
drwxr-xr-x 2 ray ray 4096 Nov 18 07:57 Music/
drwxrwxr-x 3 ray ray 4096 Nov 2 17:19 new pics/
-rw-r--r-- 1 ray ray 3867251 Nov 5 18:58 opera-7.21-20031013.4-shared-qt.i386.rpm
-rw-r----- 1 ray ray 370956 Nov 14 09:13 out.jpeg
-rw-r----- 1 ray ray 229582 Nov 14 08:16 out.pnm
drwxrwxr-x 3 ray ray 4096 Nov 14 19:47 Photos/
-rw-r--r-- 1 ray ray 3583 Nov 4 17:04 prozilla.1
drwxrwxr-x 3 ray ray 4096 Nov 2 16:18 Theresa Pics/
drwx------ 2 ray ray 4096 Nov 18 06:58 tmp/
drwxrwxr-x 2 ray ray 4096 Nov 13 15:45 Video/

Thanks for everyones help ,I really appreciate it.
 
Old 11-19-2003, 10:41 AM   #19
tricky_linux
Member
 
Registered: Jul 2003
Distribution: Red Hat Linux 9.0; Old and Solid
Posts: 674

Rep: Reputation: 30
where are those file located?
All in your zip drive?
If that's the case, then just do "chmod 777 <the file's name>"
or if you want to just have access to all the files just change"
/dev/sda /mnt/zip" to /dev/sda /mnt/zip,umask=000"
Then you will have root access to every file on that disk.
 
Old 11-19-2003, 05:40 PM   #20
FF103
Member
 
Registered: Aug 2003
Location: Kentucky
Distribution: Mandrake 10.1
Posts: 157

Original Poster
Rep: Reputation: 30
Thank you for the reply and also for all your help on this. That last post is the reply from "cd and "ls -l" in a terminal window.I assume that is my permission for all my home files. I was wondering if it was possible to change the permission on the zip drive from root access only to a regular user so that I don't have to switch to root every time I want to write to the zip drive. I think you answered my question, I'll try the chmod command and see if that does it. Again, I really appreciate everyones help on this. Thank You.
 
Old 11-19-2003, 07:06 PM   #21
michaelk
Moderator
 
Registered: Aug 2002
Posts: 20,402

Rep: Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548
In the /etc/fstab file add the option umask=000. This will allow any user to read / write to the zip drive.
 
Old 11-20-2003, 12:25 PM   #22
FF103
Member
 
Registered: Aug 2003
Location: Kentucky
Distribution: Mandrake 10.1
Posts: 157

Original Poster
Rep: Reputation: 30
Thanks for the info michaelk , I'll make that edit to the file as soon as I go offline. Thanks again for all your help on this also, I really appreciate it.
 
Old 02-05-2004, 09:03 AM   #23
Usalabs
Member
 
Registered: Jan 2004
Distribution: OpenSUSE 42.1 Server
Posts: 156

Rep: Reputation: 15
Quote:
Originally posted by Thymox
Mine works fine, make sure your fstab and kernel parameters are correct. Find out which device it is (/dev/hdd?) and add hdd=ide-scsi to your kernel 'append' section. When you boot, make sure your /etc/fstab to reflect the changed with something like /mnt/zip /dev/sda4 auto users,noauto 0 0

Works for me (fstab entry may be skewed, I'm not at a Linux box now).
You say to add hdd=ide-scsi to the kernel 'append' section, but you didn't say how to do it.

I have a zip dive problem, the device is seen as /dev/hdd4 linked to folder /mnt/zip, and the fstab reads:-

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hdb3 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/hdd4 /mnt/zip auto noauto,owner,kudzu 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0

and when I try to mount the device I get '/dev/hdd4: Input/output error
mount: I could not determine the filesystem type, and none was specified' so I changed the /dev/hdd4 setting in fstab to read '/dev/hdd4 /mnt/zip msdos noauto,owner,kudzu 0 0' and it still says the same thing, the dive light flickers but nothing, I checked and the device is using /dev/hdd4 there is no setting for the zip drive in cat /proc/scsi/scsi as the drive is an ide drive. FYI, the drive setup I have physically connected are:-

IDE0=/dev/hdd0=primary/master Linux drive /ext3
IDE1=/dev/hdd1=primary/slave backup drive /ext3
IDE3=/dev/cdrom=Secondary/master Samsung CD-R/W
IDE4=/dev/hdd4=Secondary/slave Iomega Zip100

what is the problem? is the drive incompatible with RH Linux 9? or is it something else?
 
Old 02-05-2004, 04:49 PM   #24
Thymox
Senior Member
 
Registered: Apr 2001
Location: Plymouth, England.
Distribution: Mostly Debian based systems
Posts: 4,368

Rep: Reputation: 63
Sorry. My bad.

You need to edit your bootloader's config file. For instance, the Linux entry (or at least one of them ) in my lilo.conf looks like this:
Code:
image=/boot/vmlinuz
        label="Mandy"
        root=/dev/hda2
        initrd=/boot/initrd.img
        append="devfs=mount hdc=ide-scsi hdf=ide-scsi"
        vga=794
        read-only
Notice the append line. Notice too that I have highlighted one of the two ide-scsi parameters. In my machine I have a CD burner as secondary master (hdc) and my zip drive as tertiary slave (hdf). Both burners and atapi zip drives work much better when they pretend to be scsi devices.

If you're running grub as your bootloader you will need to make different changes, but it should be apparent what you need to do.

Hope this clears things ups.
 
Old 02-06-2004, 07:48 PM   #25
Usalabs
Member
 
Registered: Jan 2004
Distribution: OpenSUSE 42.1 Server
Posts: 156

Rep: Reputation: 15
thanks, I found out (after 3 bottles of asprin and 3 days of work) that my zip drive uses /dev/hdd so I added the line (after logging in as root):- /dev/hdd /mnt/zip auto noauto,owner,kudzu 0 0 to the fstab file then rebooted, then removed the /dev/hdd4 line, then rebooted and it worked, but there is no automount on disk insertion, so I have to use the disk manager to mount the drive after disk insertion.
 
Old 02-09-2004, 06:20 PM   #26
Thymox
Senior Member
 
Registered: Apr 2001
Location: Plymouth, England.
Distribution: Mostly Debian based systems
Posts: 4,368

Rep: Reputation: 63
I'm curious that you've remove the /dev/hdd4 line and replaced it with /dev/hdd. Standard Iomega discs actually use the 4th partition (no, I don't know why). They can be repartitioned (I've actually got a couple that are 125Mb EXT2 and 125Mb FAT32) but almost all will use the 4th partition by default (I don't know what the situation is with Mac formatted zip discs).
 
Old 02-10-2004, 01:01 PM   #27
FF103
Member
 
Registered: Aug 2003
Location: Kentucky
Distribution: Mandrake 10.1
Posts: 157

Original Poster
Rep: Reputation: 30
If you go back and read my(ff103) original post , you will see that my zip drive was trying to be mounted as sda4, but I finally got it working by mounting it as sda (leaving off the 4) This also seems to go against the normal mounting of these drives.
 
Old 02-11-2004, 12:00 AM   #28
Healing Bear
LQ Newbie
 
Registered: Jan 2004
Location: Northern California
Distribution: Mandrake 9.2 - 10 Official, XP Pro
Posts: 29

Rep: Reputation: 15
Try going to /www.iomega.com/software/index.html and downloading the newest drivers and installing them... I have an older Zip 100 Parallel Port, worked in Mkd 9.2 and 10 beta ...
 
Old 05-30-2004, 06:54 AM   #29
dibblethewrecke
Member
 
Registered: Nov 2003
Location: UK
Distribution: Arch Linux
Posts: 210

Rep: Reputation: 30
i am having zip probs too but everyone ignored my last post (in another thread)

i have a dell laptop with a swappable burner and zip disk - never in together

i have to use scsi when i want to burn so at the mo i have to lilo entries - one with scsi, one without - i would like to just have one but i can't get scsi emu working on my zip drive

w/o scsi emu it mounts with

/dev/hdc4 /mnt/zip vfat defaults,noauto,user 0 0

perfectly

w scsi emu on the burner mounts at fine

/dev/scd /mnt/cdr iso9660 defaults,noauto,ro,user 0 0

but i couldn't find where my zip drive was. i tried /hdc4 but then i saw this in dmesg

Code:
hdc: attached ide-scsi driver.
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
  Vendor: IOMEGA    Model: ZIP 250           Rev: 09.K
  Type:   Direct-Access                      ANSI SCSI revision: 00
Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
sda: Unit Not Ready, sense:
Current 00:00: sns = 70  2
ASC=3a ASCQ= 0
Raw sense data:0x70 0x00 0x02 0x00 0x00 0x00 0x00 0x12 0x00 0x00 0x00 0x00 0x3a 0x00 0x00 0x00 0x00 0x00 0x01 0x20 0x01 0x00 0x00 0x00 0x00 0x00 
sda : READ CAPACITY failed.
sda : status = 0, message = 00, host = 0, driver = 28 
Current sd00:00: sns = 70  2
ASC=3a ASCQ= 0
Raw sense data:0x70 0x00 0x02 0x00 0x00 0x00 0x00 0x12 0x00 0x00 0x00 0x00 0x3a 0x00 0x00 0x00 0x00 0x00 0x01 0x20 0x01 0x00 0x00 0x00 0x00 0x00 
sda : block size assumed to be 512 bytes, disk size 1GB.  
 sda: I/O error: dev 08:00, sector 0
 I/O error: dev 08:00, sector 0
ldm_validate_partition_table(): Disk read failed.
 I/O error: dev 08:00, sector 0
 unable to read partition table
so my zip is at sda, which i see a lot of people have

thing is, when i did

mount -t vfat /dev/sda /mnt/zip

it just goes crazy. it mounts and the disk spins up but just sits there and keeps spinning and you can't stop it. i have to reboot and when my box calls all teh shutdown commands i see an infinite error speeding up the screen that refers to the zip drive and something about too much data.

any ideas what is wrong?
 
Old 05-30-2004, 08:45 AM   #30
FF103
Member
 
Registered: Aug 2003
Location: Kentucky
Distribution: Mandrake 10.1
Posts: 157

Original Poster
Rep: Reputation: 30
My gosh those zip drives are monsters aren't they, Does it mnt as sda or sda4? if it mnts as sda , you might try sda4 or visa versa, Also do you have a disk in the drive when you boot up? it will read a disk read failure if it's empty, although mine boots anyway after it finds no disk in the drive. I forgot which distro you're using, I am using mandrake 9.1 and I let super-mount mount the zip drive and then I edited the config file. I also have a dell Inspiron laptop and I use a usb 250 mb zip drive on it , and it works perfectly everytime,so go figure, Don't ya just love Linux..... Just keep at it and like me you'll stumble across a fix sooner or later. I wish I could be more help, but it seems like every situation is different where those zip drives are involved.

Last edited by FF103; 05-30-2004 at 08:46 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No More Zip Drive! otakuprinzess Mandriva 5 02-03-2005 12:44 AM
Zip drive trackrat SUSE / openSUSE 3 11-13-2004 05:51 PM
where is my zip drive? cordedpoodle Linux - Newbie 9 10-07-2003 06:32 PM
Zip drive Ian_Hawdon Linux - Hardware 2 05-25-2003 10:48 AM
zip drive seingoku Linux - Hardware 1 04-21-2003 07:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 11:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration