-   Mandriva (
-   -   X won't work after graphics card update (

hamato 08-22-2004 02:28 PM

X won't work after graphics card update
Hi there,

I'm running Mandrake 10.0 Official on my box for some months now. Yesterday I changed the graphics card and replaced my Matrox G450 with a Matrox G550 and now X won't start. It flashes a blue background with a non-movable X mouse cursor a few times and then stays with just the blue background without any mouse pointer. I can't stop X with Ctrl-Alt-Backspace, but Ctrl-Alt-Delete will reboot the box just fine.

Sometimes it gives me a console after trying to start X, so I logged in as root and run xf86config, trying the "mga" driver as well as the "vga" driver which some google result listed as a failsafe setting, both unsuccessfully.

Is there a way to start the Mandrake configuration tool which is used at the end of the installation to setup X where you can set the type of card, amount of memory etc., either graphical or ncurses-based? I would hate to have to reinstall the whole thing just for the stupid minor hardware change.

hamato 08-22-2004 03:20 PM

Okay, so my knowledge of the FreeBSD servers at work pays out at last. I solved the problem by using my wife's notebook to ssh -X mymachine, su and run "drakconf" which I found in /usr/bin. My machine had already figured out the G550, but was left with some strange monitor and resolution settings which I corrected. It then worked, but I had no visible mouse pointer (even though the mouse was usable), which was corrected by selecting "Matrox G550" instead of "Matrox G550 DualHead" (I only have one monitor connected at the moment).

Go me! ;)

J.W. 08-22-2004 04:24 PM

Welcome to LQ hamato, and thanks for following up on your thread with the resolution -- J.W.

hamato 08-22-2004 05:22 PM

I guess I'm just an old-fashioned guy, and believe the Generation @ can be taught to be good netizens and learn by example.

courtrrb 08-23-2004 04:38 PM

You can skip the "drakconf" and just run "XFdrake" It is case sensitive.

hamato 08-24-2004 03:57 AM

Thanks a lot for the hint. :) I must say I'm disappointed with the Mandrake documentation - the Mandrake Expert site is next to useless and the online documentation is a) old and b) too much on the surface. I'm used to the excellent FreeBSD docs and looking stuff up for Mandrake really put me off quite a bit, just not to the point where I'd ditch the distro (which I like very much, I must admit).

Is there a list somewhere to look up the Mandrake tools and their file names/locations, maybe including which tools are shell-usable without X forwarding? I googled but came up with nothing useful.

courtrrb 08-24-2004 07:08 AM

Not that i'm awar of. I pick up hint here and there snive MDK V6.5

All times are GMT -5. The time now is 09:57 PM.