LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 03-29-2004, 05:07 PM   #1
RockmanExe
Member
 
Registered: Aug 2003
Distribution: Mandriva, Slackware
Posts: 265

Rep: Reputation: 30
X wont start after deleting user account


the topic says almost it all. The account that was deleted it was set up for autologin, using kdm and kde, of course . Now i'm not able to start x automatically at boot time. Everything seems to be fine:

''entering runlevel 5' message says 'ok'
/etc/inittab default runlevel is 5
'loading default dm' message at boot says 'ok'
i ran XFdrake and setup X tu run automatically at startup (which i suppose only changes inittab value to 5 anyway)

i'm login at init 5...? but the system shows me the console login, so it's ok, i login and do starx. X starts like a charm, no error messages or at least i think so, where can i check for those error messages??

any ideas how to restore x startup??

Running mdk 9.1 on a pavilion n5444 laptop, btw

thanks in advace guys!
 
Old 03-29-2004, 06:35 PM   #2
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,706

Rep: Reputation: 245Reputation: 245Reputation: 245
My best guess is that the system is trying to auto login a nonexisting user, i.e. the one you deleted and you get dumped back to a command line login when that fails. Try going into mandrake control center>boot. In one of those areas you can disable the autologin. Then reboot and see if the kdm login screen comes up. If it does, login and try to reenable the autologin in mcc and see if the new user will autologin.
 
Old 03-29-2004, 07:43 PM   #3
RockmanExe
Member
 
Registered: Aug 2003
Distribution: Mandriva, Slackware
Posts: 265

Original Poster
Rep: Reputation: 30
<My best guess is that the system is trying to auto login a nonexisting user>
thanks for the reply kilgoretrout:

that's a clever thought, unfortunately, i've already done what you suggested and it didn't work
i assigned autologin to another user but still no luck, also tried disabling autologin at all, with no luck either
maybe i need to change some obscure config file...

Last edited by RockmanExe; 03-29-2004 at 07:55 PM.
 
Old 03-29-2004, 08:59 PM   #4
JayCnrs
Member
 
Registered: Mar 2003
Location: Winnipeg
Distribution: Suse 9.3 Pro
Posts: 404

Rep: Reputation: 30
Did you try to go to the KDE control center and disable the autologin there? I'm not that familiar with Mandrake but I would give this a shot, maybe if autologin is not in the Mandrake Control center or the KDE Control center it will open up to a graphical login.

Let us know how it goes
 
Old 03-30-2004, 09:10 AM   #5
RockmanExe
Member
 
Registered: Aug 2003
Distribution: Mandriva, Slackware
Posts: 265

Original Poster
Rep: Reputation: 30
yes, i've disabled autologin at all.
Sometimes if i switch kdm to mdkKdm and back again when i reboot it loads x at startup, but only if autologin is enabled and it doesn't work all the time, if i disable it, it turn me back to console login... weird thing
 
Old 03-30-2004, 03:02 PM   #6
JayCnrs
Member
 
Registered: Mar 2003
Location: Winnipeg
Distribution: Suse 9.3 Pro
Posts: 404

Rep: Reputation: 30
Well we could try getting our hands dirty, anyway this might help:

cd /etc/kde/kdm
Favorite editor open up kdmrc
where it says default user change this to an existing user
near the bottom there should be autologin=false if it isn't false change it to false.
Save the file
Reboot or Restart X


Let us know how it went

PS make sure to backup the file before changing just to be safe
 
Old 03-30-2004, 05:33 PM   #7
RockmanExe
Member
 
Registered: Aug 2003
Distribution: Mandriva, Slackware
Posts: 265

Original Poster
Rep: Reputation: 30
Hello again, thanks for your good repies
JayCnrs:

i figured it out and i did something similar to your reply. Here's what i did:

edited /etc/sysconfig/autologin, because even though autologin was disabled, within that file it said it wasn't!! and indeed it was set up to the 'olduser' account

anyway, i changed those values and now it looks like this:
USER=newuser
AUTOLOGIN=no
EXEC=/usr/X11R6/bin/startx

and that's it

btw JayCnrs, i could not find the path you said, but you point me in the right direction

thanks friends

Last edited by RockmanExe; 03-30-2004 at 07:50 PM.
 
Old 03-30-2004, 08:03 PM   #8
JayCnrs
Member
 
Registered: Mar 2003
Location: Winnipeg
Distribution: Suse 9.3 Pro
Posts: 404

Rep: Reputation: 30
Good glad to hear that, the path was probably different because I use Fedora each distro has their own places to put things.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
User Panic! Debian wont start davcefai Debian 5 11-12-2005 10:16 AM
Mozilla and Firefox don't start on user account blkmage Linux - Newbie 6 06-04-2004 05:14 PM
Deleting a user account from prompt lozz1978 Linux - Newbie 8 01-15-2004 07:43 AM
KDE 3.1 wont start at login, but only for one user nudeatom Mandriva 1 01-07-2004 04:26 PM
Normal user account cannot start KDE tagit Linux - Newbie 2 12-22-2003 04:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 04:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration