-   Mandriva (
-   -   X Server Fail on Boot (

eschrock 11-27-2009 08:26 PM

X Server Fail on Boot
After booting, I get a blank black screen. I switch to a terminal login, and attempt to startx from there, and it gives me this:

(EE) module ABI major version (2) doesn't match the server's version (5)
(EE) Failed to load module "v4l" (module requirement mismatch, 0)
(EE) Failed to load module "type1" (module does not exist, 0)
(EE) Failed to load module "freetype" (module does not exist, 0)
(EE) Failed to load /usr/lib/xorg/modules/drivers//
(EE) Failed to load module "intel" (loader failed, 7)
(EE) No drivers available.

Fatal server error:
no screens found

I don't know what to do... how do I fix this? I've tried uninstalling and reinstalling xorg and some other things a few times, and it still doesn't work. Thanks!

GrapefruiTgirl 11-27-2009 10:24 PM

I think we need more information. It looks liek the X installation is really screwed up, based on just that little bit of error messages there. Almost looks like an upgrade gone bad, or a partially incomplete install/reinstall..

A) Is this a fresh install of Mandriva? Is it a full install?
B) Please tell us what-all "other things" you have uninstalled and reinstalled to try fixing this?
C) Did the X display ever work? If so, what first caused it to fail like this?
D) Have you looked in the logfile (usually /var/log/xorg.0.log) for further info about what's wrong?

Thanks for further information.


eschrock 11-28-2009 12:04 AM

Thank you for responding so quickly!

A) It was. Unfortunately, I had some problems upgrading to Mandy 2010, but thought I had worked them out. I had to reinstall several times, and eventually decided to skip it and just install the updates to my regular version. It required me to update rpmdrake, and after that rpmdrake didn't work. I had to uninstall it and reinstall it, and then it worked fine. Then I just did regular updates (a bunch of things I didn't really look at) and rpmdrake had to update again. I started having problems with it, and logged out, and then wasn't able to log in again. Ever since then, I've had the problems as described.

B) I don't remember exactly I reinstalled to try fixing it, but it was xorg, drakx, drakxtools, and whatever allows me to execute the startx command (I had to look it up so I could reinstall).

C) See Part A.

D) I looked at the log file, but the important parts are really the errors. Though, I don't really understand the rest of it, so I may have missed something important. It's a bit of a long logfile, is there anything in particular I should post?

Thanks again!

GrapefruiTgirl 11-28-2009 12:18 AM

OK, well I'm not familiar with the ins and outs of Mandriva, so I don't know exactly what those drake tools do, but I have screwed up my share of stuff :) and caused lots of weird things to happen, similar to what you're seeing but generally with systems other than the X server. Sometimes, particularly after a bunch of operations like you have done which may or may not have each worked successfully, the easiest thing to do is reinstall. In your case, since you've written that you have already tried reinstalling various pieces of the system and that has failed, I recommend reinstalling the OS on top of the current installation. Doing this, WITHOUT reformatting the partition or deleting anything first, should reinstall the OS exactly as it should be, while leaving intact such things as your /home folder, preferences, etc.. I've done this a number of times with my Slackware system over the last few years, and when all else had failed, this restored me a working OS with little fuss.

This advice comes with no guarantee, of course, but compared to your current state, I figure it's a safe bet.

Or, wait until somebody more familiar with Mandriva comes by to offer what might be a less invasive procedure to follow to get the mess fixed up :)

As for the X logfile, you *probably* have identified the important parts already, and taking those (EE) errors into account, plus the details of what happened to get you to this point, is I believe enough information to explain the current problem without needing more details about what exactly X is logging. It's basically telling us "I'm screwed", and I still suspect that it is because there are different versions of various pieces of it, co-installed, and it's having trouble figuring out what to do.

Best regards,

eschrock 11-28-2009 12:45 AM

Ok, I'll try that. I think I know how to reinstall the OS, just use the current partitions, and then choose not to format the main drive. Is that right? Or is there more to it?

GrapefruiTgirl 11-28-2009 12:49 AM

Nope, you got it. Just boot from the CD and follow the usual steps you'd follow to install it fresh, except don't partition or format anything; select your current root partition as the destination, and voila.

I should note too-- while this will as I mentioned leave your preferences and home folder intact, it will probably leave a bunch of new configuration files around, like in /etc for example, so if you have customized a lot of config files in /etc you may like to backup the files beforehand, so you can just replace them later instead of having to edit them all again.

On Slackware, packages usually leave the new files with a .new suffix, making for easy removal or identification; maybe Mandriva does something like this, but just in case it doesn't, you might like to save those files.


All times are GMT -5. The time now is 09:19 AM.