LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   x server (https://www.linuxquestions.org/questions/mandriva-30/x-server-181799/)

trackrat 05-15-2004 01:26 PM

x server
 
I have just installed M 10 with no problems till I came to start up.
Instead of the GUI I got a text based startup, so I entered my name and password then at the prompt I typed startx only to be met by a serious error which said screens available but no usable configuration.
In the set up everything was configured exceot the GUI so I accepted the defaults ( 1024 x 768 @ 70hz ) and Vesa as the graphics card driver.
The computer is a shuttle with 2 x 256ddr ram 2 hard drives 80gb & 40gb, N-Force 2 mobo and a leadtek FX5700 graphics card.
I have re-installed it 5 times to change the GUI settings but still get the same error.
Can anyone help?.

equinox 05-15-2004 08:41 PM

i know this is going to help, but there seem to be a few people experiencing problems with nforce2 mobo's, search the forum for their posts and see what you can come up with.

vectordrake 05-16-2004 12:14 AM

What are the horizontal sync and vertical refresh rates set to in your /etc/XF86Config-4 file? What driver is listed under the section about the video card? What is the resolution and color depth that is set under the "Screens" section?

trackrat 05-16-2004 01:18 PM

When I try to access /etc/xf86config-4 as user it says no such file or directory and if I go to root I get the same reply.
The only driver I can get to work with the leadtek gf5700 is the vesa driver.
As to the other settings I do not now how to find them from the text interface.

vectordrake 05-16-2004 08:59 PM

whoops! I meant /etc/X11/XF86Config-4. Sorry

trackrat 05-17-2004 05:46 PM

when I type that command as local or root I get permission denied.

vectordrake 05-17-2004 05:58 PM

fire up konsole and type
Code:

su
You should be prompted for your root password. Type that in. That files is a configuration file. All you need to do is look at it and then change it if its wrong. You want to look at it with your pager first(less is installed on most every *nix box), and then if you want to edit it, you can fire up a text editor to change it(nano is installed on Mandrake).To look
Code:

less /etc/X11/XF86Config-4
Use the pageup and pagedown buttons to scroll up and down the document. Copy and paste the relavent sections. To get out of the pager, hit the "q". There should be no reason why you can't look at a plain text document. Some files are hidden from users like /etc/lilo.conf, but root can read them.

trackrat 05-18-2004 10:58 AM

How do I fire up the console when I cannot get the GUI interface.

vectordrake 05-18-2004 03:56 PM

If you're presented with a login: prompt, type your username in and then your password. You'll be logged in. If this is the answer that you're looking for, than I will assume that you truely are the newbie that you claim to be. If so, you'd be very wise to learn a few simple commands so that you could get around in the command line (or your system in general). Do yourself a big favor and take an hour to review the basic commands to getting around in Linux. I suggest you go to a place like www.linuxcommand.org or your distro's installation guide page and learn about "ls, man, cd" etc. Check out little things like how to log in and out. It'll be an hour well spent. Then, you can come back and we can get you graphical really fast!


See you in a bit...

trackrat 05-18-2004 05:41 PM

I am a newbie but I now how to log on and off and how to get into root.
I will take a look at your link and will get back to you.
I have used xf86config to try and set it up but non of the drivers available will give me a working screen, this is strange because on instillation when the graphics were configured it asked you to test it and it was OK.
OH well time to read your link and thanks for it.

trackrat 05-19-2004 04:54 PM

Have read your link it took longer than an hour:(
With using the examples more like 5 hours.
Hopefully now I understand a bit more, with your help I can finally get my GUI up an d running.

vectordrake 05-19-2004 06:19 PM

It would take that long to read. Wow! Mos peeps would maybe skim it ( was assuming that you would do something in between. Well, you're ahead of the game now. If you want to know all there is to know about *nix, you may want to read the Rute manual. Its comprehensive but entirely readable. Some consider it a bible of sorts. You'll be answering most of the questions if you do that :eek:

Can you post the relavent sections of XF86Config-4? I'll help you suss it out (as well as anyone else who wants to attack it). I would suggest that you try the "nv" driver to get it working and once that's accomplished, get the Linux driver from their website so you can get 3d acceleration working too. One step at a time. Lets get a screen.

The parts that are the most important usually are:
Monitor - what is the horiz and vert rates
Device - what vid card driver is in use
Screen - what is the default color depth and the modes that are set for that depth (resolution)

trackrat 05-20-2004 10:59 AM

The monitor is a Typhoon T95N 19"
The graphics card is a Leadtek GF5700 128mb.

This is how it reads.
SECTION MONITOR.
Identifier 1
VendorName Generic
ModelName 1280 x 1024 @ 76Hz
HorizSync 31.5 - 82
VertRefresh 50 - 90

# Sony Vaio C1 ( X, XS, VE, VN )?
# 1024 x 480 @ 85.6Hz 48kHz hsync
ModelLine 1024 x 480 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output
# 768 x 576 @ 79Hz, 50kHz hsync
ModelLine 768 x 576 50.00 768 832 846 1000 576 590 595 630
# 768 x 576 @ 100Hz, 61.6kHz hsync
ModelLine 768 x 576 63.07 768 800 960 1024 576 578 590 616

SECTION DEVICE
Identifier device 1
Driver VESA
Option DPMS

SECTION SCREEN
Identifier Screen 1
Device Device 1
Monitor Monitor 1
Default ColorDepth 24

Subsection Display
Depth 8
Virtual 1280 1024

Depth 15
Virtual 1280 1024

Depth 16
Virtual 1280 1024

Depth 24
Virtual 1280 1024

END SECTION
The Hor rates in the monitor manual are 35 - 95
The ver rates in the monitor manual are 50 - 150
The maximum resolution of the monitor is 1600 x 1200.

I hope I have given you all the information you need.

Regards Alan.

vectordrake 05-20-2004 06:11 PM

Before I make any recomendations, I have two more questions:
1) Does anything happen at all when you try to go graphical?
2) Do you happen to have the manual for your monitor?

trackrat 05-20-2004 11:58 PM

Yes the monitor flashes as if it is trying to load the GUI
and yes I have the manual


All times are GMT -5. The time now is 10:39 PM.