LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   X does not startup automatically on mandriva LE 2005 after Nvidia driver is installed (https://www.linuxquestions.org/questions/mandriva-30/x-does-not-startup-automatically-on-mandriva-le-2005-after-nvidia-driver-is-installed-319792/)

Sparks71 05-03-2005 02:50 PM

X does not startup automatically on mandriva LE 2005 after Nvidia driver is installed
 
Hi all

Does anyone know why after installing the latest Nvidia graphics driver (7174) on Mandriva LE 2005 that the graphical login gets broken?

I followed Nvidia's instructions to install the driver, and the driver is compiled with no errors, then after editing xorg.conf to change the driver from "nv" to "nvidia" and restarting, i'm left at the text based login and have to start X manually after logging in, once X loads it runs perfectly with the new driver. It's just the automatic start of X that is bugging me.

Running a Geforce 4 MX440 64MB card on an Abit NFS7 Athlon XP2600+ with 1024MB DDR RAM
Hope someone can help!

Many thanks

Simon

kencaz 05-03-2005 03:09 PM

You need to change your runlevel back to 5

cat /etc/inittab

Text logon
id:3:initdefault
X11
id:5:initdefault

KC

Shifty02 05-03-2005 04:18 PM

I think I´ve got almost the same problem so I checked out my /etc/inittab file.
Mine has the following ¨id:5:initdefault:¨ but as you can see with the ¨:¨ at the end unlike your post which don´t have it. Do you think this can be the problem?

Sparks71 05-03-2005 05:42 PM

@ kencaz

I performed a test install of Mandriva from scratch on a spare hard drive this time not editing inittab but using the ctrl+alt+fkey method and going to init 3 to install the drivers. After successfully compiling them and editing xorg.conf i then did init 5 which brought up X and login screen, so far so good.

So it appeared to work this time... next restart the machine. After watching the kernel messages etc, screen goes blank and then appears the text based login again :mad: i checked inittab and it still says id:5:initdefault: any ideas why this is happening/where to start looking?

@Shifty02
What happens with your setup exactly?

Many thanks

Simon

Lakota 05-03-2005 06:44 PM

I just installed the nvidia 7174 driver. Works great. Autologin works perfectly fine too. If you don't have auto login working, you probably forgot to add a line nvidia to /etc/modprobe.preload.

You must load the nvidia module you have created prior to trying to use it. That is what the file modprobe.preload is for.

kencaz 05-03-2005 06:51 PM

Sounds like it may be a driver problem. Can you startx from the command line? Is it just the graphical logon that is the problem?

I use runlevel 3 so I have never seen the graphical logon...

Here is some info from LQ that may help.
http://www.linuxquestions.org/questi...ticle&artid=30

Also. If you can get to KDE try launching "drakconf" Under "Autologon" Check the box:
"Launch the Graphical Environment when system starts"

KC

Lakota 05-03-2005 07:28 PM

logged in as root, in a console, type "vi /etc/modprobe.preload"
will look like this, give or take listed modules

# /etc/modprobe.preload: kernel modules to load at boot time.
#
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line. Comments begin with
# a `#', and everything on the line after them are ignored.
# this file is for module-init-tools (kernel 2.5 and above) ONLY
# for old kernel use /etc/modules

bt878
bttv
sis-agp
~
~
~
~
~
~
"/etc/modprobe.preload" 11L, 371C

press the “i” to put vi in insert mode. Hit the “enter” key to drop to a new line. Type “nvidia”, then hit the “exit” key to exit insert mode. Then hit the “:” key, then “wq”, then enter. You will now be back to command line, with your changes saved.

Your file should now look like this:
# /etc/modprobe.preload: kernel modules to load at boot time.
#
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line. Comments begin with
# a `#', and everything on the line after them are ignored.
# this file is for module-init-tools (kernel 2.5 and above) ONLY
# for old kernel use /etc/modules

bt878
bttv
sis-agp
nvidia
~
~
~
~
~
"/etc/modprobe.preload" 12L, 378C

What is happening if you did not do this, is you changed your /etc/X11/XF86Config link to reflect that you want to use the nvidia module instead of nv. It is a module that was not included, but added later, so you must tell the system to load it at boot. you do this as shown above.

Sparks71 05-03-2005 07:57 PM

@ Lakota

Thanks for your detailed response, i understand what you are saying and i've just checked modprobe.local and there is a line with:
nvidia-agp

so that appears to be fine, after further investigating and editing of files, numerous restarts, if i change the driver back to "nv" then the graphical login is restored, this is really confusing me.

@kencaz
yes i can "startx" and X loads normally with the new driver working perfectly, also in drakconf the option to start the graphical environment is checked and so is the display manager. leaving it as it is works but i don't use the text based system at all (only when i have to) so it's a pain in the butt to login and then startx.

Any other thoughts or suggestions welcome!

Simon


All times are GMT -5. The time now is 04:01 AM.