-   Mandriva (
-   -   wrong cpu frequency (

dresnu 03-04-2005 04:19 PM

wrong cpu frequency
Hi, thank you for taking the time to read this thread. I have a compaq laptop(evon610c) with mandrake 10.1 official installed on. My problem is that when running kde or gnome after some while the pc runs extremely slow. Everything suddenly slows down and I have to wait a few minutes in order to be able to work again. This phenomena happens periodicaly and is very annoying. It's about a month that I'm trying to solve this problem. At first I thought it was the video card driver(Radeon Mobility M7) but changing it did make any difference. I noticed though that in the mandrake control center my cpu is detected as: Mobile Intel(R) Pentium(R) 4 - M CPU 2.00GHz but scrolling down the frequency is fixated at: 1196.259(!). Now I'm pretty sure that's causing me the trouble but I don't really know how to solve it. Any suggestions are welcome! Keep in mind that I'm a newbie :-D


SillyBear 03-04-2005 11:42 PM

Mobile Pentium 4's can "step down" their speed. I'd check the bios to see if its set for automatic or not.

If you're running linux on it, the CPU management should probably NOT be set to automatic in the bios, but the lower setting when on battery, and the higher when on AC.

opjose 03-05-2005 04:49 AM

It's unlikely to be CPU throttling though it's a remote possibility.

Even at 1.1ghz Mandrake should be pretty fast.

You didn't mention how much RAM you have. It makes a big difference.

Also on a fresh install Mandrake uses an abysmally SLOW setting for the hard drive.

You need to fix this ASAP.

Edit the /etc/sysconfig/harddisks file with any editor you choose.

Look for all of the indicated lines which are commented out.

UNCOMMENT them and reboot your system.

While you are at it, edit /etc/lilo.conf and add the word COMPACT towards the top.

Then as root type "lilo" at the prompt and reboot.

This will speed up the startup proceedure greatly.

Finally if you have a shared memory display (as many laptops do) you are basically stealing RAM away from Linux just to put something up on the screen. This greatly impacts performance and can cause the system to swap quite a bit as it tries to compensate for new allocations.

dresnu 03-05-2005 01:00 PM

I tried what was suggested in the previous 2 messages. First of all in my bios the only cpu option is "Intel Speedstep Technology" which can be set enabled or disabled. I set it enabled and saw that in mcc now the frequency is correctly displayed at 1999Mhz. I fixed the ASAP which made my system a little bit faster overall but didn't fix the stall problem. So the slow down problem still persists after some while that I work on my pc and comes up periodically like before. I have 512MB of RAM, which I think is enough and my video card has it's own memory so there's not a share conflict. I noticed that the memory is almost entirely used even if I don't run any program and there's only about 15MB of free RAM. I have acpi and acpid activated and recently installed cpudyn.

opjose 03-05-2005 01:16 PM

Two things you may want to do...

Log in as you would normally and open two terminal/consoles.

In one run "top" to see which processes are eating up CPU time

In the second type "watch free" to view memory allocation.

Now when things seem to slow down, switch to each of them and watch the results....

dresnu 03-05-2005 03:30 PM

I used top and watch free commands and checked them while my pc was slowing down. I had one firefox window open and was downloading an avi file. I also had kaffeine playing the partial avi.part file that was being downloaded. The values in the top list were constantly changing of course but more or less the first 3 processes were something like this: "root 35-40% X" "user firefox-bin 30-50%" "root pppoe 10%" and I had 180MB of free memory.

opjose 03-06-2005 03:11 AM

So Firefox's download was hanging the machine up at the time... slowing down X as well.

You may be having communication problems (hint: check MTU settings) via your PPOE link.

Try seeing if the same thing happens when you are NOT connected to the internet.

Do as before, but with no internet link. Just run other programs.

dresnu 03-07-2005 03:08 PM

I tested my linux with and without being connected to the internet. The result was the same :-(. After some minutes of opening and closing windows, starting applications ecc... everything started slowing down as always. I mean it really stalled! At some time, when I wasn't connected, X was using 80% of my CPU and 30% of the memory and I had only about 5MB of free RAM(512 total). It's really frustrating... I also checked the mtu that you referred to. I found that the optimal for my connection(adsl 1.2Mbit) is 1492. This is my ifconfig:

eth0 Link encap:Ethernet HWaddr 00:02:A5:BC:E3:EB
RX packets:166426 errors:0 dropped:0 overruns:0 frame:0
TX packets:186186 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:113131787 (107.8 Mb) TX bytes:132207254 (126.0 Mb)

lo Link encap:Local Loopback
inet addr: Mask:
RX packets:199 errors:0 dropped:0 overruns:0 frame:0
TX packets:199 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:11784 (11.5 Kb) TX bytes:11784 (11.5 Kb)

ppp0 Link encap:Point-to-Point Protocol
inet addr: P-t-P: Mask:
RX packets:10583 errors:0 dropped:0 overruns:0 frame:0
TX packets:11367 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:5808685 (5.5 Mb) TX bytes:7067809 (6.7 Mb)

Do the eth0 and ppp0 mtu's have to be the same? Because I can fix the eth0 mtu by running ifconfig eth0 mtu 1492 but when I restart this setting is gone and it get's back to 1500 as seen above. I even edited /etc/syslog/network-scripts/ifcfg-eth0 and added the line MTU=1492 but it made no difference.

opjose 03-07-2005 03:28 PM

The amount of Free RAM is unimportant.

That X is using 80% CPU normally indicates a problem with the AGP driver.

Some video cards work best with their own drivers (such as the NVIDIA) except on certain motherboards (such as Intel Boards) which in turn work with their own AGP drivers.

You may have to specify a different AGP driver.

The first thing to do is to establish which CHIPSET your computer uses.

Do you know?

If not try to look it up.

dresnu 03-07-2005 05:34 PM

The laptop runs on a i845 chipset. I'm trying now to change the video card drivers pretty randomly in case I find one tha works. Is it normal that in the mandrake control center I have "Description: Radeon Mobility M7 LW (AGP)" but the bus is "Bus: PCI"?

opjose 03-08-2005 07:01 AM

Yes PCI is normal.

However you DO NOT want to be changing the video drivers.

That's not the problem.

It's the kernel provided AGP driver.

You may be loading the ATI driver or one of the generic ones, when you want the Intel-AGP driver instead... or vice versa.

dresnu 03-08-2005 04:49 PM

Problem solved! I recompiled the kernel(my first time ;-) and set the ati drivers I needed. I also managed to get rid of alot of useless things my kernel was loading and now my system seems pretty faster than before. I must still find out how to stop the fan from running all the time at full speed, but that's another issue :-D. Thanks alot opjose for your usefull tips!

Here are some some links for people that have the evon610c laptop or the radeon mobility 7500:

PS: sorry if I stress your patience :-), but you didn't tell me if the mtu of the eth0 and the ppp0 have to be the same. If you don't answer it's all the same :-)

opjose 03-08-2005 05:11 PM

Usually the eth0 MTU is larger than PPP0.

If you have a large PPP window size, it still must be smaller than the eth0 size or there will not be room for the control bytes.

All times are GMT -5. The time now is 04:25 PM.