LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   wireless nic config (https://www.linuxquestions.org/questions/mandriva-30/wireless-nic-config-341900/)

phoneix 07-10-2005 01:57 PM

wireless nic config
 
hey all,

I have a Sager 9880 Notebook with a wireless Network card. I think the drivers for the wireless are loaded, here is the harddrake information:
OK. My "Laptop" sees my wireless adapter:

[Identification
Vendor: ?RaLink

Description: ?Ralink RT2500 802.11 Cardbus Reference Card

Media class: ?NETWORK_OTHER

Connection
Bus: ?PCI

Bus PCI #: ?10

PCI device #: ?5

PCI function #: ?0

Vendor ID: ?6164

Device ID: ?513

Sub vendor ID: ?5218

Sub device ID: ?26675

Misc
Module: ?rt2500]

I try to "run config tool" on it, choose wireless, and it says manually load a driver. I click next, scroll down to rt2500, click next and my screen flashes and i go back to manually load a driver and keep repeating the process. I went to the interent and downloaded the Linux drivers from the manuafacturer, but i don't know what to do with this. I saved the file in my home directory, unzipped it with Ark. The files include:

*RT2500-linux-sta-1.4.6.1.tar.gz
*Folder: "Module" (to incude many "C Source Files", a "Configure" shell script, and a "Makefile". I think that makefile has something to do with installing
*Folder: "Utility" (to include many "C++ Source Files" and a "Makefile"

If the the control center sees the above (the rt2500) doesn't that mean the dirver is installed?
On a related note, i installed ndiswrapper as above mentioned. Now what do i do with it?

My wireless network uses WPA-PSK with AE5 Encryption, ssid=off, Static IPs, and MAC Filtering. My windows uses this no problem, so i know the card supports it. So that leaves linux.

how do i get this to work?


Thanks in advance
Phoneix

__________________

phoneix 07-11-2005 02:34 PM

Nobody??? Bueller......Bueller.....

I installed NDISWrapper. Someone told me to do that. Now what?

springshades 07-12-2005 03:38 AM

Hey, I've never worked with NDISwrapper before, so I may not be able to help you there, but I DO know that even though they say that Linux supports certain wireless cards there are virtually none that work straight off. You always have to do SOMETHING. Can you go to configure your computer and then look at your hardware list? If a module is actually loaded for your wireless card, I'm going to assume Linux has some support for your card (mine loads the Prism54 module). If that is the case, then you need to get the firmware and put it somewhere in /etc/hotplug... not sure if there is a more specific folder than that, I'm not on a Linux computer right now or I'd check it for you. Hope this gives you enough info to start with. I'm pretty sure you have to reboot before you'll see any effect. For me, my network card didn't light up until the firmware was loaded for it. If there is no module loaded for your wireless card, NDISwrapper may be your only choice.

fouldsy 07-12-2005 03:50 AM

Using ndiswrapper isn't hard, it basically wraps around a Windows .inf driver information file and tries to create a Linux modules. Can't remember any howto's off the top of my head, but ensure you have the kernel headers package installed for your machine. Do a quick Google for ndiswrapper configuration. As springshades mentioned, sometimes modules that load for one card don't for another as the chipsets may be different, so check out the HCL on this site to see if anyone has listed instructions on getting your particular wireless adaptor going

phoneix 07-12-2005 07:41 AM

Oorah!

Thanks for the replys. I'll try that. Between getting this wireless to work and my vid card, i've been reading like mad.

charlescpc 07-18-2005 12:54 AM

If you need to get ndiswrapper to work I've have luck in installing several of these cards. I can give you a pretty detailed explanation.

I had a lot of luck with Mandrake 10.1 Official and 10.2 Official.

First check to see if your card is on the ndiswrapper list to work. http://ndiswrapper.sourceforge.net/m...index.php/List

Ok, If it there then I would use the ndiswrapper that comes with mandrake because it "tuned" to work with Mandrake.(that is don't have to load kernel- source)

Go to mandrake control center and see if it's installed. If it is good if not install it.

Then make a directory and put the windows drivers. SHould be about 3 or more. I don't know if you need all of em but doesnt hurt.

Then go into terminal mode as root or su. Change into the directory where you put your window drivers. Type in ndiswrapper to see if it loaded it should give you a list of options.
If so type in ndiswrapper -i bcmwl5.inf . <= you will substitute your driver for bcmwl5.inf
That should load the driver.

type in ndiswrapper -l and it should say driver loaded and hardware present

Then if loaded you can type in ndiswrapper -m to load the setting in.

Then you can type in modprobe ndiswrapper

Then you can set up ndiswrapper to start all the time on its own. Edit the file /etc/modprobe.preload and enter this line ndiswrapper.

Then go into mandrake control center and set up the card. Go to the network part and do the wireless. Your card should show up there. go throught the wizard for setting and encription etc. You can use iwconfig ifconfig etc from terminal as root but the wizard is easier.

Hope this help this is from memory.
The mandrake version works better than the version you download. I think there is a file you have to edit to get the downloaded one to work. WIth the mandrake version you do need to load the kernel-source but it doesn't hurt.

I struggle with the downloaded version and found out the mandrake one is a breeze to use and works almost every time. You may have a problem if you have downloaded a different version. You may have to go and clean up a bunch of files etc.

Hope this helps.........

phoneix 07-18-2005 07:19 AM

Well Met Charles:

Thanks for the detailed post. Awesome. Now that i got my Video Drivers to work ( i think) i can focous on my wireless. I'll give this a shot tonight, or tomrrow at the out. Thanks again m8.

Phoneix


*Longhorn = Kill Bill Vol. 3

charlescpc 07-18-2005 03:31 PM

Cool, Just remember for some reason the one that comes with Mandriva is SO MUCH easier to install, If you card is on the ndiswrapper list there is a very good chance you can get it to work.

If you have'd downloaded the generic one and got things mucked up by unsuccessful attempts then the one Mandriva has is very solid. If you have tried with their downloaded version go to the link I sent you to clean it up. I'm a newbie and I had trouble following their instructions but if you can that link will get it up for you.

I believe there is a file you have to edit to make the generic one work and after hours of frustration of trying to get it to work without know the "secret handshake" can be very frustrating. The Mandriva version doesn' require you to download the kernel source.

Most of the people I know that will help with this the first thing they will get you to do is completely get rid of the one that comes with mandriva. I believe this is the hard way to get it to work.

Again lots of luck...

phoneix 07-24-2005 04:16 PM

OK. Horrah for me!!!

I got the driver loaded. and even got the configuration tool to run. "kinda". I double-click it to open the tool and it says that "I don't have supper (this is how it's spelled!) user privilages". I tried to use the mandrake network config tool but it wouldn't let me connect. For one, it didn't let me choose which type of encryption i had. Incidentally, its WPA-PSK AE5 (maybe tkip, can't remember). It did, however prompt me for my key, which i entered along with the ESSID (which i assume is the same as ssid. Which is turned off in the router). OK. so i went into the config tool for users and played around w/ my group and user permissions. Nothing let me use that config tool. I got irritated and set me to the root group. then set me to use all files/diretories. I still couldn't use it. In fustration...i did something stupid. I deleted my user. Like an idiot, i forgot to make another one. Imagine my surprise when i can't log in anymore. well, bugger me. now i'm in a pickle. I'll just reinstall, no big deal.

I'm babbling. Back to my orginal problem. How do I get to run that config tool w/ "supper (lol) user privilages?"

BTW, i also tried iwconfig and tried to edit the driver.dat file, but still didn't work. I think the config tool will be fine if i can use it.

charlescpc 07-24-2005 10:09 PM

hmmm, so you signed in as root and deleted all the users included the root one ?

I didn't know root would let you delete rootor super user.

You should have had the root account left and there go and just add the users again.

I don't know for sure. I've never tried to delete the root account.

Once I've loaded the drivers I've always been able to go into mandrake controle center and set up the network without using iwconfig ifconfig.
I added the essid and my encrypton and it's worked for me...

Charlie

springshades 07-25-2005 03:47 AM

Hi phoneix, I hope this info helps you.

To create a new user, you'll have to follow a couple steps. I'm first going to assume that you have a fairly fresh install, and that your install has most of the default settings. In that case, you should be able to follow these steps exactly.

*Start your computer and wait for the lilo screen to come up, immediately press escape.

*Type "linux 3" without the quotes and hit enter. (If this doesn't work, type the first word on the list that is shown then a space, then 3.

*Now you're going to go to a console interface. When it prompts you to log in, type root and hit enter. Next type in the root password and hit enter again.

*To add a user account, type "adduser username" without quotes and hit enter. Replace "username" with the user name that you want for your new account. If adduser doesn't seem to work, you might be able to type /usr/sbin/adduser instead.

This creates a user, but by default the account is disable until you get to the next step and add a password.

*To activate the account, type "passwd username" without the quotes and hit enter. The "username" is the name that you put in last time. This will prompt you to put in a password for the user.

*Next, type in "halt" to turn off your computer.

*After your computer has powered off, you can turn your computer back on as normal. You should be able to login with the new account. Haven't tried this with Mandrake, but it's the default procedure for adding users at command line.

phoneix 07-25-2005 07:28 AM

Thanks for the reply's guys, CHEERS

Ok, i broke out my Red Hat Unleashed 8 tome and did some research. I did basically what you said shades. I went into linux failsafe, logged in as root. typed "adduser <I>username</I> -p <I>password</I> -u 502 -s /bin/bash". Or something similar (that was from memory, i'm at work now). I then checked shadowpassword file and yeah, it created the user and the password, and since i used the same name as my deleted user, it kept the same home directory as well. I then typed init 5, and my user name was there, so i typed in the password and....nothing but a shaking screen. I tried this a couple of times, even created an account using the "default" swtiches. Nada. Oh well. It was a good learning experiance. It was kinda different from what you said shades. I wonder if it didn't work because Redhat 8 (my manual) and Mandrake 10.1 are that different? or uses a different file or something? I'll try your way tonight.

@ Charles. I didn't delete the Superuser/root account, just my user. But Mandrake won't let me log in as SU. I remember in RH8 i could log in as Root. Is there an option or setting in MD that will give me that ability? I looked around in the control center under "Security" and "User Accounts" but couldn't find the option. I used the "run config tool" in control Center/Hardware for my Wireless. Put the essid (which is disabled in my router) and my encryption key, but wouldn't connect. I think i'll disable security in my router temporarly to see if it can connect then work my way up.

Cheers guys

springshades 07-26-2005 02:21 AM

I doubt that it's going to work one way and not the other. I actually don't create users in Mandrake that way, I use a GUI. However, it sounds like you DO have an account for your user. Next thing that you could do is simply enter in run level 3, login, then type in startx. This will get you to KDE where you can add a user from a GUI. You can even do that as root I think. As long as the root account stays intact, this shouldn't be too hard to fix.

PS, I've heard it's pretty complicated to allow root to login graphically. The best way to do it would be typing "linux 3" in lilo, and then login as root and hit startx.

phoneix 07-27-2005 07:21 AM

Well, well well. I was able to restore my user accounts. Horrah for me. I also obtained a copy of Mandriva 10.2 LE and did a clean install. Imagine my surprise when it recgonized almost everything (excluding the webcam). It found and installed the Nvidia 6800 Go Ultra, complete w/ splash screen. My wireless nic, tv tuner, sound. My only problem is that when i go to configure the Wireless nic, it locks up the computer, down to the keyboard. I have to hard shutdown. It runs fine until i configure the wireless, about half way through configuration. I wonder if its a driver issue. I appreciate all the advice you've all given me. I'll be sure to pass on this good knowledge.

springshades 07-30-2005 08:21 PM

You might already have this fixed, but I've never heard of ANY wireless card being fully supported right after install in Linux. It might have been detected, but most likely there is some necessary component missing. If it was detected and there is a module that supports your card, you'll still probably need to get the firmware for your card from the internet and put it in the right place. If there isn't a module for your card, you'll have to set up ndiswrapper. There should be an rpm for ndiswrapper that you could try.


All times are GMT -5. The time now is 02:03 AM.