-   Mandriva (
-   -   What is correct path to C compiler (

NeilJones 04-12-2008 01:07 PM

What is correct path to C compiler
I am trying to install a new version of Python on my system.

I get. I am running Mandriva 2008
I havre tried the obvious combinations to me in $PATH. Any ideas what it should be?

checking MACHDEP... linux2
checking EXTRAPLATDIR...
checking for --without-gcc... no
checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

MensaWater 04-12-2008 01:12 PM

Typically it is in /usr/bin. Some people put it in /usr/local/bin if they are adding this as a separate compiler on an existing system (e.g. Solaris or HP-UX) that already has its own cc compiler.

It is always possible you don't already have the gcc package installed. If you state which Distro (e.g. RedHat, Ubuntu, etc...) and which version of that distro then we can hell you to determine if the package is installed.

reddazz 04-12-2008 01:50 PM

If gcc was installed, it would be in /usr/bin. You need to install gcc using the GUI package manager or using urpmi. It may help if you went to easyrupmi and setup the various main, contrib, plf and updates repos and then install gcc.

unSpawn 04-12-2008 08:21 PM

Threads merged
Snow makes a last leap
Long before the Sun has set
Tranquility mine

NoahT1BM 04-25-2008 08:32 PM

I am running Mandriva One 2008.1 and I am getting that same error when I am trying to install CUPS. what should I be looking for in /usr/bin? How do I change the path if it needs to be changed?

ernie 04-26-2008 09:48 AM

If you are getting an error that a source package you are attempting to make and install is unable to find your c compiler, you need to install gcc (The error is telling you that the compiler is not installed). Open a terminal window (if you do not already have one open), su to root (command is su). NOTE:you will need your root password. Install gcc (command is urpmi gcc).

If urpmi returns an error indicating the package does not exist, or can not be found (and you have not yet done so), you should set up the Internet Software Media Sources (repositories) for use with urpmi (and the Software Package Manager). Go to the Easy URPMI WEB site and follow the directions there. I see they just updated the site yesterday (Friday 25 April, 2008) and I have not checked it out yet (but I will today) so I can not provide direction to help you with its use, but it appears to have been automated (which should make it even easier to use than ever).

If you have set up the Internet Software Media Sources, and still get the compiler not found error, try updating your media sources with urpmi (command is urpmi.update -a)


NoahT1BM 04-29-2008 10:48 AM

Thanks Ernie. The installation went smoothly. However, I have not yet had a chance to test my HP Deskjet, but I feel that I will not have any issues.

All times are GMT -5. The time now is 01:09 AM.