LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   What is Captive-NTFS? (https://www.linuxquestions.org/questions/mandriva-30/what-is-captive-ntfs-253519/)

allforcarrie 11-11-2004 02:09 AM

What is Captive-NTFS?
 
I can brows my NFTS drives just fine with Mandrake 10 ...

opjose 11-11-2004 02:26 AM

Captive permits you to safely WRITE to the NTFS partitions in Linux.

It works by utilizing Microsoft's own drivers for NTFS, so there are few, if any problems.

allforcarrie 11-11-2004 07:01 AM

THAT IS GREAT! How do i get it working?

opjose 11-11-2004 05:22 PM

The captive web site explains it best.

http://www.jankratochvil.net/project/captive/

It's REALLY easy to do.

The installer is very smart as well, it will go out and search for drivers in any Windows partition.

Under 10.1 Official, using the provided RPM's for some reason this process hung on my laptop.

I rebooted and ran the installer again and told it to skip the search of my existing Windows XP partition.

When I did this, it connected to Microsoft and downloaded the correct drivers from MS. Very nice.

You do need the LUFS modules installed prior to installing captive.

If you don't already have them or suspect you don't try

urpmi lufs

to get them in place.

opjose 11-11-2004 05:24 PM

Also there is a utility called captive-install-fstab that modifies the /etc/fstab file to use the captive drivers instead of the Linux ones.

Save off your existing /etc/fstab file...

e.g.

cp /etc/fstab /etc/fstab.sav

then run this utility AFTER installing captive as indicated.

Reboot and you can read and write to the NTFS partitions from Linux.

allforcarrie 11-11-2004 11:18 PM

i installed that but nothing happened, is there a setting i have to change?

opjose 11-12-2004 12:39 AM

Did you UNMOUNT your windows partition?

Then did you type mount -a or cat the /etc/fstab file to see if the captive-acquire-fstab made the proper changes?

Did the installation via captive-aquire-install work?

allforcarrie 11-12-2004 05:33 AM

I didnt try that, i'll check it out when i get home.

allforcarrie 11-12-2004 08:36 AM

Quote:

[root@localhost paul]# mount -a/mnt/win_c
mount: invalid option -- /
Usage: mount -V : print version
mount -h : print this help
mount : list mounted filesystems
mount -l : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere'.
Details found in /etc/fstab may be omitted.
mount -a [-t|-O] ... : mount all stuff from /etc/fstab
mount device : mount device at the known place
mount directory : mount known device here
mount -t type dev dir : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
mount --bind olddir newdir
or move a subtree:
mount --move olddir newdir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using -L label or by uuid, using -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say man 8 mount .
[root@localhost paul]#
I am completely lost.... :scratch:

Quote:

[root@localhost paul]# umount /mnt/win_c
umount: /mnt/win_c: device is busy
umount: /mnt/win_c: device is busy

opjose 11-12-2004 01:55 PM

Nah, just a little bit confused and missing a space or two in your syntax.

First print out the /etc/fstab and post it here so I can have a peek.

Then we'll take it further.

allforcarrie 11-14-2004 06:45 AM

so I did a clean install of 10.1 and unmounter my drive, i installed the captive RPM. here is the file:


Quote:

/dev/hde5 / ext2 defaults 1 1
/dev/hda /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec,users 0 0
/dev/hdb /mnt/cdrom2 auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec,users 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,sync,codepage=850 0 0
/dev/hde1 /mnt/win_c ntfs umask=0,nls=iso8859-1,ro 0 0
/dev/hdf1 /mnt/win_c2 ntfs umask=0,nls=iso8859-1,ro 0 0
none /proc proc defaults 0 0
/dev/hdf1 /mnt/captive-music captive-ntfs defaults,noauto 0 0
/dev/hde1 /mnt/captive-noname captive-ntfs defaults,noauto 0 0

opjose 11-14-2004 06:56 AM

Does it work properly now?

allforcarrie 11-14-2004 07:21 AM

I have no idea. I cant open any directorys to get to the mnt Dir. I ushualy open home then hit the up botton but home keeps crashing..... the only way i can see anything is to use nautalas directly

opjose 11-14-2004 07:33 AM

Open a console, and su to root.

Enter the root password when prompted.

type

umount /mnt/win_c
umount /mnt/win_c2
umount /mnt/captive-music
umount /mnt/captive-noname

Disregard any errors about the device not being mounted...

Now edit the /etc/fstab file using whatever editor you know.

At worst use kwrite

e.g.

kwrite /etc/fstab

Delete the following lines

/dev/hde1 /mnt/win_c ntfs umask=0,nls=iso8859-1,ro 0 0
/dev/hdf1 /mnt/win_c2 ntfs umask=0,nls=iso8859-1,ro 0 0

These are redundant and will only act to screw up captive.

Save the file.

Now type

mount /mnt/captive-music
mount /mnt/captive-noname

Now go to the directory...

cd /mnt/captive

and display it's contents

ls -l

Do you see your NTFS files?

If so captive is working fine.

allforcarrie 11-14-2004 08:00 AM

all i can see now is empty folders, before i could see everything fine.


All times are GMT -5. The time now is 09:46 PM.