LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 03-07-2005, 02:56 AM   #1
ppk007
LQ Newbie
 
Registered: Feb 2005
Posts: 5

Rep: Reputation: 0
Weird KDE problem - Konqueror will not start on Mandrake 10.1


I posted this in the General Forum, but did not get much interest or results. Hopefully, there is more interest here.

I am running Mandrake 10.1 (brand new distribution). After I setup a user, I login and try to double-click on the "Home" icon. It comes up in the task-bar and the hour-glass spins for a while and about a minute later, it disappears, but nothing shows up.

If I do a ps aux I see:
ppk 7084 0.0 1.7 22448 9064 ? S 15:50 0:00 kdeinit: kfmclient openProfile filemanagement

Also, nothing shows up if I type "kfmclient openProfile filemanagement" in a console window, but I get the following error:

bash-2.05b$ kfmclient openProfile filemanagement
DCOPReply<>: cast to 'QCString' error


Okay, more details on this problem. It seems to be related to my USB CompactFlash reader. I re-installed the system from DVD-ROM and if I don't have a CF card in the reader, everything seems to go fine and I don't have this error. However, I my compact flash reader no longer has an entry in fstab and it doesn't seem to work anymore.

If I re-install the system with this card installed, then I have this symptom of the "kfmclient openProfile filemanagement" hanging.

Since, I would like my CompactFlash reader and my KDE Home icon to work, I tried to do more diagnosing. There is nothing in the /var/log/messages file, but there is an entry in my .xsession-errors file:

kdecore (KAction): WARNING: KActionCollection::KActionCollection( QObject *parent, const char *name, KInstance *instance )
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20
Minor opcode: 0
Resource id: 0x1c01a86
ALSA lib pcm_hw.c:549:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
DCOP aborting while waiting for answer from 'kded'
DCOP aborting while waiting for answer from 'konqueror-10187'

Any suggestions? Thanks in advance.
 
Old 03-07-2005, 03:14 AM   #2
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
DO NOT plug in the USB reader during the installation.

There are a few readers which give Mandrake heartaches and can cause it to freeze up.

Make sure your reader is externally powered and connected either directly to the computer or via a SUPPORTED USB power hub.

Plug a card into the read, then plug the reader into the computer.

Check the output of DMESG

If things are working you will see an entry at the end about finding the new "drive" when you do this.

Then log out and back in.

In all likelyhood you will then see an icon for your flash card.
 
Old 03-07-2005, 03:30 AM   #3
hawea
LQ Newbie
 
Registered: Mar 2005
Location: NZ
Distribution: Mandrake 10.1
Posts: 1

Rep: Reputation: 0
Iīve had USB headaches with 10.1 which I didnīt have with 10.0.

External USB hard drive is detected (hot plug) and can initially be opened but canīt write to it. Konqueror then locks up. System monitor shows CPU red lining at 100% even after USB disconnected.

If I boot with USB connected then KDE desktop comes up with no device shortcuts at all. Konqueror is locked up as you described.

Sorry no suggestions...but you are not alone.
 
Old 03-07-2005, 05:27 AM   #4
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
It's a difference in the kernels and support drivers.

Mandrake seems to load ALL of the interface drivers even when they are not needed.

This can cause conflicts and hangups.

The best thing to do is to avoid their load, and then load them as needed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
weird Konqueror problem drevil666 Linux - Newbie 3 06-26-2005 04:02 AM
Weird KDE problem - Konqueror will not start on Mandrake 10.1 ppk007 Linux - General 4 03-07-2005 01:20 PM
Weird KDE Sound Problem mac57 Mandriva 1 01-28-2005 01:36 PM
Weird DISPLAY problem on KDE TallGuy Linux - General 6 01-02-2004 10:13 PM
Weird Konqueror problem (a bug?) ivanatora Linux - Software 1 10-13-2003 03:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 01:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration