-   Mandriva (
-   -   vncserver does not work - 2006 x86_64 (

ejennings_98 11-02-2005 01:26 PM

vncserver does not work - 2006 x86_64
I have a new machine, I installed Mandriva 2006 x86_64. I did the usual install adding tightvnc server and client. I cannot get the vncserver to work.

The vnc client does not generate an error, it does nothing, not even ask me for a password.

I have a second machine, Mandriva 2005LE - 32bit running. I have compared the vnc setup and they both seem to be the same. I can easily connect to this second machine using vnc from Linux or Windows.

Currently the new system is running Apache, MySQL, WebMin and ssh; all are working and I can connect to any of them remotely. I am on a secure network, so for now I disabled the firewall.

Any suggestions regarding what I should try?

Regards, Eric

acid_kewpie 11-02-2005 03:30 PM

well you can define what doing nothing actually means.. does it timeout or somthing?

ejennings_98 11-02-2005 04:10 PM


Yes, sorry I should be more specific. When I say the vnc client does nothing when connecting to the vncserver, what I have found is this:

On Linux the VNC client apparently connects, but the window is black, displaying nothing. As well it never prompted me for a password even though I had set one.

On Windows the VNC client does not show after I attempt to connect. There is no timeout or anything. If I check the task list I find that the vnc client is running.

With with both vnc clients I am able to connect to a second Linux server in my office with no problems.

Regards, Eric

ejennings_98 11-03-2005 06:21 PM


acid_kewpie 11-03-2005 07:01 PM

check the vncserver logs in ~/.vnc/host:display#.log. if you're running the server as a service, try just using the vncserver command directly instead, if only for debugging purposes.

ejennings_98 11-03-2005 08:20 PM


Here is the output from the log file:

02/11/05 14:37:59 Xvnc version 3.3.tight1.2.9
02/11/05 14:37:59 Copyright (C) 1999 AT&T Laboratories Cambridge.
02/11/05 14:37:59 Copyright (C) 2000-2002 Constantin Kaplinsky.
02/11/05 14:37:59 All Rights Reserved.
02/11/05 14:37:59 See for information on VNC
02/11/05 14:37:59 See for TightVNC-specific information
02/11/05 14:37:59 Desktop name 'X' (myserver:1)
02/11/05 14:37:59 Protocol version supported 3.3
02/11/05 14:37:59 Listening for VNC connections on TCP port 5901
02/11/05 14:37:59 Listening for HTTP connections on TCP port 5801
02/11/05 14:37:59 URL http://myserver:5801
failed to set default font path 'unix/:-1'
Fatal server error:
could not open default font 'fixed'
XIO: fatal IO error 104 (Connection reset by peer) on X server ":1.0"
after 0 requests (0 known processed) with 0 events remaining.

It appears there is a font issue. With a lot of googling all I could come up with is to add a /etc/vnc.conf file and set the font path. However I could not find any examples. Any ideas how to resolve this, or is adding a vnc.conf file the solution?


mrcheeks 11-03-2005 11:35 PM

you might have a font problem check your /etc/X11/xorg.conf file.

ejennings_98 11-04-2005 12:17 PM


I modified the /etc/X11/xorg.conf file and still I cannot connect. However there was one thing, the ~/.vnc/xxxx:1.log file no longer had the font error.

But that is confusing to me as Mandrake has been running a font server for along time, and should not require the extra font info to be added to the xorg.conf file.

With much googling for the previous error "failed to set default font path" and "vncserver", I have found that lots of Debian systems have had to maintain a /etc/vnc.conf file, with the font paths in it. Are you familiar with this?

Any other suggestions?

Regards, Eric

stork 11-05-2005 03:07 AM

This is how i got my vnc server to work, mabye it will work for you too...

First, as root open /etc/sysconfig/vncservers
Add line: VNCSERVERS="1:your_username"
Save and exit.

Then open /home/your_username/.vnc/xstartup
Uncomment the #!/bin/sh (remove the #-sign)
Save and exit.

Then open /etc/rc.d/rc.local
Add line at end: su your_username -c "vncserver -depth 16 -geometry 1280x1024"
This is to set the colordepth and geometry, you can set them as you want

Then start terminal.
As root: chkconfig --level 35 vncserver on

This will start the vnc sever at boot

The first time you restart your computer you will have to set a vnc password.
Start terminal:
As your_username: vncpasswd
then set a password and it should work.

Please let me know if it worked out!

acid_kewpie 11-05-2005 01:26 PM

i think i had an issue a while ago similar to this, where the fonts had moved between the use of xfree86 and xorg. as such vncserver was looking in the wrong location for fonts. either use the -fp option to tell it where the new location is, or edit the vncserver script yourself and change the line in there.

ejennings_98 11-07-2005 12:55 PM


When I edited the vncserver file I got a string of new errors looking for the 100dpi fonts. This server does not have the 100dpi fonts, but neither does my other 32bit server which is currently running vncserver.

This is rather confusing, but I will attempt to install the fonts.


smiler 11-23-2005 05:30 AM

did you get this one fixed?
I have the same problem with the same installation,
how did you fix it (if you did)??


Originally posted by ejennings_98

When I edited the vncserver file I got a string of new errors looking for the 100dpi fonts. This server does not have the 100dpi fonts, but neither does my other 32bit server which is currently running vncserver.

This is rather confusing, but I will attempt to install the fonts.


ejennings_98 11-23-2005 11:44 AM


I did not fix it. I decided to use Webmin to remote administer the machine. By using ssh and webmin I can do pretty much anything I need.

This is what I tried:
- I installed the 100dpi fonts,
- I tried all other suggestions mentioned in this thread,
- I did extensive searching on Google and tried a number of other tips, tricks and magic,
Nothing worked!

Just to recap the systems that I have worked with:
- I currently have two 32 bit machines both running Mandriva 2005 LE and I have had no problems running VNC server. I have run VNC on about 5 other Linux based machines in the past with little problems.
- I have setup two 64 bit machines, one with Mandriva 2005 LE and the other with Mandriva 2006. I cannot get VNC server to work with either of them.

I have decided not to waste any more time on this issue.

Regards, Eric

smiler 11-25-2005 03:59 AM

[QUOTE]Originally posted by ejennings_98

Same here, all my i586 installations never had any problems with VNC.
I had the same experience as you with the A64 one, except I had never any font errors, so I think it is unrelated to these.

I have found that I can tunnel X over SSH, so I can bring up the applications one by one by first connecting with ssh -X server-address and then just starting applications from the remote console command-line -- /usr/sbin/drakconf & to get the Mandriva control center remotely.

I wonder if it is worth submitting a bug report ?



smiler 11-25-2005 05:59 AM

Also uninstallling tightvnc-server and installing the 32 bit version makes it able to connect to, but a lot of kded crash messages pops up, but u can use the applications



All times are GMT -5. The time now is 09:57 AM.