-   Mandriva (
-   -   VNC on Mandrake (9.0 & 9.2) blank screen on client side (

saavik24 01-10-2004 10:15 AM

VNC on Mandrake (9.0 & 9.2) blank screen on client side
I have tried using the vnc server on several versions of Mandrake but I always get the same results, a blank screen on the client side. I have searched for this problem several times here and other places. The only reference I have found meaningful is to edit the vncservers file, edit what... See the log and vncserver file below. Any help would be great.

vncservers file:
# The VNCSERVERS variable is a list of display:user pairs.
# Uncomment the line below to start a VNC server on display :1 as my
# 'myusername' (adjust this to your own). You will also need to set a
# VNC password; run 'man vncpasswd' to see how to do that.
# DO NOT RUN THIS SERVICE if your local area network is untrusted. For a
# secure way of using VNC, see



17/06/03 21:29:59 Xvnc version 3.3.3r2+tight1.2.5
17/06/03 21:29:59 Copyright (C) 1999 AT&T Laboratories Cambridge.
17/06/03 21:29:59 Copyright (C) 2000-2002 Constantin Kaplinsky.
17/06/03 21:29:59 All Rights Reserved.
17/06/03 21:29:59 See
17/06/03 21:29:59 See -specific information
17/06/03 21:29:59 Desktop name 'X' (home.server.hom:2)
17/06/03 21:29:59 Protocol version supported 3.3
17/06/03 21:29:59 Listening for VNC connections on TCP port 5902
17/06/03 21:29:59 Listening for HTTP connections on TCP port 5802
17/06/03 21:29:59 ://home.server.hom:5802

17/06/03 21:30:33 Got connection from client
17/06/03 21:30:33 Protocol version 3.3
17/06/03 21:30:37 Pixel format for client
17/06/03 21:30:37 8 bpp, depth 8
17/06/03 21:30:37 true colour: max r 7 g 7 b 3, shift r 0 g 3 b 6
17/06/03 21:30:37 rfbProcessClientNormalMessage: ignoring unknown encoding 16
17/06/03 21:30:37 Using hextile encoding for client
17/06/03 21:31:13 Client gone
17/06/03 21:31:13 Statistics:
17/06/03 21:31:13 key events received 1, pointer events 72
17/06/03 21:31:13 framebuffer updates 71, rectangles 173, bytes 14067
17/06/03 21:31:13 hextile rectangles 173, bytes 14067
17/06/03 21:31:13 raw bytes equivalent 514199, compression ratio 36.553565

david_ross 01-10-2004 10:17 AM

Welcome to LQ.

Take a look at your startup file in ~/.vnc/ and add a command to start your chosen window manager.

saavik24 01-10-2004 01:25 PM

Currently the xstartup looks like this ...


# Mandrake Linux VNC session startup script
exec /etc/X11/xinit/xinitrc

xinitrc then does this
# (c) 2000-2002 MandrakeSoft
# $Id: xinitrc-xinitrc,v 1.2 2002/09/10 05:53:43 flepied Exp $

# Set a background here because it's not done anymore
# in Xsesion for non root users
if [ "`whoami`" != root ]; then
xsetroot -solid "#21449C"

exec /etc/X11/Xsession $*


Xsession is pretty long so I didn't post, but it looks like it sets up the environment for the default interface. I use Gnome, what would the command be to start Gnome.
Sorry for the newbe question I do not know the command line interface very well at all.


david_ross 01-10-2004 01:30 PM

Change the xstartup line from:
exec /etc/X11/xinit/xinitrc

Then kill all your Xvnc proccesses and start the server again. When you login you should have gnome running.

saavik24 01-10-2004 01:58 PM

Well I made the change I and it did have an affect, now it is a blank screen in black and white with kind of a checkerd background. I did stop and the restart the vncserver.


moemy 01-12-2004 07:18 PM

I am interested in a solution to this as well. I have the exact same problem and the suggested changes have the exact same effect on my Mandrake 9.2 system.

Interestingly, I installed something called rfbdrake ('remote frame buffer tool') from the Mandrake package that uses vncviewer as the client app and it seems to work, albeit very slowly. The little documentation associated with it indicates that it uses x0rfbserver as the server application. I also noted that vncserver never shows any indication that it is taking control of the host system, so the problem doesn't seem to be just about the graphic output

Not sure if this is in the least bit helpful. I am an absolute (less than 8 hours hands-on time) Linux newb.

saavik24 01-12-2004 07:44 PM

I have seen this problem reported several times, as yet I have not seen a working fix. Hopefully someone will see this and know exactly the right fix. Thanks for your input I will try it, that should get me by for now.
I have played with linux (GUI) for 3 or 4 years now. But I am still very much a newbie.

moemy 01-13-2004 08:21 PM

OK I seem to have solved my problem,which was pretty silly. My Linux box has a very old graphics card which appears not to be able to handle 32K colors. I went into the vncserver script and changed the number of colors to 16k and everything works fine now. Not sure if you will have a similar solution, but I would definitely take a hard look at the graphics card. Tightvnc is much faster than rfbdrake.

Now to find those posts about getting Linux to autoinstall vncserver on boot...

saavik24 01-14-2004 04:51 AM

I tried starting vncserver using this command ...
vncserver :2 -depth 16

I am assuming that is what you did, it didn't work for me. If you changed that setting some where else let me know.

OOH and congrats on getting yours working

moemy 01-15-2004 10:05 PM

Well I put it in the vncserver script itself but yes, that should have done it. It is interesting that your symptoms were the same as mine though. If you have an extra graphics card laying around, I suppose you could swap it into the Linux server to see whether the graphics card is the problem. Don't know what else to say. Sorry.

kikker 09-19-2004 02:19 PM

I guess this fix the problem.

Kikker46 ;)

All times are GMT -5. The time now is 06:30 AM.