-   Mandriva (
-   -   urpmi updated kernel source but not the kernel itself(??) (

tredegar 02-14-2005 11:41 AM

urpmi updated kernel source but not the kernel itself(??)

I just ran urpmi --auto-select on my mandrake 10.1 official system. It updated a load of packages, including, I noticed, the kernel source.

After a reboot, I was surprised to find the nvidia drivers still working (I didn't think they'd like a kernel upgrade).

My kernel was I used to have a directory in /usr/src called linux- but that has now been replaced by linux-
uname still reports my kernel as This seems to me to be a potentially serious inconsistency.

Should I be worried?
What should I do?
Why did urpmi do this to me?


bunnadik 02-14-2005 11:48 AM

That's a feature not a bug.
"urpmi --auto-select" replaces installed rpm's and with something as important as the kernel you don't
want that to happen. If the replaced kernel is buggy for some reason (or doesn't have the NVIDIA module *grin*) you're in dire straits.

I think the agreed upon way is to download the kernel manually and do a 'rpm -i kernel....rpm'
This way if the new kernel doesn't work you still have the old one intact.

- Peder

tredegar 02-14-2005 12:09 PM


Thank you for your fast response!

It may be a "feature" but I wish I had had the opportunity to tell urpmi NOT to update the kernel!

So I suppose I'll have to find the rpm for mandrake kernel and install that manually? My heart is sinking. Or perhaps I should bite the bullet and compile it myself? Now I am having a minor panic. I wish I had not got into this mess!

Can i just resinstall the sources, so there is consistency between what is running and the sources? I have no complaints about

Padma 02-14-2005 12:56 PM

just go to the command line and enter "urpmi kernel". It will display a list of available kernels to install. Just pick the "linux-" kernel, and let it install. After a reboot, you will be in the new kernel. You will find your old kernel is still there to use, as well, if the new one doesn't work for you (although it should be fine - it's what I'm running).

bunnadik 02-15-2005 01:01 AM

You don't need the sources unless you want to compile your own kernel or compile an external module
(NVIDIA, ivtv to that kernel.

- Peder

tredegar 02-15-2005 02:27 AM

Thank you both.

The problem is solved:

Between posts I took your advice and installed the rpm of the kernel. When it finished downloading and "installing" I was pleased to find I was still running the old kernel, so I had a chance to look at the changes the installation made to /boot and /etc/lilo.conf.

In times past, I have found myself almost locked-out of my computer when I have introduced a new kernel, so I was highly suspicious. Anyway I rebooted to the new kernel. To my surprise, it all worked. Except the NVIDIA driver, but I do not see that as a problem, I just need to reinstall it. I have also automatically been given the option in lilo of returning to my old kernel. Thanks to someone.

In conclusion: It was not difficult. I feared things going wrong, but the linux distributions have improved enormously over the past few years, and I have to admit that I am impressed.

All times are GMT -5. The time now is 05:13 PM.