-   Mandriva (
-   -   urpmi.update --all / urpmi database locked (

thepoint 09-19-2003 08:49 PM

urpmi.update --all / urpmi database locked

I really messed the file management system su. I was trying to get security updates running and I kept getting messages that the mirror did not support 9.1 updates. I looked around and found a few things to try.

I went to Easy Urpmi and things looked really swell. :)

About the third download ( I was hit in the face with the limitation of a dial up connection ) the process told me that there was a 16M file that would take many hours to download.

So now, i is really messed up. When I run urpmi.update --all I get several messages "unable to access hdlist file of "Installation CD 1 (x86) (cdrom1). medium ignored. It says this about all of the other repositories as well, then it says "urpmi database locked".

I've gone into etc/urpmi and var/lib/urpmi and messed around now it's all messed up.

Thats probably a lot more than you want to know, but I am at a loss.



jschiwal 09-20-2003 02:44 AM

You might want to bring up the Mandrake Control Center / Software Management / Software Sources Manager and check if the entries look ok.

On my computer for the first install disk it says
URL: removable://mnt/cdrom/Mandrake/RPMS
Relative path to synthesis/hdlist: ../base/

Make sure that the disk is in the cdrom drive when you click Save changes. Your cdrom drive may be mounted somewhere else.

thepoint 09-20-2003 05:42 AM

I guess I really wasn't clear. How do I clear the "uprmi database locked" message.



ac_dispatcher 09-20-2003 11:19 AM

Ive had the same problem too. I seems like a lock file somewhere. I could not find it. As bad as it sounds I rebooted :eek: and it all worked again.

thepoint 09-20-2003 12:23 PM

Noooo! Not a reboot!!! I finally got it to work by going into File Sources Manager and removing everything, then putting it back in.



thekswenson 11-05-2003 06:03 PM

I removed /var/lib/urpmi/.LOCK and /var/lib/urpmi/.RPMLOCK and it worked well...

All times are GMT -5. The time now is 09:28 AM.