-   Mandriva (
-   -   Upgrading to 2.6.6 seems to have nuked my machine (

HawkeyeCoug 05-17-2004 08:34 PM

Upgrading to 2.6.6 seems to have nuked my machine
I am trying to install a new kernel for the first time. I have a fairly standard Mandrake 9.1 setup. I have my booting hard disk with 9.1 mounted and a second hard disk with /home mounted where I have a bunch of work and my music collection which I don't want to rip again.

So, I compile just as the install notes in 2.6.6 say. (make ... menuconfig, make, make module_install install, all as root). Then I check the /boot menu and it still has an entry for some 2.4.xx-13mdk kernal, which is also a little bigger than the one I complied. I used drakboot, and set 2.6.6 to default. Then, I reboot.

Well, I get a few warnings when I booted -- mostly from automount stuff. I was kind of expecting it, as I am just trying to experiment. Then, the typical KDE login screen comes up, just like normal. I try to log in, and KDE can't write to /home. I try gnome and windomaker, and neither work. I log in a console, and /home has basically dissapeared -- nothing is listed on it!

I reboot in failsafe, and there is some linux configuration option that pulls up a menu system. I get into lilo. It sees my new kernel (266) as well as seeming to see the old one. I reboot, log in as root. /home is still nuked, and now the only files coming up when I go to /boot are the new kernel, not the old one! All those files, including system map and the like, are nowhere to be found!

I can understand me checking a wrong option in the kernel compile and messing up the new kernel, but how does that delete all the previous stuff? Where did I mess up, and what can I do to fix it? Surely the data is still there, it just needs to be recovered somehow.

HawkeyeCoug 05-17-2004 10:27 PM

Update on trying to fix it
I recompiled the stock kernel supplied with Mandrake 9.2. However, lilo seems to be blown off the map, as all /sbin/lilo gives is an error, even though lilo is listed there. I have tried booting into failsafe and changed the default boot to the newly compiled (i.e. stock) kernal, but it still doesn't list it in the startup. It says it is not reading ext3 filesystems in the bootup messages, which I believe most of my system is on. Would a re-install fix things without destroying data? Is there any way to get that darn 2.6.6 kernal out of there? Could I use knoppix somehow to fix things?


Linux-Losur 05-18-2004 02:54 AM

Most of this is way out of my league. BUT, I can suggest that the /home partition is not being mounted. Make sure it's in your /etc/fstab, and make sure that /etc/fstab points to the right location.

As for Lilo, the fact that it's reporting errors when you run it after you edit the config file indicates that there's an error in your config file, and should tell you exactly what the error is. So, fix the error, run lilo again, and you should be good to go. Oh, one other thing here - lilo won't update the mbr if there are errors in the config file.

HawkeyeCoug 05-18-2004 12:36 PM

Thanks for the suggestion
I took your suggestion. I opened my lilo.conf file in nano (I just had command line access). I then looked at it, then ran lilo. It complained about not having a boot message. So I added one (note that I found out later this kills the nice graphical boot screen at start-up, but I really didn't care). Then, it complained about not having the keymap file. I found out that it doesn't matter if you use a standard QWERTY keyboard, so I commented it out with a #. Finally, it gave me an error with "initrd" lines in the kernels. I found out this is an option that involves booting to a ram disk first, then booting regularly. I crossed my fingers, and commented that part out. I ran lilo, and no errors. I did a "shutdown -r now", and booted the Mandrake 9.1 kernel I recompiled last night (2.4.something).

Well, it came up, and everything seems to be working. My work and music collection are back, and accessable. All my settings seem to be intact. Things seem to be working.

So, here is a summary of what I think happened: I compiled 2.6.6 with bad flags. I did not back up /boot before going with the automatic install. Somehow, /boot was deleted and just replaced with the 2.6.6 kernel. I went back to the /usr/src file and compiled the stock Mandrake kernel. I tried to install it but lilo.conf was messed up. I edited lilo.conf by commenting out various parts when errors came up. Lilo worked, and I rebooted, and it worked.

I will give further updates on what must seem my humorous attempts to install a new kernel. But, sometimes you don't learn unless you fall. Thanks for the tip, as it really did work.

Linux-Losur 05-18-2004 02:46 PM

You're most welcome. Glad I could help!

All times are GMT -5. The time now is 09:40 PM.