-   Mandriva (
-   -   updatedb crashes locks up the computer (

beejayzed 03-26-2004 06:01 PM

updatedb crashes OS
Hi all,
Today I wanted to search for something that I had just installed so I had run updatedb.
Crash boom! kapow(well not really), the whole thing completely locked up. The first time it happened, it gave me some error message to do with the kernel but when I tied re-installing it, it's stopped giving me errors.
I tried running it in a different console but still no go. I tried lots of other things like using the other kernel.
I tried running updatedb for Mandrake 10 in Mandrake 9.1 and it's doesn't crash the system.
Anyway, does anyone have any suggestions, maybe the location of a log file so that I cn post the original error message.

beejayzed 03-26-2004 11:35 PM

Okay if someone has had any experience similar to this please tell me, even if it's with a different program.
Where would this kind of thing be logged?

lnxconvrt 03-27-2004 12:28 AM

I had a similar problem once...
but under Red Hat. Not a system crash, but sendmail stopped due to high load average. Turned out I had lots of hung updatedb processes.

First, you might check if you have any hung updatedb processes running and kill them. Then check /etc/updatedb.conf and see if it needs adjusting.

In my case it was trying to access an nfs mount that no longer was in existence.

I don't know about the crash, but errors in the config can cause it to hang.


beejayzed 03-27-2004 02:41 AM

I takes the whole system down with it so I need to restart. I hardly think they would still be around after restarting about five times.

beejayzed 03-27-2004 02:43 AM

And I reinstalled the slocate package, making sure I deleted all it's configuration files before I reinstalled it..

beejayzed 03-27-2004 02:48 AM

Ah well, I guess I'll just have to reinstall. All the rebooting with out going through the procedures has corrupted the filesystem.

neon 12-26-2004 02:57 PM

hi, i'm having this same problem..
I'm trying to uninstall slocate, how do I do that?


neon 12-26-2004 03:00 PM

oh, what should I do if it says segmentation fault??
it sounds bad..
i get this error message when i ran slocate -u

lnxconvrt 12-27-2004 10:47 PM

short answer
since I don't have much time at the moment. Using FC3 you should be able to uninstall with "yum remove slocate". Then "yum install slocate" would reinstall. Or, I think, there is an rpm option (maybe -F or freshen, try man rpm) to freshen a package.

If there's more wrong than that can fix, you could try using strace, as in "strace locate somefile" or whatever the exact command is that produces the problem. Probably pipe the output to less because there will be a lot of it. But you might see what exactly is causing the problem.

All times are GMT -5. The time now is 08:44 AM.