LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 03-24-2005, 06:26 PM   #1
Petrov Labitzke
LQ Newbie
 
Registered: Mar 2005
Location: Santiago de Chile
Distribution: Mandrake 10.1 PowerPack
Posts: 17

Rep: Reputation: 0
Trouble Booting


Howdy all.

I am using Mandrake 10.1 PowerPack, and I love it to death. It is by far the best version of Linux that I have tried. It is, however, giving me some trouble on the bootup.

When the computer boots into Lilo, it gives me the option of Windows 2000, Mandrake Linux 10.1, linux non-fb, and failsafe. Every time that I choose the Mandrake Linux 10.1, it works fine until it gets to where the login screen should be, and my monitor kicks off and says that the frequency is out of range. It does not do this when I use the linux non-fb option or the failsafe option, so I just use the linux non-fb one when I want to use Linux.

I am just curious if I am losing anything by using that option. If so, is there anything that I can do to make the Mandrake Linux 10.1 option work?

Thank you.
 
Old 03-24-2005, 07:02 PM   #2
RySk8er30
Member
 
Registered: Jul 2004
Location: Buffalo, NY
Distribution: Mandriva 2005LE
Posts: 274

Rep: Reputation: 30
In the Mandrake Control Center, under Hardware, select Monitor. Find a resolution that you want and a frequency rate of 70Hz. I'm not 100% sure what your settings should be. If you let me know the Model/Make of your monitor I can be more specific.

I'm sure there is a way to do this through the shell by editing some config files, but try this first.

Ryan
 
Old 03-24-2005, 10:12 PM   #3
Petrov Labitzke
LQ Newbie
 
Registered: Mar 2005
Location: Santiago de Chile
Distribution: Mandrake 10.1 PowerPack
Posts: 17

Original Poster
Rep: Reputation: 0
I use a Mag 770V monitor. What I use on Windows and the version of Linux that works is 1280X1024. It seems to work fine and I like it a lot.

I just changed the setting to 800X600, and got the same thing when I tried to boot into the "Mandrake Linux 10.1" option. I even turned off the graphical login screen, so I was able to log in, but when I put in the "startx" command, I got the same "out of frequency" thing. Criminy.

My question still stands. Am I losing anything by booting into the "Linux non-fb" option? If not, I honestly do not mind pushing the down arrow that one extra time to get to the "Linux non-fb" option. Does anyone know what that means, by the way?

Thank you.

Last edited by Petrov Labitzke; 03-24-2005 at 10:42 PM.
 
Old 03-25-2005, 12:12 PM   #4
RySk8er30
Member
 
Registered: Jul 2004
Location: Buffalo, NY
Distribution: Mandriva 2005LE
Posts: 274

Rep: Reputation: 30
I stole this from another post...

The reason for the no-FB choice is that not all video cards
support framebuffer. If you can see the splash screen when you
first boot then your card does framebuffers. All nonfb does is
the vga=xxx line is removed from this boot option. vga=xxx is
what sets the FB resolution.

In your /etc/X11/XF86Config file, what is the Monitor's refresh rate set to? There should be a line which says...

"800x600 ??Hz"

What is the number where the ?? is set?

Ryan
 
Old 03-25-2005, 04:22 PM   #5
Petrov Labitzke
LQ Newbie
 
Registered: Mar 2005
Location: Santiago de Chile
Distribution: Mandrake 10.1 PowerPack
Posts: 17

Original Poster
Rep: Reputation: 0
What do you mean by splash screen? When I boot up with the "Mandrake 10.1" option, it shows me this screen with no trouble. It is when it tries to switch to this screen that it tells me that it is out of frequency. I have even tried logging in since it is easy to memorize the steps, and it worked, meaning that I heard the KDE starting "music," but the monitor never came on.

I switched things back to 1280X1024, so that is what most things say in that file. In the part that specifically names my monitor, there is no resolution, but the HorizSync is 30-70, and the VertRefresh is 50-150. Using the menu on the monitor, it says that the H is currently 64.3 KHz and the V is 60.3 Hz.

The monitor part of the file looks like this:

Section "Monitor"
Identifier "monitor1"
VendorName "MAG Technology Co., Ltd."
ModelName "MAG 770V"
HorizSync 30.0-70.0
VertRefresh 50.0-150.0

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# Dell D800 and few Inspiron (16/10) 1280x800
ModeLine "1280x800" 147.89 1280 1376 1512 1744 800 801 804 848

# Dell D800 and few Inspiron (16/10) 1680x1050
ModeLine "1680x1050" 214.51 1680 1800 1984 2288 1050 1051 1054 1103

# Dell D800 and few Inspiron (16/10) 1920x1200
ModeLine "1920x1200" 230 1920 1936 2096 2528 1200 1201 1204 1250 +HSync +VSync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

If it helps at all, my video card is an integrated Radeon 9100. It is rather old now. As far as videos go, it seems to do what it is supposed to do. There are certain videos that my Linux cannot play, but Windows plays them with no troubles. And the most important thing is that I can play 3d Pong on Windows.

Anyway, I am sorry to be a bother.

Thank you,

Petrov Labitzke
 
Old 03-25-2005, 04:41 PM   #6
RySk8er30
Member
 
Registered: Jul 2004
Location: Buffalo, NY
Distribution: Mandriva 2005LE
Posts: 274

Rep: Reputation: 30
Edit your /etc/lilo.conf file. Remove the line...

vga=XXX

Try that out...
 
Old 03-25-2005, 05:50 PM   #7
Petrov Labitzke
LQ Newbie
 
Registered: Mar 2005
Location: Santiago de Chile
Distribution: Mandrake 10.1 PowerPack
Posts: 17

Original Poster
Rep: Reputation: 0
It said vga=755. I got rid of it, and it did the same thing. I then tried deleting the "splash=silent" at the end so that the first two options looked identical. Unfortunately, it went out of range before getting to the login screen. There must be something about the way that the graphical interface is set up, but why would it only do it on the regular option? It is very possible that my video card cannot handle the framebuffer.
 
Old 03-28-2005, 08:52 AM   #8
RySk8er30
Member
 
Registered: Jul 2004
Location: Buffalo, NY
Distribution: Mandriva 2005LE
Posts: 274

Rep: Reputation: 30
I did some further research...

Try editing the /etc/lilo.conf file again and insert this line...

vga=normal

Let me know if it works...

Ryan
 
Old 03-28-2005, 11:20 PM   #9
Petrov Labitzke
LQ Newbie
 
Registered: Mar 2005
Location: Santiago de Chile
Distribution: Mandrake 10.1 PowerPack
Posts: 17

Original Poster
Rep: Reputation: 0
Yeah, I still have the same thing. Sorry.
 
Old 03-29-2005, 07:10 AM   #10
RySk8er30
Member
 
Registered: Jul 2004
Location: Buffalo, NY
Distribution: Mandriva 2005LE
Posts: 274

Rep: Reputation: 30
After you edited your lilo.conf did you run lilo? To run lilo do the following:

1. Open a shell
2. Log in as superuser (su)
3. Run the command "lilo" (no quotes)

Ryan
 
Old 03-29-2005, 12:06 PM   #11
Petrov Labitzke
LQ Newbie
 
Registered: Mar 2005
Location: Santiago de Chile
Distribution: Mandrake 10.1 PowerPack
Posts: 17

Original Poster
Rep: Reputation: 0
In fact I did not. I read that it said to do that, but I assume that it meant that I should restart the computer and run Lilo that way. I will not be able to mess with it for a while because I am at work where we use Apples. When I get home, I will give it a try.

Thank you.
 
Old 03-29-2005, 08:33 PM   #12
Petrov Labitzke
LQ Newbie
 
Registered: Mar 2005
Location: Santiago de Chile
Distribution: Mandrake 10.1 PowerPack
Posts: 17

Original Poster
Rep: Reputation: 0
Success! Thank you much. It seems to look and work just like the linux non-fb option, but I am glad that it now works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
trouble booting zlyoga Linux - Newbie 6 12-19-2004 01:45 PM
Trouble Booting newguy1 Linux - Newbie 7 05-19-2004 07:32 PM
Trouble booting! =( Jephrey Linux - Software 1 10-12-2003 12:19 PM
Trouble booting from CD AshleyK Linux - Hardware 9 09-25-2003 09:41 AM
Trouble Booting! islandkid Linux - Software 2 03-14-2002 01:38 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 11:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration