LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Tried to delete file as root but it says I don't have permission to delete it! (https://www.linuxquestions.org/questions/mandriva-30/tried-to-delete-file-as-root-but-it-says-i-dont-have-permission-to-delete-it-156155/)

beejayzed 03-11-2004 03:41 AM

rm -f doesn't work, it says I don't have permission.

bigearsbilly 03-11-2004 04:03 AM

do an "ls -l"
on it, let's see what it is

bigearsbilly 03-11-2004 04:04 AM

do "mount", make sure it's not on a read only file system

billy

beejayzed 03-11-2004 04:10 AM

Sorry, I'm posting this message in Windows. Do you know hwo to boot in single user mode. I think the file is a symlink gone bad. It says the date is 1997!

whansard 03-11-2004 04:13 AM

telinit S
at prompt goes to single user.

beejayzed 03-11-2004 04:28 AM

I tried deleting it in single user mode. It still says permission denied! :cry:

beejayzed 03-11-2004 02:41 PM

Okay I did ls -l libpcap.so.0 and it says I don't have permission.

whansard 03-11-2004 06:09 PM

what type of filesystem is it? maybe the filesystem is a little corrupt.

bigearsbilly 03-12-2004 02:46 AM

sounds like jiggered up permissions likely.
where is it?


are you logged in as root?
do you have rwx permissions on the directories?
can you 'cd' to the directory it's in?
can you then do an 'ls' ?

billy


billy


All times are GMT -5. The time now is 10:49 AM.