LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 10-06-2003, 07:50 AM   #1
neophyte
LQ Newbie
 
Registered: Oct 2003
Location: USA
Distribution: got them all off my disk
Posts: 4

Rep: Reputation: 0
Question System sounds but no sound from CD player


I know this topic is not a new one, and I have read a lot of the threads already dealing with this problem --and still I can't resolve it.

Just recently installed Mandrake 9.1, so I'm a newbie, but I'm determined to solve this problem.... with some help.

I can hear little system sounds when windows open, but that's about all the sound I ever get. Here's what I've done so far:

Checked aumix, all @ 100 except mic
Checked vol control, all @ max except bass, treble, and mic
Checked inside the PC, and yes there is a little gray cable connected between the CD player and my sound card.
If I put an audio CD in the the drive, and then bring up Multimedia, Sound, CD Player; I can see the title of the first tune. If I click on Play, the seconds timer starts running and the light on the player is on ---as if it is playing the CD. However, there isn't a hint of any sound from the speakers (even with manual vol wide open).

(Incidently, my player works fine when the machine is booted in MS XP Pro. This is a dual-boot machine.)

Here is the result of a "lspci":
00:00.0 Host bridge: Intel Corp. 82850 850 (Tehama) Chipset Host Bridge (MCH) (rev 02)
00:01.0 PCI bridge: Intel Corp. 82850 850 (Tehama) Chipset AGP Bridge (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB PCI Bridge (rev 02)
00:1f.0 ISA bridge: Intel Corp. 82801BA ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801BA IDE U100 (rev 02)
00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #1) (rev 02)
00:1f.3 SMBus: Intel Corp. 82801BA/BAM SMBus (rev 02)
00:1f.4 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #2) (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400]
(rev a1)
02:09.0 Ethernet controller: National Semiconductor Corporation DP83815 (MacPhyter) Ethernet Controller
02:0a.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
02:0a.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 07)
02:0d.0 Communication controller: Conexant HCF 56k Data/Fax/Voice/Spkp Modem (rev 08)

As you can see, my sound card is a SB Live!

Here is the result of a "lsmod":
Module Size Used by Not tainted
lp 8096 0 (autoclean)
sd_mod 13100 0 (autoclean)
snd-seq-midi 5024 0 (autoclean) (unused)
snd-emu10k1-synth 5276 0 (autoclean) (unused)
snd-emux-synth 31644 0 (autoclean) [snd-emu10k1-synth]
snd-seq-midi-emul 6780 0 (autoclean) [snd-emux-synth]
snd-seq-virmidi 4572 0 (autoclean) [snd-emux-synth]
snd-seq-oss 31104 0 (unused)
snd-seq-midi-event 5640 0 [snd-seq-midi snd-seq-virmidi snd-seq-oss]
snd-seq 42608 2 [snd-seq-midi snd-emux-synth snd-seq-midi-emul snd-seq-virmidi snd-seq-oss snd-seq-midi-event]
snd-pcm-oss 43556 0
snd-mixer-oss 14488 0 [snd-pcm-oss]
snd-emu10k1 69268 0 [snd-emu10k1-synth]
snd-rawmidi 17600 0 [snd-seq-midi snd-seq-virmidi snd-emu10k1]
snd-pcm 77536 0 [snd-pcm-oss snd-emu10k1]
snd-timer 18376 0 [snd-seq snd-pcm]
snd-page-alloc 7732 0 [snd-emu10k1 snd-pcm]
snd-util-mem 3008 0 [snd-emux-synth snd-emu10k1]
snd-ac97-codec 40160 0 [snd-emu10k1]
snd-seq-device 5832 0 [snd-seq-midi snd-emu10k1-synth snd-emux-synth snd-seq-oss snd-seq snd-emu10k1 snd-rawmidi]
snd-hwdep 6368 0 [snd-emu10k1]
snd 40868 0 [snd-seq-midi snd-emux-synth snd-seq-virmidi snd-seq-oss snd-seq-midi-event snd-seq snd-pcm-oss snd-mixer-oss snd-emu10k1 snd-rawmidi snd-pcm snd-timer snd-util-mem snd-ac97-codec snd-seq-device snd-hwdep]
soundcore 6276 0 [snd]
af_packet 14952 1 (autoclean)
sr_mod 16920 0 (autoclean)
floppy 55132 0
natsemi 18752 1 (autoclean)
nls_iso8859-1 3516 1 (autoclean)
ntfs 76812 1 (autoclean)
supermount 15296 4 (autoclean)
ide-cd 33856 0
cdrom 31648 0 [sr_mod ide-cd]
ide-scsi 11280 0
parport_pc 25096 2 (autoclean)
ppa 10648 0 (unused)
scsi_mod 103284 4 [sd_mod sr_mod ide-scsi ppa]
parport 34176 2 [lp parport_pc ppa]
usb-uhci 24652 0 (unused)
usbcore 72992 1 [usb-uhci]
rtc 8060 0 (autoclean)
ext3 59916 2
jbd 38972 2 [ext3]

What should I do next to resolve this problem? I've installed Mdk 9.1 twice, and got the same results both times. Help would be appreciated. Tnx.
 
Old 10-06-2003, 09:38 AM   #2
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Is there an Options or Preferences menu on the CD Player? The only thing I can think of is that the CD Player program itself is using the wrong output plugin (this sometimes happens with XMMS, but I never use the standalone CD Player under either GNOME or KDE), so I don't know how it sets its output, and I'm not in MDK right now, so I can't check).

You could also try playing the CD in XMMS or other media player, to see if it works there.

Hope this helps-- it must be really annoying for you .
 
Old 10-06-2003, 09:54 AM   #3
neophyte
LQ Newbie
 
Registered: Oct 2003
Location: USA
Distribution: got them all off my disk
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by motub
Is there an Options or Preferences menu on the CD Player? The only thing I can think of is that the CD Player program itself is using the wrong output plugin (this sometimes happens with XMMS, but I never use the standalone CD Player under either GNOME or KDE), so I don't know how it sets its output, and I'm not in MDK right now, so I can't check).

You could also try playing the CD in XMMS or other media player, to see if it works there.

Hope this helps-- it must be really annoying for you .
Well, yes there are some Preferences, and I checked them and they seem to be okay. Speaker Vol is set to max, etc.

I tried XMMS, but I don't see the play list in it, nor does it try to play the CD. I'm not sure how to point XMMS at my CD drive.

I tried Grip, and it acts the same way as CD Player. It sees the play list, spins the CD (as if playing), but no sound.
 
Old 10-06-2003, 10:31 AM   #4
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
XMMS playlist isn't shown by default, but if you're familiar with Winamp 2, you can guess how to display it. Right-click on the main window, and you should find Playlist Editor in the menu; click on it to show it.

OK, this is stupid, and I know you checked your mixer, but the really last only thing I can think of is--- could the mixer's CD channel have "Mute" enabled? Check the Volume control (is this KDE or GNOME or some other WM?) and confirm that the "Mute" setting is unchecked (it's either a button below the channel settings next to or above "Record", or it may be in a menu along the top).

Other than that, is it possible that the little gray cable is loose or mis-plugged? Or that the volume wheel on the CD itself is turned down to 0? I don't know if that would make any difference, but since the issue is that sound works, but CDs can't be heard, I've gotta think that it's the CD itself or the CD channel in the mixer. If you didn't have the capacity to play CDs, the programs you used to play them would error out, hang the machine or crash outright.

At least that's my experience.

Only other test I can think of is-- do sounds other than system sounds play correctly, such as sound and music in games, and mp3 or ogg files? If you're using MDK, you probably have Frozen Bubble installed. Fire it up and see if you hear the music playing at the menu screen. If not, then we can triangulate the problem at being either the sound server or the wrong drivers for your sound card. Either of which would seem to be the kind of thing that would give you a visible error, but.... any port in a storm
 
Old 10-06-2003, 10:54 AM   #5
neophyte
LQ Newbie
 
Registered: Oct 2003
Location: USA
Distribution: got them all off my disk
Posts: 4

Original Poster
Rep: Reputation: 0
I just now booted up Mdk Linux, to look at the things you suggested.... and took a giant step backwards.

Now, I don't hear ANY of the little system sounds.

I had never been in Frozen Bubble, so started it up, and played a game, and never heard a thing out of the speakers.

The gray cable is attached at both ends, snd card and player, and I was just playing a CD when I was running Windows XP.

I don't have any more time right now to mess with this.

Perhaps getting this problem resolved is not within my capability.

Thanks anyway....
 
Old 10-06-2003, 03:54 PM   #6
courtrrb
Member
 
Registered: Sep 2003
Location: Iowa, US
Distribution: MDK Since V6.5
Posts: 571

Rep: Reputation: 30
You could go into MCC and try changing the sb live driver. I've had this happen on 1 of my systems. ( I have 4 of them with same hw are so you would think) Remember not all sound blasters are made the same and from the same manufacture.
 
Old 10-06-2003, 05:06 PM   #7
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Yes, that would have been my next suggestion as well.

In the case that you don't know how:

Open the Mandrake Control Center, go to Hard Drake (sorry, not in Mandy at the moment, but what you're looking for is essentially the Device Manager, so follow your way to wherever the hardware-related tools are) and select the sound card. The properties should tell you if there is more than one driver available for it, if so, use the "Run config tool" button to start draksound and then use either the drop down menu to choose the other driver, or use the "let me choose any driver" button to choose the other named driver manually.

You shouldn't have to reboot, but you probably would need to stop and start the sound daemon for whichever DE you're using (artsd if KDE, esd if GNOME)--- hey.

Are you using GNOME? I'm thinking that the reason the system sounds are gone is possibly because you don't have esd enabled at startup (this may also hold true for KDE, but I use KDE very rarely, so I don't know how to work with artsd, but I'm pretty sure it's on by default, unlike esd).

Anyway, if you do use GNOME, you might want to go to the GNOME control panel sound utility (Main menu=>Configuration=>Gnome=>Gnome Control Panel=>sound) and check the "enable sound server at startup" checkbox. I think that if checking that doesn't start esd then you can type 'start esd' or 'esd' in a terminal to actually start it for this session, or you could just reboot. In any case, if you also checked the "enable system sounds" at least your little system sound effects should be back.

In fact, do one of these things at a time. First enable esd. If that doesn't get you system sounds and Frozen Bubble music, then change the sound card drivers. If it does get you system sounds and Frozen Bubble music and sound effects, but still no CD music, please post which driver Hard Drake is listing as the one in use for the SB live, but don't change it yet. One step at a time. .
 
Old 01-22-2004, 10:01 PM   #8
Boneglorious
LQ Newbie
 
Registered: Jan 2004
Distribution: Mandrake 10.0, Debian 3.0
Posts: 14

Rep: Reputation: 0
problem resolved?

Neophyte--

Did you ever resolve this problem? If so, please share your solution, because my problem is similar.

I'm using RH9 with KDE, and when I play games, the sound is fine. However, I can't play a CD using either GRIP or XMMS. It appears to be playing, tells me the volume is turned up, etc., but there's no sound.

When I do soundcard detection, the test sound plays.

I originally ran Windows XP, and had no problems hearing CDs.

The aRTs sound server is enabled at startup, but whether it is or not seems to have no effect on which sounds I hear.

My sound card is via82cxxx_audio from VIA Tech. The driver I'm using is one that came with RH9, because the drivers that came with the sound card are all for Windows. I don't think the driver is at fault though, because it seems like if that were the case, the test sound would not play.

Thanks for any help you can provide. (I'm very new to Linux and setting up computers, so I can't even think of things to try.)

--Boneglorious

Last edited by Boneglorious; 01-22-2004 at 10:25 PM.
 
Old 03-09-2004, 08:34 PM   #9
Boneglorious
LQ Newbie
 
Registered: Jan 2004
Distribution: Mandrake 10.0, Debian 3.0
Posts: 14

Rep: Reputation: 0
Just to give an idea to anyone who has an similar problem, and happens to stumble on this: one possible cause is an improperly installed or missing cable. There should be a special four-pin cable connecting the CD drive to the sound card in order to play audio CDs. It seems not to matter which way you insert the connectors.

An interesting (and misleading) point is that some audio-playing programs bypass this hardware solution in favor of some software solution. For example, as I stated above, I had no problem playing CDs in XP. I was using Windows Media Player, which uses the software solution, leading me to believe I had all of the necessary hardware set up correctly.

This possible cause is actually the only one I know of so far that can cause this problem, once the obvious (CD volume, no appropriate media player, etc) is exhausted. Obviously, I'll keep my eyes open and post updates should I learn anything new in the future.

I hope this helps someone (Well, actually I hope someone at least reads it since this is the first time I've been able to post a solution instead of a problem.) (And now I'm done rambling essentially to myself, since probably no one will ever read this and I won't know if they do anyway.) (Hello out there!)

Last edited by Boneglorious; 03-09-2004 at 08:39 PM.
 
Old 03-10-2004, 02:22 AM   #10
beejayzed
Member
 
Registered: Jan 2004
Location: Auckland, New Zealand
Distribution: Ubuntu
Posts: 686

Rep: Reputation: 30
To check if that is the problem, try pluging your speakers into the cdrom and see if you can play cds.
 
Old 03-12-2004, 10:25 AM   #11
jamesgf
Member
 
Registered: Apr 2003
Location: madison wi
Posts: 38

Rep: Reputation: 15
hi all-

I have the same problem on my 9.1 system. Im running KDE, ALSA, with an SBlive. All system sounds work, games work, MP3s play fine. Ive tried everything suggested here to get CDs to play with no luck. I have 2 drives, a DVD rom and a CD writer, both connected to the sound card via the analog cables. Both will play CDs under winXP but no dice in 9.1.

any other ideas?

thanks,
-j
 
Old 03-12-2004, 02:40 PM   #12
beejayzed
Member
 
Registered: Jan 2004
Location: Auckland, New Zealand
Distribution: Ubuntu
Posts: 686

Rep: Reputation: 30
See if you can hear anything if you plug the speakers into the cdrom.
 
Old 04-27-2004, 12:35 PM   #13
fractalgarden
LQ Newbie
 
Registered: Apr 2004
Location: London, UK
Distribution: SuSE 9 Pro
Posts: 1

Rep: Reputation: 0
An old topic I know but I was looking for answers to my own CD problems and came up with this thread when I did a search. I had exactly the same problems as many of the posters - could hear system sounds and play mp3s but I couldn't hear CDs even though the player said the track was playing. I finally resolved the problem by rechecking all my settings in KAMix and discovered that Aux was muted (external source playback tab). One very redfaced newbie! So for anyone still having problems see if that helps to resolves things.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Have system sounds but no cd music sound cwhh Debian 2 11-24-2005 04:54 AM
Have system sounds but no cd music sound cwhh Linux - Newbie 2 11-24-2005 04:53 AM
Have system sounds but no cd music sound cwhh Linux - General 1 11-23-2005 10:13 PM
Basic System Sounds but no CD Player philipogletree Linux - Hardware 6 10-30-2005 07:12 PM
No system sounds in KDE, but sound from amaroK BuckRogers01 Linux - Software 3 09-11-2005 02:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 08:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration